f26-blocker-review
MINUTES

#fedora-blocker-review: F26-blocker-review

Meeting started by roshi at 16:06:13 UTC (full logs).

Meeting summary

  1. Roll Call (roshi, 16:06:14)
  2. Introduction (roshi, 16:08:59)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (roshi, 16:08:59)
    2. We'll be following the process outlined at: (roshi, 16:09:03)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (roshi, 16:09:05)
    4. The bugs up for review today are available at: (roshi, 16:09:08)
    5. http://qa.fedoraproject.org/blockerbugs/current (roshi, 16:09:10)
    6. The criteria for release blocking bugs can be found at: (roshi, 16:09:13)
    7. https://fedoraproject.org/wiki/Fedora_26_Alpha_Release_Criteria (roshi, 16:09:15)
    8. https://fedoraproject.org/wiki/Fedora_26_Beta_Release_Criteria (roshi, 16:09:18)
    9. https://fedoraproject.org/wiki/Fedora_26_Final_Release_Criteria (roshi, 16:09:21)

  3. (1467164) 26 Final RC-1.3 compose is missing 'custodia' package (roshi, 16:11:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1467164 (roshi, 16:11:31)
    2. Proposed Blocker, distribution, NEW (roshi, 16:11:33)
    3. AGREED: - RHBZ#1467164 - AcceptedBlocker - This bug is a clear violation of the following criterion: "Release-blocking roles and the supported role configuration interfaces must meet the core functional Role Definition Requirements to the extent that supported roles can be successfully deployed, started, stopped, brought to a working configuration, and queried." (roshi, 16:17:54)

  4. (1467278) gdm prevents user logging in under vesa (roshi, 16:17:59)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1467278 (roshi, 16:18:02)
    2. Proposed Blocker, gdm, NEW (roshi, 16:18:04)
    3. AGREED: - RHBZ#1467278 - RejectedBlocker - Rejecting as a blocker under the same reasoning from Comment #9. (roshi, 16:24:39)

  5. (1467316) kwin and kactivitymanager crash on the first boot of KDE (roshi, 16:25:17)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1467316 (roshi, 16:25:20)
    2. Proposed Blocker, kwin, NEW (roshi, 16:25:23)
    3. AGREED: - RHBZ#1467316 - RejectedBlocker - This bug doesn't clearly violate any criteria, and it doesn't cause any noticeable problems or user-visible notifications of the failure, so is not considered a blocker. (roshi, 16:30:28)

  6. (1467368) totem doesn't work in VMs under Wayland (roshi, 16:31:32)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1467368 (roshi, 16:31:32)
    2. Proposed Blocker, totem, NEW (roshi, 16:31:32)
    3. AGREED: - RHBZ#1467368 - Punt - It's unclear what all configurations are affected by this bug, and we'd like some more information before we determine status. (roshi, 16:46:04)

  7. (1436873) KDE live environment notifies of available updates (roshi, 16:49:12)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1436873 (roshi, 16:49:15)
    2. Accepted Blocker, spin-kickstarts, ON_QA (roshi, 16:49:18)

  8. Open Floor (roshi, 16:53:40)
  9. (1466356) Serial console output is garbled in U-Boot on Raspberry Pi (roshi, 16:54:38)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1466356 (roshi, 16:54:42)
    2. Proposed Freeze Exceptions, bcm283x-firmware, MODIFIED (roshi, 16:54:45)
    3. AGREED: - RHBZ#1466356 - AcceptedFreezeException - It would be good to get a fix for this as RPi is a widely used platform. (roshi, 16:57:32)

  10. (1467355) Docker images are missing from f26 final RC composes (roshi, 16:57:39)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1467355 (roshi, 16:57:42)
    2. Proposed Freeze Exceptions, distribution, NEW (roshi, 16:57:45)
    3. AGREED: - RHBZ#1467355 - AcceptedFreezeException - It would be good to get a fix in for this if the change is non-invasive. (roshi, 17:00:21)

  11. (1467383) Missing workstation ostree installer in F26 RC's (roshi, 17:00:24)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1467383 (roshi, 17:00:26)
    2. Proposed Freeze Exceptions, distribution, NEW (roshi, 17:00:29)
    3. AGREED: - RHBZ#1467383 - AcceptedFreezeException - It'd be good to get this in if possible, to showcase the potential of an Atomic Workstation. (roshi, 17:03:04)

  12. (1467108) Blank transition from an animated png wallpapers (roshi, 17:03:14)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1467108 (roshi, 17:03:14)
    2. Proposed Freeze Exceptions, f26-backgrounds, MODIFIED (roshi, 17:03:14)
    3. AGREED: - RHBZ#1467108 - RejectedFreezeException - Because of the risk to other DEs, we're not going to include this during freeze (especially because this is easily fixed via an update and doesn't impact the default background). (roshi, 17:06:48)

  13. Open Floor (roshi, 17:06:53)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1464843 (adamw, 17:07:22)
    2. https://pagure.io/releng/issue/6836#comment-446781 and https://pagure.io/releng/issue/6836#comment-447049 (adamw, 17:27:52)
    3. https://paste.fedoraproject.org/paste/bLlxk4TcMC4R1wFBP1LRJQ (nirik, 17:32:30)
    4. https://docs.pagure.org/releng/sop_retire_orphaned_packages.html doesn't mention any actual dates/times. (nirik, 17:38:46)
    5. https://koji.fedoraproject.org/koji/taskinfo?taskID=20280394 is the task (adamw, 18:05:03)
    6. https://koji.fedoraproject.org/koji/taskinfo?taskID=20280539 (adamw, 18:06:13)
    7. https://kojipkgs.fedoraproject.org//work/tasks/456/20280456/root.log (adamw, 18:07:14)
    8. AGREED: The blocking of packages with dependency problems - https://pagure.io/releng/issue/6836 - was done far too late (well into Final freeze) and has already caused the RC-1.3 compose to be a failure. We agreed that all the packages blocked as part of that ticket should be unblocked again, and this kind of blocking should never be done without going through the FE/blocker process in future. (adamw, 18:20:15)


Meeting ended at 18:30:40 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (192)
  2. roshi (168)
  3. mattdm (83)
  4. nirik (66)
  5. mboddu (50)
  6. tenk (18)
  7. zodbot (13)
  8. kparal (3)
  9. satellit (2)


Generated by MeetBot 0.1.4.