f26-blocker-review
LOGS
16:00:23 <roshi> #startmeeting F26-blocker-review
16:00:23 <zodbot> Meeting started Mon May 22 16:00:23 2017 UTC.  The chair is roshi. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:23 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:23 <zodbot> The meeting name has been set to 'f26-blocker-review'
16:00:23 <roshi> #meetingname F26-blocker-review
16:00:23 <zodbot> The meeting name has been set to 'f26-blocker-review'
16:00:23 <roshi> #topic Roll Call
16:00:33 * pschindl is here
16:00:39 <roshi> who's around for some blocker funtimes?
16:00:42 <jkurik> .hello jkurik
16:00:43 <zodbot> jkurik: jkurik 'Jan Kurik' <jkurik@redhat.com>
16:00:53 * jkurik is available for approx. 1 hour
16:01:04 <roshi> welcome pschindl and jkurik :)
16:01:08 <sgallagh> .hello sgallagh
16:01:09 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
16:01:45 <roshi> #chair jkurik pschindl sgallagh adamw kparal
16:01:45 <zodbot> Current chairs: adamw jkurik kparal pschindl roshi sgallagh
16:01:54 * kparal is here
16:02:38 <roshi> seems like we have enough to get started :)
16:02:50 <roshi> #topic Introduction
16:02:50 <roshi> Why are we here?
16:02:51 <roshi> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:02:54 <roshi> #info We'll be following the process outlined at:
16:02:57 <roshi> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:02:59 <roshi> #info The bugs up for review today are available at:
16:03:02 <roshi> #link http://qa.fedoraproject.org/blockerbugs/current
16:03:04 <roshi> #info The criteria for release blocking bugs can be found at:
16:03:07 <roshi> #link https://fedoraproject.org/wiki/Fedora_26_Alpha_Release_Criteria
16:03:10 <roshi> #link https://fedoraproject.org/wiki/Fedora_26_Beta_Release_Criteria
16:03:13 <roshi> #link https://fedoraproject.org/wiki/Fedora_26_Final_Release_Criteria
16:03:35 <roshi> alright, 3 proposals for Beta
16:03:37 <roshi> #topic (1452866) FreeIPA fails to work properly after Fedora 25 - Fedora 26 upgrade, logs show ns-slapd errors
16:03:41 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1452866
16:03:43 <roshi> #info Proposed Blocker, 389-ds-base, NEW
16:05:31 <sgallagh> adamw: This is consistent for all upgrades?
16:06:24 <kparal> if freeipa is part of the default install, I think the upgrade criterion doesn't actually apply
16:06:30 <kparal> *is not
16:06:43 <kparal> as adamw notes in his proposal
16:06:59 <sgallagh> Hmm
16:07:27 <sgallagh> Right, FreeIPA isn't part of the default package set.
16:07:46 <kparal> we can talk whether it should
16:07:50 <kparal> block
16:07:56 <sgallagh> Presumably, one can uninstall and reinstall FreeIPA successfully
16:07:58 <kparal> but I think it's not currently covered
16:08:08 <sgallagh> Since the cause of the issue is the lack of network in the special upgrade boot
16:08:27 <sgallagh> So yeah, I think probably this is -1 with the current criteria, though I'd be strongly +1 FE
16:08:41 <sgallagh> Is there a Final criterion for upgrades?
16:08:54 <sgallagh> I'd be somewhat more likely to vote blocker for Final on this
16:08:57 <roshi> -1 blocker under that logic, and +1 FE
16:08:59 <kparal> nothing extra from beta, I think
16:09:41 <sgallagh> This is a really lousy bug though.
16:09:47 <roshi> yeah
16:09:55 * sgallagh will propose it for the Prioritized Bugs list
16:09:58 <roshi> can always propose a criteria change
16:10:07 <kparal> actually I might revert my opinion
16:10:13 <roshi> I mean, I could see a "Fedora Roles must be upgradable" criterion
16:10:37 <kparal> the upgraded system must meet all criteria. and a criterion for a new install is that freeipa must work
16:10:42 <sgallagh> roshi: Well, we explicitly asked for that not to happen because upgrades were touchy when we first started the role plans.
16:10:43 <kparal> so the upgraded system should also meet that
16:10:49 <sgallagh> And now we're looking at replacing them.
16:10:56 <roshi> eventually that'd be a goal though, right?
16:11:05 <sgallagh> kparal: No, the criterion is that it must be possible to deploy a FreeIPA role that works.
16:11:08 <roshi> if you asked for it not to be, seems a clear -1
16:11:34 <sgallagh> roshi: Well, the fact that we didn't amend it once upgrades started to mostly work is ambiguous :)
16:11:41 <kparal> the default package set talks about what we're upgrading, but doesn't necesarilly mean that other criteria outside of the set no longer apply
16:11:41 <roshi> lol
16:11:47 <pschindl> I'm -1 blocker and +1 FE for now too.
16:12:06 * roshi gives kparal time to convince others
16:12:23 <kparal> so if a new install must be able to deploy a working freeipa role, the upgraded default system must also be able to do that
16:12:28 <kparal> does that make sense?
16:12:35 <sgallagh> kparal: I don't think this is quite serious enough to block Beta, but I'd almost certainly vote +1 blocker on Final if it were to be re-proposed after Beta ships...
16:12:51 <roshi> the upgraded one can *deploy* one, just not upgrade the previous deployment, aiui
16:12:54 <kparal> sure, punt to Final since it's not that serious
16:13:16 <kparal> hm
16:13:19 <kparal> words :)
16:13:31 <jkurik> I am +1 to block on final and +1 to make it FE for beta
16:13:32 <sgallagh> I'll phrase it
16:14:04 <kparal> jkurik++
16:14:04 <zodbot> kparal: Karma for jkurik changed to 5 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:14:19 <kparal> that actually meant I support his proposal :)
16:14:44 <kparal> I wonder...
16:14:47 <kparal> jkurik--
16:14:50 <roshi> proposed #agreed - RHBZ#1452866 - RejectedBlocker (Beta) AcceptedFreezeException - This bug doesn't actually violate the upgrade criterion. However, it's a nasty bug that we'd consider a FE for fixing. Please repropose for Final, as if this doesn't get fixed before then we'd want to re-evaulate.
16:15:12 <roshi> that get everything in there?
16:15:12 <sgallagh> roshi: I'd s/actually/strictly/
16:15:51 <kparal> can the secretary, whoever that it, immediately repropose to Final so that it's not forgotten?
16:16:16 <roshi> proposed #agreed - RHBZ#1452866 - RejectedBlocker (Beta) AcceptedFreezeException - This bug doesn't strictly violate the upgrade criterion. However, it's a nasty bug that we'd consider a FE for fixing. Please repropose for Final, as if this doesn't get fixed before then we'd want to re-evaulate.
16:16:23 <pschindl> ack
16:16:24 <sgallagh> ack
16:16:30 <jkurik> ack
16:17:01 <kparal> ack
16:17:02 <pschindl> I can do the secretary work, but I'm not sure, if I'll be here to the end.
16:17:12 <kparal> pschindl++
16:17:12 <zodbot> kparal: Karma for pschindl changed to 1 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:17:15 <roshi> thanks pschindl
16:17:24 <roshi> let me know which ones you don't get and I'll finish up
16:17:35 <pschindl> roshi: ok.
16:17:59 <roshi> #agreed - RHBZ#1452866 - RejectedBlocker (Beta) AcceptedFreezeException - This bug doesn't strictly violate the upgrade criterion. However, it's a nasty bug that we'd consider a FE for fixing. Please repropose for Final, as if this doesn't get fixed before then we'd want to re-evaulate.
16:18:09 <roshi> #topic (1451630) anaconda does not fall back to text mode for non-graphical systems
16:18:13 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1451630
16:18:15 <roshi> #info Proposed Blocker, anaconda, NEW
16:19:29 <roshi> I'm -1 on this based on comment #6
16:19:39 <sgallagh> This one is kind of ambiguous.
16:20:13 <sgallagh> It's definitely -1 if it is only happening on a non-blocking medium though
16:20:14 <kparal> needs clarification, either punt or -1 and repropose if needed
16:20:24 <sgallagh> But if it turns up on a blocking arch, we should revisit
16:21:06 <pschindl> -1 for now.
16:21:06 <roshi> I'd punt and see about other arches
16:21:17 <roshi> votes to punt?
16:21:25 <roshi> it'll get re-looked at on Thursday
16:21:27 <sgallagh> proposed #agreed RejectedBlockerBeta Right now, this issue is only reported on non-blocking architectures. Please re-propose if it can be reproduced on a blocking install medium.
16:21:30 <roshi> (Go/No-Go meeting)
16:21:43 <roshi> ack
16:21:46 * roshi is fine with that
16:21:54 <jkurik> ack
16:21:57 <sgallagh> Actually, that's not in the right format, but I'll let roshi fix it
16:21:58 <roshi> I didn't know there was a fallback either until this bug
16:22:11 <roshi> gonna make me type all that? jeez man
16:22:12 <roshi> :p
16:22:28 <sgallagh> roshi: You *do* know about copy-paste, right?
16:22:54 <kparal> never heard of that never heard of that never heard of that never heard of that never heard of that never heard of that never heard of that never heard of that never heard of that never heard of that never heard of that never heard of that never heard of that
16:23:09 <roshi> proposed #agreed - RHBZ#1451630 - RejectedBlocker - Right now this issue is only reported on non-blocking architectures. Please re-propose if it can be reproduced on a blocking install medium.
16:23:19 <kparal> ack
16:23:25 <roshi> yeah, but the line breaks in irssi mean I need to clean it up *anyways*
16:23:34 <sgallagh> kparal: It would be funnier if you recorded yourself typing all of that by hand
16:23:36 <roshi> I paste into, but rarely from irc
16:23:41 <roshi> lol
16:23:42 <jkurik> ack
16:23:56 <roshi> #agreed - RHBZ#1451630 - RejectedBlocker - Right now this issue is only reported on non-blocking architectures. Please re-propose if it can be reproduced on a blocking install medium.
16:24:05 <roshi> #topic (1451754) Software selection checkbox stays unchecked
16:24:05 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1451754
16:24:05 <roshi> #info Proposed Blocker, anaconda, MODIFIED
16:25:28 <jkurik> +1 FE Beta, +1 Blocker final.
16:25:53 <roshi> same
16:25:54 <sgallagh> Same, +1 FE Beta, +1 Blocker final
16:25:55 <kparal> same
16:26:15 <pschindl> same
16:27:00 <sgallagh> I dislike making that call subjectively, but I think this is one of those times that intuition supersedes the strict reading of the rules
16:27:51 <jkurik> sgallagh: yes, at least for me :)
16:27:52 <roshi> proposed #agreed - RHBZ#1451754 - AcceptedFreezeException (Beta) RejectedBlocker (Beta) AcceptedBlocker (Final) - We'd like to get this fixed for Beta, but are not willing to block Beta on polish (since it does *work*), but we would block for Final release.
16:28:19 <pschindl> ack
16:28:21 <jkurik> ack
16:28:38 <sgallagh> ack
16:28:52 <roshi> #agreed - RHBZ#1451754 - AcceptedFreezeException (Beta) RejectedBlocker (Beta) AcceptedBlocker (Final) - We'd like to get this fixed for Beta, but are not willing to block Beta on polish (since it does *work*), but we would block for Final release.
16:29:01 <roshi> that's it for blocker proposals for Beta
16:29:09 <roshi> #info moving onto the FE proposals
16:29:29 <roshi> we've got 5 to look at
16:29:29 <roshi> #topic (1452415) Updated f26-backgrounds for beta release
16:29:29 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1452415
16:29:30 <roshi> #info Proposed Freeze Exceptions, f26-backgrounds, NEW
16:29:36 <sgallagh> Hang on
16:29:48 <sgallagh> There's one more possible Beta blocker to discuss (not on the list yet)
16:29:56 <sgallagh> But it was raised to the QA list about an hour ago
16:30:06 <sgallagh> I asked mcatanzaro to stop in and discuss it with us
16:30:10 <roshi> ah
16:30:11 <roshi> #undo
16:30:11 <zodbot> Removing item from minutes: INFO by roshi at 16:29:30 : Proposed Freeze Exceptions, f26-backgrounds, NEW
16:30:14 <roshi> #undo
16:30:14 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x1a2156d0>
16:30:18 <roshi> #undo
16:30:18 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x19b831d0>
16:30:50 <roshi> bz id?
16:31:00 <roshi> sgallagh: want to set the topic and whatnot?
16:31:04 <sgallagh> .bug 1449752
16:31:04 <zodbot> sgallagh: Bug 1449752 – blivet-gui desktop file should not be installed by default in Fedora Workstation - https://bugzilla.redhat.com/1449752
16:32:00 <kparal> we might need to finish the discussion on test list first
16:32:04 * kparal just replied
16:32:14 <mcatanzaro> Hi
16:32:19 <sgallagh> Well, sometimes it's useful to have a more interactive discussion, but I'll bow to the will of the council
16:32:32 <kparal> currently there's no criterion to block this on, correct?
16:32:34 <mcatanzaro> We discussed this at the Workstation WG meeting today.
16:33:13 <mcatanzaro> "All applications installed by default in Fedora Workstation must comply with each MUST and MUST NOT guideline in the Applications and Launchers policy."
16:33:15 <roshi> it doesn't violate a criterion, and we already do it with anaconda
16:33:25 * roshi thought it was great that it was installed already
16:33:32 <roshi> I honestly thought it was a feature
16:33:42 <mcatanzaro> We approved a modification to the applications and launchers policy: "App launchers installed by default must be approved by the Workstation WG."
16:34:30 <sgallagh> mcatanzaro: I'm actually a little concerned by that, because its inclusion on that page feels a little out of place.
16:34:45 <kparal> if it's already approved, we can block
16:34:47 <sgallagh> Better would be to simply cite the aspect of those guidelines that Blivet-GUI fails to meet and that should be a blocker
16:35:01 <roshi> there should also be something where QA gets notified of changes - I didn't see anything
16:35:05 <mcatanzaro> Anyway, I'm supposed to ask for feedback from QA before adding that text to the policy page. I guess that's you all. It is sort of out of place, indeed.
16:35:07 <roshi> (but I could have just missed it)
16:35:15 <kparal> mcatanzaro: it's not on the wiki yet
16:35:18 <sgallagh> mcatanzaro: Right, but it also might not be necessary
16:35:35 <mcatanzaro> The problem is that blivet-gui does not violate any of the current guidelines there, I don't think.
16:35:45 <sgallagh> ah
16:35:51 <mcatanzaro> We don't have any guideline that says "must be a nice-looking GNOME-style app"
16:35:58 <kparal> sgallagh: they just want to be able to pick which apps go in there and which do not
16:36:04 <roshi> so the WG just doesn't want this
16:36:04 <sgallagh> Right
16:36:04 <kparal> which is fine by me
16:36:20 <roshi> -1 blocker for Beta, +? for Final once the discussion is resolved
16:36:25 <kparal> but as I said in the test list, workstation wg will probably need to police that themselves
16:36:27 <kparal> we'll just block
16:36:37 <mcatanzaro> Of course we'll police default apps ourselves.
16:36:45 <kparal> ok
16:36:46 * sgallagh nods
16:36:57 <mcatanzaro> And yes, this would be a Final blocker, we don't want a Beta blocker as we want Beta to be released. ;)
16:37:04 <roshi> ok
16:37:15 * roshi thought this was a beta proposal from sgallagh
16:37:16 <sgallagh> I think this is firmly within the spirit of what the Edition WGs are for and that regardless of that FESCo decision I can't find, we should honor that
16:37:27 <kparal> +1 final
16:37:32 <sgallagh> No, I just wanted it discussed before we jumped over to FE bugs.
16:37:42 <sgallagh> +1 Final Blocker
16:37:52 <sgallagh> Sorry if that was unclear
16:37:58 <mcatanzaro> Larger question is: should we add this text to our applications and launchers guidelines? Or add a completely new blocker criterion? Or change nothing and rely on the power granted to us by the FESCo decision that maybe exists somewhere in the past? :)
16:38:25 <roshi> #topic (1452415) Updated f26-backgrounds for beta release
16:38:25 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1452415
16:38:28 <kparal> mcatanzaro: first or third, I think
16:38:30 <roshi> damnit
16:38:32 <roshi> #undo
16:38:32 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x202e4350>
16:38:36 <roshi> #undo
16:38:36 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x202e4490>
16:38:44 * roshi misclicked the middle mouse...
16:38:58 <kparal> I'd personally add it to the guidelines page
16:38:59 <roshi> sorry for spam
16:39:05 <sgallagh> I think we just correct the text on the Blocker SOP from "The group then decides whether the bug is accepted as a blocker; if not, the group can discuss whether to accept it as a blocker for a later milestone, or accept it as a freeze exception issue instead, or reject it entirely. This decision should be based on the Release Criteria for the release in
16:39:05 <sgallagh> question: no bug should be accepted as a blocker unless it violates the release criteria (or has been designated as a blocker by FESCo)" to include the Edition WGs
16:39:15 <roshi> yeah, so people can see it from the release criteria
16:39:43 * roshi was agreeing with kparal
16:39:44 <mcatanzaro> sgallagh: Works for me. FESCo can always mediate disputes if a WG proposes something objectionable.
16:39:58 * sgallagh nods
16:40:32 <sgallagh> mcatanzaro: Though if we ever see you try to block on font kerning, we'll rethink this ;-)
16:40:49 <roshi> proposed #agreed - RHBZ#1452415 - AcceptedBlocker (Final) - This bug is a violation of the following criterion: "All applications installed by default in Fedora Workstation must comply with each MUST and MUST NOT guideline in the Applications and Launchers policy."
16:41:19 <mcatanzaro> Well, I guess we don't need to use that policy.
16:42:10 <sgallagh> proposed #agreed - RHBZ#1452415 - AcceptedBlocker (Final) - The Workstation WG has voted that this issue is serious enough to warrant blocking their Edition.
16:42:35 <roshi> ack
16:42:46 <mcatanzaro> That's mostly true... technically we voted that new apps should be approved by the WG.
16:42:53 <jkurik> sgallagh: then it needs to be blocked by FESCo, right ?
16:43:01 <mcatanzaro> Well, even that is only mostly true.... :D
16:43:07 * sgallagh sighs
16:43:30 <sgallagh> jkurik: I feel pretty sure we (FESCo) agreed to grant that privilege to the WGs for their particular editions.
16:43:53 <jkurik> sgallagh: ok, I am fine with that
16:43:57 <sgallagh> But if people would prefer that FESCo make the final call on that, we can take it there.
16:44:08 <mcatanzaro> Let's go with sgallagh's proposed agreed and move on. It's close and has the same effect as what we agreed.
16:44:21 <jkurik> sgallagh: I just wanted to be sure how it will work
16:44:30 <sgallagh> jkurik: How what will work?
16:44:46 <jkurik> sgallagh: the blocking
16:44:58 <jkurik> if any ...
16:45:14 <sgallagh> jkurik: Take it to #fedora-qa
16:45:23 <jkurik> lets move on, I understand it now
16:45:39 <roshi> ok
16:45:40 <roshi> can do
16:45:43 <roshi> onto the FEs
16:45:49 <roshi> #topic (1452415) Updated f26-backgrounds for beta release
16:45:50 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1452415
16:45:50 <roshi> #info Proposed Freeze Exceptions, f26-backgrounds, NEW
16:45:58 <roshi> damnit
16:46:00 <roshi> #undo
16:46:00 <zodbot> Removing item from minutes: INFO by roshi at 16:45:50 : Proposed Freeze Exceptions, f26-backgrounds, NEW
16:46:02 <roshi> #undo
16:46:02 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x1d554950>
16:46:03 <roshi> #undo
16:46:03 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x1d554350>
16:46:10 <roshi> sgallagh: gotta do the actual #agreed
16:46:55 <sgallagh> #agreed - RHBZ#1452415 - AcceptedBlocker (Final) - The Workstation WG has voted that this issue is serious enough to warrant blocking their Edition
16:47:23 <roshi> thanks
16:47:24 <roshi> V
16:47:26 <roshi> #topic (1452415) Updated f26-backgrounds for beta release
16:47:27 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1452415
16:47:27 <roshi> #info Proposed Freeze Exceptions, f26-backgrounds, NEW
16:47:37 <kparal> +1 fe
16:47:43 <jkurik> I am +1 FE
16:47:44 <roshi> +1
16:48:10 <pschindl> roshi: there is a wrong number of bug in previous agree. But I guess that it's not a problem
16:48:24 <sgallagh> oops
16:48:36 <roshi> yeah, I just noticed that too
16:48:45 <roshi> but I'm not going to do more #undos for that :p
16:48:48 <sgallagh> hahaha
16:48:55 <roshi> normally I would - but not today!
16:49:00 <sgallagh> I was +1 FE in the BZ, as was stickster
16:49:06 <pschindl> That would be record :)
16:49:23 <roshi> too many #undo already
16:49:29 * roshi curses his fat fingers
16:49:44 <pschindl> +1 FE
16:49:48 <roshi> proposed #agreed - RHBZ#1452415 - AcceptedFreezeException - We want to get this fixed for beta.
16:50:11 <jkurik> short and clear
16:50:13 <jkurik> ack
16:50:16 <pschindl> ack
16:50:31 <roshi> #agreed - RHBZ#1452415 - AcceptedFreezeException - We want to get this fixed for beta.
16:50:45 <roshi> #topic (1441844) Need dark variant of logo
16:50:45 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1441844
16:50:45 <roshi> #info Proposed Freeze Exceptions, gnome-shell-extension-background-logo, NEW
16:51:21 <dustymabe> .hello dustymabe
16:51:24 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
16:51:31 <dustymabe> sorry went to lunch
16:52:10 <sgallagh> +1 FE
16:52:20 <pschindl> +1 FE
16:52:21 <jkurik> dustymabe: that reminds me it is time for a dinner
16:52:25 <kparal> +1 fe
16:52:26 <jkurik> +1 FE
16:52:42 <roshi> sure +1
16:53:11 <roshi> proposed #agreed - RHBZ#1441844 - AcceptedFreezeException - This would be good to get pulled in for Beta.
16:53:16 <sgallagh> ack
16:53:31 <pschindl> ack
16:53:36 <roshi> #agreed - RHBZ#1441844 - AcceptedFreezeException - This would be good to get pulled in for Beta.
16:53:45 <roshi> #topic (1363918) [abrt] kactivitymanagerd: QXcbConnection::processXcbEvents(): kactivitymanagerd killed by SIGSEGV
16:53:48 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1363918
16:53:50 <roshi> #info Proposed Freeze Exceptions, kwin, NEW
16:55:16 <roshi> we still block on KDE, right?
16:55:33 <jkurik> roshi: yes
16:55:44 <jkurik> afaik
16:56:01 * roshi was just checking - never know what changed that I missed during my haitus
16:56:08 <sgallagh> Yes, but this was proposed as FE
16:56:30 <sgallagh> So far, it's not clear how likely it is to happen
16:56:43 <kparal> +1 fe
16:56:51 <sgallagh> I'm inclined to give it +1 FE
16:56:54 <roshi> +1 FE, with a caveat to repropose if it happens a lot
16:57:02 <sgallagh> roshi: Yes, that
16:57:06 <pschindl> +1 FE
16:57:16 <jkurik> +1 FE
16:57:31 <dustymabe> +1 FE from me
16:57:59 <roshi> proposed #agreed - RHBZ#1363918 - AcceptedFreezeException - It would be good to get this fixed for Beta. However, if it starts to show up in more places, repropose as a blocker and we'll revisit it.
16:58:03 <roshi> that work?
16:58:12 <dustymabe> ack
16:58:30 <roshi> dustymabe: did you bring enough lunch for the whole class?
16:58:34 <roshi> :p
16:58:44 <dustymabe> roshi: yep. and then i ate it all :(
16:58:48 <roshi> lol
16:58:50 <roshi> figures
16:59:02 <roshi> atomic folks (/me shakes his head...)
16:59:10 <roshi> other ack/nack/patch?
16:59:19 <jkurik> ack
16:59:30 <roshi> #agreed - RHBZ#1363918 - AcceptedFreezeException - It would be good to get this fixed for Beta. However, if it starts to show up in more places, repropose as a blocker and we'll revisit it.
16:59:33 <dustymabe> roshi: you are atomic folks :)
16:59:44 <roshi> oh snap
16:59:45 <roshi> :p
16:59:47 <roshi> #topic (1410178) CVE-2016-9941 CVE-2016-9942 libvncserver: various flaws [fedora-all]
16:59:50 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1410178
16:59:52 <roshi> #info Proposed Freeze Exceptions, libvncserver, ON_QA
17:00:07 * roshi wouldn't advertise how low your bar to entry is like that :p
17:00:10 * jkurik has to leave for other duties
17:00:15 <roshi> thanks jkurik!
17:00:19 <roshi> see you Thursday
17:00:28 <jkurik> see you on Go/No-Go :)
17:00:38 <kparal> +1 fe
17:00:55 <sgallagh> Isn't this also a dep of Anaconda?
17:00:57 <roshi> +1
17:01:22 <sgallagh> I'm hesitating
17:01:36 <roshi> pretty sure it is in anaconda
17:01:38 <sgallagh> I don't like changing things out from under critical software during Freeze
17:01:50 <kparal> if it is, maybe even more reason to approve it
17:02:00 <roshi> we don't even have an RC yet
17:02:20 <sgallagh> But it looks like it's a simple backport of the security fixes
17:02:27 * roshi isn't worried about pulling in security fixes
17:02:27 <sgallagh> I was mostly concerned if it was a rebase
17:02:40 <sgallagh> So I wanted to look into it before approving
17:03:21 <sgallagh> Remember, we only should ideally be approving FEs that don't risk causing other issues.
17:03:29 <sgallagh> But I think we're good in this case. +1 FE
17:03:46 <roshi> proposed #agreed - RHBZ#1410178 - AcceptedFreezeException - It'd be good to get these security fixes in. However, if it causes issues with Anaconda, we'll have to revert it.
17:04:04 <dustymabe> ack
17:04:11 <sgallagh> ack
17:04:26 <kparal> ack
17:04:32 <roshi> #agreed - RHBZ#1410178 - AcceptedFreezeException - It'd be good to get these security fixes in. However, if it causes issues with Anaconda, we'll have to revert it.
17:04:41 <roshi> #topic (1444654) Moving a file using Drag and Drop onto a folder works immediately the first time in nautilus, takes time subsequently.
17:04:44 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1444654
17:04:46 <roshi> #info Proposed Freeze Exceptions, nautilus, NEW
17:05:40 <dustymabe> hmm
17:05:56 <roshi> this'ns odd
17:05:57 <dustymabe> for this one would also be good to get a confirmation of what the bug is
17:06:16 <dustymabe> which would then lead to a possible proposed fixe
17:06:20 <kparal> there's not even a comment on it by the developer, nor in the upstream bug
17:06:30 <roshi> same punt as before?
17:06:33 <sgallagh> That's ugly, but I'm not comfortable changing a major part of the GNOME desktop during Freeze
17:06:35 <sgallagh> I'm -1 FE
17:06:40 <sgallagh> It can be fixed with an update later
17:06:42 <kparal> -1 until there's at least some dev response
17:06:43 <dustymabe> how do we escalate things to get them looked at by the devs?
17:06:44 <roshi> I want to see a fix first
17:06:45 <kparal> a fix is better
17:06:52 <roshi> depends on the team and if we can
17:07:13 <sgallagh> It works eventually, so it's not breaking the blocking criteria for default apps either
17:07:14 <dustymabe> basically if it's not a blocker it doesn't have to be fixed
17:07:27 <sgallagh> dustymabe: There's a Prioritized Bugs policy
17:07:42 <sgallagh> dustymabe: https://fedoraproject.org/wiki/Fedora_Program_Management/Prioritized_bugs_and_issues_-_the_process
17:07:47 <dustymabe> sgallagh: yeah
17:07:51 <kparal> we can propose this as a final blocker, if many people can reproduce
17:08:01 <kparal> for beta I think it's ok anyway
17:08:34 <pschindl> I can't reproduce this.
17:08:39 <dustymabe> we should be able to automatically tag things for that list from this meeting
17:09:05 <roshi> I guess I'm either +1 punt or -1 since there's no info and doesn't seem like many people see it
17:09:15 * roshi tests on the 0513 image he has installed right here
17:09:34 <dustymabe> -1 FE - re-evalute onece we have more info
17:09:34 <sgallagh> It doesn't happen to me on my laptop either
17:09:50 <pschindl> I'm -1 FE.
17:11:30 <pschindl> There is newer version in stable so it could be already fixed.
17:12:00 <dustymabe> pschindl: could you add that info to the bug report?
17:12:09 <dustymabe> and maybe the reporter can confirm/deny
17:12:36 <roshi> didn't see it here
17:12:43 <roshi> with empty or non-empty files
17:13:43 <roshi> proposed #agreed - RHBZ#1444654 - RejectedFreezeException - This bug lacks the information we need to determine how invasive it would be and no one in the meeting could reproduce it.
17:14:05 <pschindl> I will add there need info for reporter if he can test it with new version.
17:14:14 <pschindl> ack
17:14:23 <dustymabe> ack
17:14:37 <kparal> ack
17:14:43 <roshi> #agreed - RHBZ#1444654 - RejectedFreezeException - This bug lacks the information we need to determine how invasive it would be and no one in the meeting could reproduce it.
17:15:02 <roshi> that's it for the FE proposals
17:15:10 <roshi> now, to check in on the accepted blockers
17:15:33 <roshi> #topic AcceptedBlocker status review
17:15:41 <roshi> #link https://lists.fedorahosted.org/archives/list/test@lists.fedoraproject.org/thread/COATZINPNXVXIK4KNMSIBNVDFLXOHO5R/#43ZUCKZAT6PN45RW6P6OISA4D2CMEQV4
17:15:54 <roshi> adamw sent out a status email earlier - ^^ is the link
17:16:47 <dustymabe> roshi: some of those have made it to stable
17:17:08 <roshi> yep
17:17:12 <roshi> just giving context
17:17:26 <roshi> first up
17:17:27 <roshi> #topic (1443415) [TRACKING] Upgrade f25 to f26 get stuck in Cleanup
17:17:30 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1443415
17:17:33 <roshi> #info Accepted Blocker, dnf, NEW
17:18:32 <roshi> pwhalen: you around?
17:19:22 * sgallagh needs to depart.
17:19:30 <roshi> thanks sgallagh
17:19:33 <roshi> gl hf
17:20:34 <roshi> #info still no movement on this upgrade bug
17:20:40 * roshi moves on to the next...
17:20:54 <roshi> #topic (1403352) FreeIPA server install fails (and existing servers probably fail to start) due to changes in 'dyndb' feature on merge to upstream BIND
17:20:57 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1403352
17:21:00 <roshi> #info Accepted Blocker, freeipa, ON_QA
17:21:40 <dustymabe> roshi: i'm still here
17:21:42 <dustymabe> just not sure what to say
17:21:51 <roshi> no worries
17:22:09 * roshi is in the same position, but I'm running the meeting - so I have to make stuff up
17:22:12 <roshi> :p
17:22:47 <dustymabe> roshi: :) - that means you own the show
17:22:57 <dustymabe> you can do whatever you like
17:23:12 <roshi> that's a scary world :)
17:23:22 <roshi> looks like some movement, but still tracking it down
17:23:33 <roshi> shoulda done this while sgallagh was still here
17:23:56 <roshi> #info Debugging is still ongoing for this bug
17:24:04 <roshi> kparal: you still around?
17:24:23 * roshi thinks pschindl is still here too, since bugs are being updated
17:24:36 <roshi> but it's hard to secretarialize *and* be in the meeting
17:24:46 <roshi> #topic (1438046) initial-setup.service: Failed to set up stdin: Inappropriate ioctl for device
17:24:49 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1438046
17:24:51 <roshi> #info Accepted Blocker, initial-setup, ON_QA
17:25:31 <sgallagh> I don't have any insight on the last one. Sorry.
17:25:32 <pschindl> roshi: Yes, I'm still here and all bugs were secretari****d
17:26:00 <dustymabe> so arm disk images are release blocking.. cool
17:26:07 <roshi> yep
17:26:23 <roshi> no worries sgallagh - you were just the most likely to have info since adamw isn't here
17:26:25 <pschindl> roshi: Are we going to do final blocker proposals too?
17:26:38 <roshi> yeah, if people are around
17:26:43 <roshi> but Beta is priority now
17:26:55 <roshi> so want to get through those even if we don't get to Final today
17:27:01 <kparal> roshi: sorry, back now
17:27:05 <dustymabe> roshi: so this last bug
17:27:09 <dustymabe> it's in testing
17:27:10 <roshi> no worries kparal
17:27:13 <roshi> right
17:27:28 <roshi> #info an update for this is in testing as of 2017-05-18
17:27:56 <roshi> #topic (1443206) gnome-shell consistently crashes in the middle of first-login gnome-initial-setup
17:27:59 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1443206
17:28:02 <roshi> #info Accepted Blocker, libgweather, ON_QA
17:28:08 <roshi> dustymabe: this bit of the meeting we don't always do
17:28:17 <roshi> just when we're getting close to Go/No-go
17:28:34 <roshi> to make a note of any bugs that need attention or aren't getting fixed
17:28:38 <roshi> so we know ahead of time
17:29:00 <roshi> I checked today, I *don't* see this bug
17:29:11 <roshi> at least on the 0513 WS Live
17:29:15 <roshi> it installs fine for me
17:29:18 <roshi> g-i-s runs
17:29:20 <roshi> no crashes
17:30:14 <roshi> gnome weather crashes w/o location data, but otherwise works for me as well
17:30:55 <roshi> anyone have more to add to this?
17:31:02 <dustymabe> not i
17:31:50 <roshi> kparal: pschindl ?
17:32:14 <roshi> #info debugging is still ongoing for this bug.
17:33:09 * roshi moves on
17:33:17 <roshi> #topic (1348688) Anaconda cannot access LVM partitions in a LUKS-encrypted disk partition after decryption
17:33:20 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1348688
17:33:22 <roshi> #info Accepted Blocker, lvm2, ON_QA
17:34:12 <roshi> #info An update for this landed on 2017-05-19, please test
17:34:21 <roshi> #topic (1445302) partition on a FW RAID used as a PV is put into a list of filtered devices by blivet
17:34:24 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1445302
17:34:27 <roshi> #info Accepted Blocker, python-blivet, ON_QA
17:34:35 * dustymabe brb
17:34:44 <roshi> pschindl: update?
17:35:54 <kparal> it seems pschindl needs to verify this one
17:36:00 <pschindl> I couldn't reproduce it
17:36:02 <roshi> yeah
17:36:05 <pschindl> with the update
17:36:14 <kparal> so let's close as fixed
17:36:16 <roshi> #info It seems this bug is fixed.
17:36:31 <roshi> #action pschindl to update and close bug.
17:36:39 <pschindl> I will update it :)
17:36:44 <roshi> thanks
17:36:50 <roshi> that's all we have for Beta stuff
17:36:57 <roshi> #topic Open Floor
17:37:07 <roshi> I propose we adjourn here and get to work on Beta testing
17:37:12 <roshi> thoughts?
17:37:42 <dustymabe> sounds good - i have to go to another meeting anyway
17:38:21 <kparal> nothing else from me. thanks everyone
17:38:46 <dustymabe> would like to know if we have any good contacts within systemd
17:38:54 <roshi> thanks for coming folks!
17:38:56 * roshi doesn't
17:39:02 * roshi sets fuse...
17:39:03 <roshi> 3...
17:39:06 <roshi> kparal might
17:39:09 <kparal> dustymabe: #systemd channel
17:39:20 <roshi> 2...
17:39:36 * roshi thinks he'll go get lunch since dustymabe didn't bring any
17:39:39 <roshi> 1...
17:39:42 <roshi> thanks folks!
17:39:47 <roshi> Thanks pschindl !
17:39:51 <roshi> pschindl++
17:39:51 <zodbot> roshi: Karma for pschindl changed to 2 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:39:56 <dustymabe> thanks roshi
17:40:08 <roshi> #endmeeting