f26-blocker-review
MINUTES

#fedora-blocker-review: F26-blocker-review

Meeting started by adamw at 17:00:44 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 17:00:44)
  2. Introduction (adamw, 17:04:28)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 17:04:28)
    2. We'll be following the process outlined at: (adamw, 17:04:28)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 17:04:30)
    4. The bugs up for review today are available at: (adamw, 17:04:30)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 17:04:32)
    6. The criteria for release blocking bugs can be found at: (adamw, 17:04:34)
    7. https://fedoraproject.org/wiki/Fedora_26_Alpha_Release_Criteria (adamw, 17:04:36)
    8. https://fedoraproject.org/wiki/Fedora_26_Beta_Release_Criteria (adamw, 17:04:38)
    9. https://fedoraproject.org/wiki/Fedora_26_Final_Release_Criteria (adamw, 17:04:40)
    10. 4 Proposed Blockers (Alpha) (adamw, 17:04:50)
    11. 1 Proposed Blocker (Beta) (adamw, 17:05:10)
    12. 1 Proposed Blocker (Final) (adamw, 17:05:20)
    13. 2 Accepted Blockers (Alpha) (adamw, 17:05:32)
    14. coremodule will secretarialize (adamw, 17:05:43)

  3. (1409177) Kickstart installs fail with Python 3.6 (adamw, 17:05:59)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1409177 (adamw, 17:05:59)
    2. Proposed Blocker, anaconda, MODIFIED (adamw, 17:05:59)
    3. AGREED: 1409177 - AcceptedBlocker (Alpha) - clearly violates "The scripted installation mechanism must provide a working function for creating local user accounts, including the ability to specify a hashed password, and for specifying a hashed password for the root account." (as the 'scripted installation mechanism' is entirely broken) (adamw, 17:09:19)

  4. (1410523) gi.overrides.BlockDev.LVMError: Failed to call the 'LvCreate' method on the '/com/redhat/lvmdbus1/Vg/1' object: GDBus.Error:org.freedesktop.DBus.Python.dbus.exceptions.DBusException: ('com.redhat.lvmdbus1.Vg', "Exit code 3, stderr = --size may not ... (adamw, 17:09:30)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1410523 (adamw, 17:09:30)
    2. Proposed Blocker, anaconda, NEW (adamw, 17:09:30)
    3. AGREED: 1410523 - AcceptedBlocker (Alpha) - violates "When using a dedicated installer image, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces" (adamw, 17:13:45)

  5. (1403352) FreeIPA server install fails (and existing servers probably fail to start) due to changes in 'dyndb' feature on merge to upstream BIND (adamw, 17:14:01)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1403352 (adamw, 17:14:01)
    2. Proposed Blocker, freeipa, ASSIGNED (adamw, 17:14:01)
    3. AGREED: 1403352 - AcceptedBlocker (Alpha) - violates "Release-blocking roles and the supported role configuration interfaces must meet the core functional Role Definition Requirements to the extent that supported roles can be successfully deployed, started, stopped, brought to a working configuration, and queried" (domain controller is a blocking role) (adamw, 17:17:42)

  6. (1408282) TypeError: can't pickle _ped.Alignment objects (adamw, 17:17:52)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1408282 (adamw, 17:17:52)
    2. Proposed Blocker, python-blivet, POST (adamw, 17:17:53)
    3. this is addressed in current builds, bug is left open to track fix landing upstream, so removing blocker status (adamw, 17:18:25)
    4. that's all the proposed Alpha blockers, moving onto proposed Beta (adamw, 17:19:14)

  7. (1376638) rescue mode cannot mount a default Fedora install (adamw, 17:19:25)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1376638 (adamw, 17:19:25)
    2. Proposed Blocker, anaconda, ASSIGNED (adamw, 17:19:25)
    3. AGREED: 1376638 - punt (delay decision) - the behaviour here seems to have changed a bit in recent rawhide composes, we will investigate manually in more detail (adamw, 17:22:42)

  8. (1405539) changing the default keyboard layout changes also disk decryption in plymouth, but only after kernel update, long after (adamw, 17:22:55)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1405539 (adamw, 17:22:55)
    2. Proposed Blocker, plymouth, NEW (adamw, 17:22:56)
    3. AGREED: 1405539 - punt (delay decision) - we could not come to a clear consensus on this bug this week, and there's plenty of time before final, so we are punting for more consideration and hopefully more input from other voters (adamw, 17:56:18)

  9. Open floor (adamw, 17:57:55)


Meeting ended at 17:59:58 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (128)
  2. roshi (61)
  3. kparal (44)
  4. coremodule (15)
  5. mcatanzaro (13)
  6. pwhalen (11)
  7. Southern_Gentlem (8)
  8. zodbot (5)
  9. garretraziel (5)


Generated by MeetBot 0.1.4.