f25-blocker-review
MINUTES

#fedora-blocker-review: F25-blocker-review

Meeting started by adamw at 16:01:05 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:01:05)
  2. Introduction (adamw, 16:05:12)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:05:12)
    2. We'll be following the process outlined at: (adamw, 16:05:13)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:05:13)
    4. The bugs up for review today are available at: (adamw, 16:05:16)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:05:17)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:05:19)
    7. https://fedoraproject.org/wiki/Fedora_25_Alpha_Release_Criteria (adamw, 16:05:23)
    8. https://fedoraproject.org/wiki/Fedora_25_Beta_Release_Criteria (adamw, 16:05:25)
    9. https://fedoraproject.org/wiki/Fedora_25_Final_Release_Criteria (adamw, 16:05:27)
    10. coremodule will be the secretary (adamw, 16:08:16)
    11. 4 Proposed Blockers (adamw, 16:10:44)
    12. 5 Accepted Blockers (adamw, 16:10:44)
    13. 4 Proposed Freeze Exceptions (adamw, 16:10:48)
    14. 7 Accepted Freeze Exceptions (adamw, 16:10:48)

  3. (1389762) systemd presets request - switcheroo-control.service (adamw, 16:11:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1389762 (adamw, 16:11:08)
    2. Proposed Blocker, fedora-release, POST (adamw, 16:11:08)
    3. AGREED: 1389762 - RejectedBlocker AcceptedFreezeException - per the criteria and blocker process there is nothing that makes this a blocker, incomplete Changes are not inherently release blocking. However, it's obviously worth a freeze exception. Note FESCo has the power to declare this a blocking issue if it so desires. (adamw, 16:18:04)

  4. (1384508) [abrt] gnome-session: _gtk_style_provider_private_get_settings(): gnome-session-failed killed by SIGSEGV (adamw, 16:18:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1384508 (adamw, 16:18:20)
    2. Proposed Blocker, gnome-session, NEW (adamw, 16:18:21)
    3. AGREED: 1384508 - RejectedBlocker - As things stand, there is not sufficient indication that this affects more than a handful of users, so it's hard to consider it a blocker (not a wide enough impact). If more details emerge that indicate this could affect many users, we may re-consider the decision. (adamw, 16:34:39)

  5. (1389885) gnome-shell freeze when holding F11 key in gnome-terminal (adamw, 16:37:04)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1389885 (adamw, 16:37:04)
    2. Proposed Blocker, gnome-shell, NEW (adamw, 16:37:04)
    3. AGREED: 1389885 - RejectedBlocker - as this isn't really in basic functionality and seems to affect X only, it doesn't meet the blocker criteria. We may be willing to grant an FE for a fix if it's simple and non-invasive, but would like to see more details before voting on that (adamw, 16:45:12)

  6. (1383471) [abrt] WARNING: CPU: 3 PID: 12176 at ./include/linux/swap.h:276 page_cache_tree_insert+0x1cc/0x1e0 (adamw, 16:45:24)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1383471 (adamw, 16:45:24)
    2. Proposed Blocker, kernel, NEW (adamw, 16:45:24)
    3. AGREED: 1383471 - punt (delay decision) - we believe this may already have been resolved, so we will ask for feedback from reporters and close the bug if appropriate (adamw, 16:51:53)
    4. moving on to proposed freeze exceptions (adamw, 16:52:10)

  7. (1389959) Switching keyboard layout with key combo does not work in Wayland (adamw, 16:52:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1389959 (adamw, 16:52:20)
    2. Proposed Freeze Exceptions, anaconda, NEW (adamw, 16:52:21)
    3. AGREED: 1389959 - AcceptedFreezeException (Final) - this is an installer issue and cannot be fixed with an update, and is sufficiently serious to warrant a freeze exception (adamw, 17:09:23)
    4. we already discussed the next bug on the list (#1389762) as a proposed blocker, and granted it a freeze exception. (adamw, 17:10:16)

  8. (1188774) [anaconda] white screen on external monitor attached to a Lenovo ThinkPad T400 when docked and lid closed (adamw, 17:10:21)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1188774 (adamw, 17:10:22)
    2. Proposed Freeze Exceptions, metacity, NEW (adamw, 17:10:22)
    3. AGREED: 1188774 - unpropose (drop Blocks:, but do not apply RejectedFreezeException tag) - this bug has been around a long time and we are not willing to grant an FE without an actual code fix, so there's no point punting every week until that's the case (adamw, 17:17:09)

  9. (1331382) Anaconda layout indicator does not switch the keyboard layout when clicked when running in Workstation live (adamw, 17:18:11)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1331382 (adamw, 17:18:11)
    2. Proposed Freeze Exceptions, mutter, ASSIGNED (adamw, 17:18:11)
    3. AGREED: 1331382 - AcceptedFreezeException (Final) - this is somewhat less likely to be encountered than on F24 as Wayland is now the default, but there are still enough cases where we fall back to X that it is worth fixing, and cannot be fixed with an update (adamw, 17:26:09)
    4. that's all proposals, now taking a look at selected accepted blockers (adamw, 17:27:25)
    5. desktop team will look into status of #1331382 (adamw, 17:29:12)
    6. #1381996 fix should be in composes from today onwards, pschindl will verify it (adamw, 17:29:33)
    7. fixes for #1378156 and subsequent iscsi bugs are working through the anaconda/blivet review processes, we should have new builds in a few days (adamw, 17:30:08)
    8. #1370222 is waiting on a spin-kickstarts PR to work around the bug, kparal has the hammer (adamw, 17:38:06)
    9. #1382001 is showing no progress at all (adamw, 17:38:55)

  10. Open floor (adamw, 17:41:34)


Meeting ended at 17:50:56 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (175)
  2. kparal (63)
  3. cmurf (52)
  4. jkurik (23)
  5. coremodule (14)
  6. garretraziel (10)
  7. pschindl (8)
  8. linuxmodder (7)
  9. zodbot (7)
  10. sgallagh (6)
  11. halfline (5)
  12. Kevin_Kofler (3)
  13. mclasen_ (2)
  14. satellit (1)
  15. fale (1)


Generated by MeetBot 0.1.4.