f25-blocker-review
MINUTES

#fedora-blocker-review: F25-blocker-review

Meeting started by adamw at 16:00:01 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:00:02)
  2. Introduction (adamw, 16:02:28)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:02:28)
    2. We'll be following the process outlined at: (adamw, 16:02:28)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:02:30)
    4. The bugs up for review today are available at: (adamw, 16:02:30)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:02:32)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:02:34)
    7. https://fedoraproject.org/wiki/Fedora_25_Alpha_Release_Criteria (adamw, 16:02:38)
    8. https://fedoraproject.org/wiki/Fedora_25_Beta_Release_Criteria (adamw, 16:02:40)
    9. https://fedoraproject.org/wiki/Fedora_25_Final_Release_Criteria (adamw, 16:02:42)
    10. 4 Proposed Blockers (adamw, 16:02:51)
    11. 0 Everything Else (for Beta) (adamw, 16:03:01)
    12. 5 Proposed Blockers (for Final) (adamw, 16:03:17)
    13. coremodule will secretarialize (adamw, 16:04:19)

  3. (1369786) Autopart fails on installation from live usb created by l-i-t-d (adamw, 16:04:40)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1369786 (adamw, 16:04:40)
    2. Proposed Blocker, anaconda, NEW (adamw, 16:04:41)
    3. AGREED: 1369786 - AcceptedBlocker (Beta) - clear violation of "All release-blocking images must boot in their supported configurations. This criterion differs from the similar Alpha criterion only in that it requires all supported methods of writing a Fedora USB stick to work, not just any single one" and "The installer must be able to complete an installation to a single disk using automatic partitioning." (adamw, 16:07:59)

  4. (1366793) Nothing obsoletes retired dnf-langpacks packages, breaks upgrade from Fedora 23 to 25+ (adamw, 16:10:00)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1366793 (adamw, 16:10:00)
    2. Proposed Blocker, dnf, ASSIGNED (adamw, 16:10:00)
    3. the FPC ticket we filed on this - https://fedorahosted.org/fpc/ticket/645 - has been kicked to FESCo - https://fedorahosted.org/fesco/ticket/1620 (adamw, 16:12:02)
    4. AGREED: 1366793 - AcceptedBlocker (Beta) - the lack of a clear policy here makes the decision somewhat difficult, but in the absence of a policy we hold this to be a violation of "For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from fully updated installations of the last two stable Fedora releases with that package set installed." (adamw, 16:15:36)

  5. (1369492) mouse cursor coordinates are incorrect in VM under wayland, makes cursor unusable (adamw, 16:15:58)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1369492 (adamw, 16:15:58)
    2. Proposed Blocker, mutter, NEW (adamw, 16:15:59)
    3. AGREED: 1369492 - AcceptedBlocker (Beta) - clearly violates "The release must be able host virtual guest instances of the same release." combined with multiple desktop criteria (adamw, 16:19:30)

  6. (1026119) fails to unmount encrypted filesystem (/dev/mapper/luks-partition) containing /var/log on every shutdown (adamw, 16:19:38)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1026119 (adamw, 16:19:38)
    2. Proposed Blocker, systemd, NEW (adamw, 16:19:38)
    3. https://github.com/systemd/systemd/issues/867#issuecomment-148349919 (adamw, 16:22:17)
    4. AGREED: 1026119 - RejectedBlocker (Beta) - based on all available information this affects only a corner case (encrypted separate /var partition) and even when encountered appears not to have serious consequences (adamw, 16:26:17)
    5. moving on to proposed Final blockers (adamw, 16:26:52)

  7. (1370118) Some fonts are missing on the netinst and dvd (adamw, 16:26:58)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1370118 (adamw, 16:26:58)
    2. Proposed Blocker, anaconda, NEW (adamw, 16:26:58)
    3. AGREED: 1370118 - AcceptedBlocker (Final) - clear violation of "The installer must correctly display all sufficiently complete translations available for use." (adamw, 16:30:44)

  8. (1370889) libgweather "Failed to get METAR data: 404 Not Found" (adamw, 16:30:52)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1370889 (adamw, 16:30:52)
    2. Proposed Blocker, libgweather, MODIFIED (adamw, 16:30:52)
    3. AGREED: 1370889 - AcceptedBlocker (Final) - this violates "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test" in the case of gnome-weather (this is considered 'basic functionality' of gnome-weather) (adamw, 16:35:11)

  9. (1366004) [abrt] setroubleshoot-server: service.py:647:_message_cb:SystemError: <built-in function isinstance> returned a result with an error set (adamw, 16:35:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1366004 (adamw, 16:35:20)
    2. Proposed Blocker, setroubleshoot, NEW (adamw, 16:35:20)
    3. AGREED: 1366004 - RejectedBlocker (Final) - so far this doesn't seem to be a crash on boot (thus does not violate cited criterion) and also doesn't seem reliably reproducible on regular use of the sealert app (thus doesn't violate 'basic functionality' criterion for pre-installed apps). can be reproposed if more details emerge (adamw, 16:51:07)

  10. (1295031) cannot preview files under wayland/XWayland (adamw, 16:51:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1295031 (adamw, 16:51:13)
    2. Proposed Blocker, sushi, NEW (adamw, 16:51:13)
    3. AGREED: 1295031 - RejectedBlocker (Final) This is niche functionality that doesn't quite pass the bar of "basic funcionality" for default-installed applications. (adamw, 17:00:32)

  11. (1370136) glibc update corrupts display of a running system (adamw, 17:00:56)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1370136 (adamw, 17:00:56)
    2. Proposed Blocker, systemd, POST (adamw, 17:00:56)
    3. AGREED: 1370136 - punt (delay decision) - we don't have a clear vote on this at present and it's likely to be resolved long before Final in any case, so we're delaying it for now (adamw, 17:26:58)
    4. going back to a newly-proposed Beta blocker (adamw, 17:27:28)

  12. (1225184) anaconda does not detect RAID devices (adamw, 17:27:31)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1225184 (adamw, 17:27:31)
    2. Proposed Blocker, python-blivet, ASSIGNED (adamw, 17:27:32)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=1219264#c18 (adamw, 17:32:24)
    4. AGREED: 1225184 - AcceptedBlocker (Final) - as this is reproducible with clean disk images it seems like a violation of "When using the custom partitioning flow, the installer must be able to correctly interpret...any disk with a valid ms-dos or gpt disk label and partition table containing ext4 partitions, LVM and/or btrfs volumes, and/or software RAID arrays at RAID levels 0, 1 and 5 containing ext4 partitions" for live images (adamw, 17:49:24)

  13. Open floor (adamw, 17:49:34)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1225184#c66 (cmurf, 17:50:04)


Meeting ended at 17:54:44 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (181)
  2. kparal (128)
  3. cmurf (102)
  4. sgallagh (64)
  5. coremodule (16)
  6. dgilmore (11)
  7. zodbot (9)
  8. pwhalen (8)
  9. handsome_pirate (7)
  10. mboddu (6)
  11. pschindl (5)


Generated by MeetBot 0.1.4.