f24-blocker-review
MINUTES

#fedora-blocker-review: F24-blocker-review

Meeting started by adamw at 16:02:32 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:02:32)
  2. Introduction (adamw, 16:07:29)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:07:29)
    2. We'll be following the process outlined at: (adamw, 16:07:29)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:07:30)
    4. The bugs up for review today are available at: (adamw, 16:07:32)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:07:34)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:07:36)
    7. https://fedoraproject.org/wiki/Fedora_24_Alpha_Release_Criteria (adamw, 16:07:38)
    8. https://fedoraproject.org/wiki/Fedora_24_Beta_Release_Criteria (adamw, 16:07:40)
    9. https://fedoraproject.org/wiki/Fedora_24_Final_Release_Criteria (adamw, 16:07:42)
    10. no Beta blockers, starting with proposed Beta FEs (adamw, 16:08:50)

  3. (1331107) The shutdown process on KDE takes ~2/3 minutes longer than usual (adamw, 16:09:04)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1331107 (adamw, 16:09:04)
    2. Proposed Freeze Exceptions, plasma-workspace, NEW (adamw, 16:09:04)
    3. AGREED: 1331107 - RejectedFreezeException (Beta) - as this could involve many core components and it seems the real cause is yet unknown and no-one has any idea what the fix will look like, we cannot approve a freeze exception at this time. It can be re-proposed with more info on the cause and/or a fix. (adamw, 16:17:18)
    4. tflink will secretarialize (adamw, 16:20:16)

  4. (1330318) rpm-ostree status error: Error calling StartServiceByName for org.projectatomic.rpmostree1: Timeout was reached (adamw, 16:20:33)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1330318 (adamw, 16:20:33)
    2. Proposed Freeze Exceptions, selinux-policy, MODIFIED (adamw, 16:20:33)
    3. AGREED: 1330318 - AcceptedFreezeException (Beta) - this causes a significant problem in the Atomic images and we must push the fix stable to remedy that; fix should be safe per selinux-policy update policies, so this is accepted as a freeze exception (adamw, 16:25:47)

  5. (1331834) initramfs are no longer hostonly by default (adamw, 16:26:15)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1331834 (adamw, 16:26:15)
    2. Proposed Freeze Exceptions, spin-kickstarts, NEW (adamw, 16:26:15)
    3. AGREED: 1331834 - AcceptedFreezeException - we're willing to run a compose with this change but *only* if there's sufficient time before the go/no-go date to test it and unwind if things go bad, i.e. on a Monday or earlier. we acknowledge the likely inconvenience for i686 installs (adamw, 16:33:44)
    4. all Beta blockers are in VERIFIED state, so moving on to proposed Final blockers (adamw, 16:39:05)

  6. (1206936) Laptop does not resume from hibernate, boots instead (adamw, 16:39:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1206936 (adamw, 16:39:54)
    2. Proposed Blocker, anaconda, NEW (adamw, 16:39:55)
    3. AGREED: 1206936 - RejectedBlocker (Final) - this is a worrying issue, but we do not find that it meets the release criteria, which have always been held specifically not to cover hibernation, thus it is rejected as a release blocker (adamw, 16:55:30)

  7. (1329908) [comps] LXQt group description is the same as for LXDE, may confuse users to see two list entries for LXDE (adamw, 16:55:41)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1329908 (adamw, 16:55:42)
    2. Proposed Blocker, comps, ASSIGNED (adamw, 16:55:42)
    3. AGREED: 1329908 - RejectedBlocker (Final) - it seems clear that this does not violate any of the release criteria (adamw, 17:02:44)

  8. (1317275) [abrt] gnome-software: gs_plugin_loader_get_updates_async(): gnome-software killed by SIGSEGV (adamw, 17:02:58)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1317275 (adamw, 17:02:58)
    2. Proposed Blocker, gnome-software, NEW (adamw, 17:02:58)
    3. AGREED: 1320396 - punt (delay decision) - there is no info on how to reproduce this or if it is still currently a problem, we will ask the reporter for more details and discuss again next time (adamw, 17:16:57)

  9. (1329342) 1.8.0.91-1.b14.fc25 (OpenJDK April CPU) breaks EC ciphers (adamw, 17:17:07)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1329342 (adamw, 17:17:07)
    2. Proposed Blocker, java-1.8.0-openjdk, MODIFIED (adamw, 17:17:08)
    3. AGREED: 1329342 - punt (delay decision) - we expect this to be closed soon as it was included in Beta composes and has sufficient karma to get a stable push in the next day or two, so we delay the decision expecting it to be closed by next week (adamw, 17:20:04)

  10. (1318470) failure to mount persistent overlay when booting live USB (adamw, 17:20:38)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1318470 (adamw, 17:20:38)
    2. Proposed Blocker, livecd-tools, NEW (adamw, 17:20:38)
    3. AGREED: 1318470 - AcceptedBlocker (Final) - this is accepted per the current criterion which it definitely seems to violate, but we note that this whole area has changed a lot with F24 and it may be that persistence is no longer supported: we will check with the developers for clarification (adamw, 17:34:09)

  11. (1331107) The shutdown process on KDE takes ~2/3 minutes longer than usual (adamw, 17:34:33)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1331107 (adamw, 17:34:33)
    2. Proposed Blocker, plasma-workspace, NEW (adamw, 17:34:34)
    3. AGREED: 1331107 - RejectedBlocker (Final) - this is definitely an annoyance, but a delay in shutdown isn't severe enough to meet the criteria, especially as it can be fixed with an update for installed systems (adamw, 17:44:29)

  12. (1330766) [abrt] realmd: g_cancellable_is_cancelled(): realmd killed by SIGSEGV (adamw, 17:44:43)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1330766 (adamw, 17:44:43)
    2. Proposed Blocker, realmd, NEW (adamw, 17:44:44)
    3. AGREED: 1330766 - AcceptedBlocker (Final) - this does seem like a violation of "It must be possible to join the system to a FreeIPA or Active Directory domain at install time and post-install" in the case that the client packages are not yet installed, which is the case for a default Server install (adamw, 17:54:53)

  13. (1247797) [abrt] WARNING: CPU: 0 PID: 1101 at drivers/gpu/drm/i915/intel_display.c:11098 intel_check_page_flip+0xea/0x100 [i915]() [i915] (adamw, 17:54:59)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1247797 (adamw, 17:54:59)
    2. Proposed Blocker, xorg-x11-drv-intel, NEW (adamw, 17:54:59)
    3. AGREED: 1247797 - punt (delay decision) - it seems this may have been fixed recently, we will ask other reporters if they are still seeing the problem and re-consider this next week (adamw, 17:59:42)

  14. Open floor (adamw, 17:59:50)


Meeting ended at 18:06:31 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (272)
  2. cmurf (153)
  3. kparal (92)
  4. tflink (18)
  5. nb (17)
  6. pwhalen (16)
  7. satellit (13)
  8. garretraziel (12)
  9. danofsatx (10)
  10. zodbot (7)
  11. RaphGro (7)
  12. jkurik (6)
  13. Southern_Gentlem (4)
  14. pschindl_ (1)
  15. coremodule (1)


Generated by MeetBot 0.1.4.