f20alpha-blocker-review-5
LOGS
16:01:43 <tflink> #startmeeting f20alpha-blocker-review-5
16:01:43 <zodbot> Meeting started Wed Sep 11 16:01:43 2013 UTC.  The chair is tflink. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:43 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:43 <tflink> #meetingname f20alpha-blocker-review-5
16:01:44 <tflink> #topic Roll Call
16:01:44 <zodbot> The meeting name has been set to 'f20alpha-blocker-review-5'
16:01:51 * kparal 
16:01:55 * roshi 
16:01:59 * pwhalen is here
16:02:04 * mkrizek here
16:02:52 * pschindl is here
16:02:56 <tflink> lots o' people today :)
16:04:22 <tflink> so let's get started with some ever-so-fun boilerplate
16:04:31 <tflink> #topic Introduction
16:04:36 <tflink> Why are we here?
16:04:36 <tflink> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and freeze exception bugs.
16:04:43 <tflink> #info We'll be following the process outlined at:
16:04:44 <tflink> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:04:50 <tflink> #info The bugs up for review today are available at:
16:04:50 <tflink> #link http://qa.fedoraproject.org/blockerbugs/current
16:04:54 <tflink> #info The criteria for release blocking bugs can be found at:
16:04:54 <tflink> #link https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria
16:05:01 <tflink> #info Up for review today, we have:
16:05:07 <tflink> #info 1 Proposed Blockers
16:05:08 <tflink> #info 10 Accepted Blockers
16:05:08 <tflink> #info 6 Proposed Freeze Exceptions
16:05:08 <tflink> #info 8 Accepted Freeze Exceptions
16:05:23 <tflink> I suspect that today will be a short review meeting :)
16:05:37 <tflink> waiting on RC1 for many of these
16:05:57 <tflink> however, if there are no objections, we'll get started with the proposed blockers
16:07:48 * jreznik is here, back from the other meeting
16:08:03 <tflink> #topic (1006539) SIGSEGV - ~NonSharedCharacterBreakIterator () from /lib/libQtWebKit.so.4
16:08:06 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=1006539
16:08:09 <tflink> #info Proposed Blocker, qtwebkit, NEW
16:09:13 <pwhalen> criteria - http://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Required_applications
16:09:35 <tflink> i tried repoducing this on x64 and had no luck
16:09:45 <tflink> my thought is that this is gonna be a judgement call
16:09:59 <tflink> I'm leaning more towards -1/+1 unless the ARM images can't be updated
16:10:08 <kparal> pwhalen: does firefox work?
16:10:19 <tflink> kparal: it's not part of the kde spin, though
16:10:23 <pwhalen> tflink, they should update fine. I would need to test firefox
16:10:25 <kparal> I know
16:10:26 <jreznik> also it should be possible to switch to khtml
16:10:48 <tflink> other thoughts?
16:10:59 <jreznik> pwhalen: could you try it?
16:11:15 <jreznik> view -> view mode -> KHTML
16:11:20 <pwhalen> I would be inclined to say +1 FE rather than a blocker
16:11:36 <pwhalen> jreznik, will take a few
16:11:49 <jreznik> for me -1/+1 FE, if KHTML works, I'd even say let's skip it for now
16:12:08 <kparal> I wouldn't block either, "it's just arm" ;-)
16:12:45 <pschindl> I'm +1 FE too.
16:13:39 <tflink> proposed #agreed 1006539 - RejectedBlocker AcceptedFreezeException - While not a great situation to be in, this is only on ARM, there are reasonable workarounds (use khtml) and could be fixed with an update post-release as it doesn't affect lives. Rejected as a blocker for F20 alpha but a tested fix would be considered past freeze.
16:13:59 <tflink> oh, any volunteers for secretary duty?
16:14:07 <pwhalen> jreznik, KHTML also seg faults
16:14:22 <roshi> link me to an example and I'll attempt secretary duty
16:14:54 <tflink> are we still -1 blocker?
16:15:00 <kparal> roshi: https://bugzilla.redhat.com/show_bug.cgi?id=1004902#c6
16:15:03 <kparal> roshi: thanks
16:15:25 <roshi> no prob kparal :) thanks for the link
16:15:30 <jreznik> pwhalen: really? on what?
16:15:30 <tflink> roshi: any of the accepted blocker/fe bugs that have been done in meeting
16:16:51 <jreznik> tflink: patch, seems like khtml crashes too...
16:17:01 <tflink> proposed #agreed 1006539 - RejectedBlocker AcceptedFreezeException - While not a great situation to be in, this is only on ARM and  could be fixed with an update post-release as it doesn't affect lives. Rejected as a blocker for F20 alpha but a tested fix would be considered past freeze.
16:17:06 <tflink> jreznik: yeah, was just fixing that
16:17:07 <tflink> :)
16:17:25 * jreznik should not read proposals and just ack them then :D
16:17:33 <jreznik> ack
16:17:47 <pwhalen> ack
16:17:54 <mkrizek> ack
16:18:09 <tflink> jreznik: oh, I miss plenty of things :)
16:18:09 * spstarr_work stumbles in
16:18:16 <tflink> #agreed 1006539 - RejectedBlocker AcceptedFreezeException - While not a great situation to be in, this is only on ARM and  could be fixed with an update post-release as it doesn't affect lives. Rejected as a blocker for F20 alpha but a tested fix would be considered past freeze.
16:18:26 <tflink> ok, that's all of the proposed blockers on my list today
16:18:31 <tflink> moving on to proposed FE
16:19:28 <tflink> #topic (1005198) IndexError: list index out of range
16:19:29 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=1005198
16:19:29 <tflink> #info Proposed Freeze Exceptions, anaconda, MODIFIED
16:19:48 <tflink> hrm, we're already +3 in bug
16:19:53 <tflink> i forgot to move it to accepted
16:20:02 <tflink> nvm
16:20:05 <spstarr_work> :)
16:20:08 <kparal> +1 here
16:20:16 <spstarr_work> thats a +1
16:21:11 <tflink> proposed #agreed 1005198 - AcceptedFreezeException - This can cause crashes during install under the right network conditions and while it doesn't qualify as a release blocking bug, a tested fix would be considered past freeze.
16:21:22 <kparal> ack
16:21:25 <tflink> I'll make roshi do the secretarial work :)
16:21:47 * roshi assumed it was for the whole meeting anyway :)
16:22:04 <tflink> roshi: instead of skipping it and doing it myself later since it's already +3 in bug
16:22:16 <roshi> aha
16:23:15 <tflink> ack/nak/patch?
16:23:38 * kparal notes we have already 4 acks
16:24:32 <jreznik> ack
16:24:36 <tflink> we do? oh, in bug
16:24:40 <tflink> wfm
16:24:47 <tflink> #agreed 1005198 - AcceptedFreezeException - This can cause crashes during install under the right network conditions and while it doesn't qualify as a release blocking bug, a tested fix would be considered past freeze.
16:25:01 <tflink> #topic (1002436) gnome-intial-setup offers “anthy” after an installation performed in Japanese, not kkc
16:25:03 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=1002436
16:25:06 <tflink> #info Proposed Freeze Exceptions, gnome-initial-setup, ON_QA
16:25:24 <pschindl> ack
16:25:25 <tflink> as i read this, the japanese IME installed by default w/ gnome isn't what gnome is configured for
16:25:37 <tflink> so you end up with a default IME that doesn't work
16:26:24 <tflink> could this be fixed post-release with an update?
16:26:50 <tflink> bah, I dont remember jens' irc handle
16:26:50 <kparal> do you need the input method just to type japanese chars, or even to type "yum update"?
16:27:05 <tflink> to be able to type non-roman chars
16:27:31 <tflink> i assume that it would fall back to some roman input (us english would be my guess)
16:28:07 <kparal> it doesn't sound that bad for Alpha, but I am +1 FE
16:28:45 <tflink> for teh record, the same issue was accepted as beta fe for f19
16:28:53 <tflink> https://bugzilla.redhat.com/show_bug.cgi?id=948117
16:29:18 <tflink> +1 FE
16:30:10 <tflink> proposed #agreed 1002436 - AcceptedFreezeException - This is more of a polish issue for japanese language installs but it can't be fixed with an update and a tested fix would be considered past freeze.
16:30:14 <tflink> ack/nak/patch?
16:30:30 <spstarr_work> indifferent :)
16:30:46 <kparal> I guess the default setting can't be fixed with an update. but you can still install&configure
16:30:48 <kparal> ack
16:31:08 <tflink> what happened to everyone who was here @ the start?
16:31:16 <pschindl> ack
16:31:17 <roshi> ack
16:31:26 * kparal pokes mkrizek
16:31:27 <tflink> #agreed 1002436 - AcceptedFreezeException - This is more of a polish issue for japanese language installs but it can't be fixed with an update and a tested fix would be considered past freeze.
16:32:18 <tflink> #topic (1006375) Incorrect arches / ovirt-node has broken dependencies in the F-20 tree
16:32:21 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=1006375
16:32:24 <tflink> #info Proposed Freeze Exceptions, ovirt-node, ASSIGNED
16:33:11 <tflink> the desire here was to be able to release a new ovirt-node (derivative of fedora) soon
16:33:15 <kparal> +1 FE, shouldn't affect default compose
16:33:16 * Viking-Ice greetings
16:33:29 <tflink> Viking-Ice: welcome
16:33:35 <Viking-Ice> +1 FE
16:33:36 <spstarr_work> if it doesn't impact compose then +1
16:33:41 <mkrizek> +1 FE
16:33:55 <jreznik> +1 FE
16:34:25 <spstarr_work> FE
16:34:46 <tflink> proposed #agreed 1006375 - AcceptedFreezeException - This doesn't affect compose and is a request from a derivative project (ovirt-node) so they can do a release soon. A tested updated would be considered past freeze.
16:34:58 <kparal> ack
16:35:02 <mkrizek> ack
16:35:03 <pschindl> ack
16:35:04 <jreznik> ack
16:35:06 <roshi> ack
16:35:09 <tflink> #agreed 1006375 - AcceptedFreezeException - This doesn't affect compose and is a request from a derivative project (ovirt-node) so they can do a release soon. A tested updated would be considered past freeze.
16:35:17 <tflink> #topic (1005338) rdesktop missing dependency on libgssglue
16:35:17 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=1005338
16:35:17 <tflink> #info Proposed Freeze Exceptions, rdesktop, ON_QA
16:35:26 <tflink> more libgssglue fun
16:35:38 <tflink> +1 FE - fixes dep issues on non-blocking spins
16:35:49 <spstarr_work> +1 FE
16:35:51 <kparal> +1 FE
16:36:14 <mkrizek> +1 FE
16:36:21 <jreznik> +1 FE
16:36:47 <tflink> proposed #agreed 1005338 - AcceptedFreezeException - This is a blocking issue (dep resolving and compose problem) for a non-release-blocking spin (FEL) and a tested fix would be considered past freeze.
16:37:16 <kparal> ack
16:37:17 <mkrizek> ack
16:37:30 <roshi> ack
16:37:38 <pschindl> ack
16:37:39 <tflink> #agreed 1005338 - AcceptedFreezeException - This is a blocking issue (dep resolving and compose problem) for a non-release-blocking spin (FEL) and a tested fix would be considered past freeze.
16:37:46 <tflink> #topic (1006230) pretrans scriplet uses shell commands
16:37:46 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=1006230
16:37:47 <tflink> #info Proposed Freeze Exceptions, sagemath, MODIFIED
16:37:52 <tflink> similar issue
16:38:01 <tflink> breaking compose of scientific spin
16:38:13 <tflink> +1 FE
16:38:20 <kparal> +1 FE
16:38:50 <tflink> proposed #agreed 1006230 - AcceptedFreezeException - Breaks compose for a non-release-blocking spin (scientific) and a tested fix would be considered past freeze.
16:39:06 <spstarr_work> low hanging fruit issues :)
16:39:30 <tflink> yeah, but I don't remember seeing spin FEs @ alpha before
16:39:47 <jreznik> tflink: because spins were not produced at alpha before
16:39:57 <tflink> jreznik: ah, that would explain part of it
16:40:53 <tflink> votes?
16:40:57 <tflink> ack/nak/patch?
16:41:02 <tflink> bueller?
16:41:08 <roshi> ack
16:41:11 <mkrizek> ack
16:41:14 <tflink> roshi: vote?
16:41:20 <tflink> we're still +2 FE
16:41:28 <roshi> ah, we need +3 right?
16:41:33 * tflink figured the 3rd was coming
16:41:35 <roshi> +1 FE
16:41:41 <kparal> ack
16:41:50 * roshi now "acks"
16:42:02 <tflink> not so much need on simple issue, but preferred. especially with as many people who are supposedly here
16:42:05 <tflink> :)
16:42:14 <tflink> #agreed 1006230 - AcceptedFreezeException - Breaks compose for a non-release-blocking spin (scientific) and a tested fix would be considered past freeze.
16:42:24 <tflink> ok, that would be all of the proposed FE
16:42:44 <tflink> I don't see any accepted blockers that need review today
16:43:30 <kparal> have we missed 998030?
16:43:33 <Viking-Ice> ack
16:43:34 <tflink> any disagreements on that &&
16:43:41 <tflink> damn, missed ^^
16:43:55 <tflink> kparal: it already has +3
16:44:03 <tflink> we can go over it, though
16:44:14 <kparal> I don't mind, we just need to move it to accepted then
16:44:44 <tflink> done
16:44:53 <kparal> ok
16:45:28 <tflink> if there are no disagreements about the need to review accepted blockers, it's time for ...
16:45:32 <tflink> #topic Open Floor
16:45:43 <tflink> anything else that needs to be brought up now?
16:45:47 <tflink> now/here?
16:46:12 <kparal> nope
16:46:23 <tflink> otherwise, methinks it's about time for some frantic RC1 testing :)
16:46:49 * tflink sets patent-pending non-deterministic fuse for (0,5] minutes
16:47:01 <pschindl> I just ask you for providing karma to updates on RC1. I will send mail soon.
16:49:15 <tflink> #info Fedora 20 alpha go/no-go is tomorrow - 2013-09-11 @ 17:00 UTC
16:49:22 * Viking-Ice turns on the quantum fuse... Oh boy will some random dimension be in for a big surprise
16:49:30 <tflink> Thanks for coming, everyone?
16:49:43 <tflink> Viking-Ice: but it was already lit, now we have two!
16:49:44 <jreznik> thanks tflink for meeting!
16:49:48 * tflink gets scared, and runs
16:49:53 * tflink will send out minutes shortly
16:49:55 <tflink> #endmeeting