atomic-community
LOGS
16:02:18 <jberkus> #startmeeting atomic-community
16:02:18 <zodbot> Meeting started Mon Oct  2 16:02:18 2017 UTC.  The chair is jberkus. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:02:18 <zodbot> The meeting name has been set to 'atomic-community'
16:02:18 <centbot> Meeting started Mon Oct  2 16:02:18 2017 UTC.  The chair is jberkus. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:19 <centbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:02:40 <jberkus> #topic role-call
16:02:50 <jberkus> .hello jberkus
16:02:51 <zodbot> jberkus: jberkus 'Josh Berkus' <josh@agliodbs.com>
16:03:06 <jbrooks> .hello jasonbrooks
16:03:08 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
16:03:24 <tsweeney_> tsweeney
16:04:25 <jberkus> .hello tsweeney
16:04:26 <zodbot> jberkus: Sorry, but you don't exist
16:05:23 <jbrooks> jberkus, the hello thing might be a little weird because it's tied to fedora's account system
16:05:52 <dustymabe> .hello dustymabe
16:05:54 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
16:06:17 <jberkus> anyone else?  maxamillion dwalsh_ runcom giuseppe imcleod jlebon etc.
16:06:18 <ashcrow> .hello smilner
16:06:19 <zodbot> ashcrow: smilner 'None' <smilner@redhat.com>
16:06:44 <jlebon> .hello jlebon
16:06:44 <zodbot> jlebon: jlebon 'None' <jlebon@redhat.com>
16:06:45 <imcleod> .hello imcleod
16:06:48 <zodbot> imcleod: imcleod 'Ian McLeod' <imcleod@redhat.com>
16:07:15 <jberkus> (at some point, I need a comprehensive list for this meeting)
16:07:21 <jberkus> ok, starting
16:07:27 <miabbott> .hello miabbott
16:07:29 <zodbot> miabbott: miabbott 'Micah Abbott' <miabbott@redhat.com>
16:07:32 <jberkus> #topic Centos Atomic Host release
16:07:46 <jberkus> jbrooks: quick summary of last week's release?
16:08:09 <jbrooks> It was the one that matched us up w/ the 7.4 stream
16:08:25 <jbrooks> The biggest thing for users was overlay storage support
16:08:25 <jberkus> (jbrooks: ageed, it's a little wierd, but meetbot is too useful to pass up)
16:08:41 <jbrooks> The default is still devicemapper, but you can convert
16:08:42 <jberkus> jbrooks: yes, which means I can now rebase from CAH to FAH and back.
16:08:43 <tsweeney_> dwalsh is on the road today, not sure he'll join.
16:08:50 <jberkus> tsweeney_: ok
16:09:07 <jbrooks> We're going to have another small release probably this week, because CentOS is on a monthly release schedule
16:09:21 <jbrooks> We held the last one up a bit to get the 7.4 bits in
16:09:26 <maxamillion> .hello maxamillion
16:09:27 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
16:09:27 <maxamillion> sorry
16:09:30 <maxamillion> distracted
16:09:50 <jberkus> jbrooks: ok, thanks
16:10:07 <jberkus> #topic CRI-O on Atomic Host
16:10:17 <maxamillion> mmmmm ... cri-o
16:10:25 <jberkus> I'd like to make sure that there's some documented way for AH users to run CRI-O
16:10:51 <jbrooks> https://github.com/projectatomic/atomic-system-containers/tree/master/cri-o-fedora
16:10:55 <jberkus> should we be promoting layering, or working on a system container ...
16:10:57 <jbrooks> There's one for centos, too
16:11:03 <jberkus> jbrooks: wow, way ahead of me
16:11:09 <jberkus> jbrooks: wanna do a blog post?
16:11:17 <jberkus> jbrooks++
16:11:17 <zodbot> jberkus: Karma for jasonbrooks changed to 5 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:11:18 <jbrooks> That container image isn't in FLIBS
16:11:28 <dustymabe> jbrooks: can we get it there?
16:11:58 <jbrooks> I asked Jerry about it last week, he's too busy, but I'm going to ping giuseppe about whether he wants to submit it, or I can also submit it
16:12:25 <jbrooks> jberkus, I will write a post about it
16:12:26 <dustymabe> would be good to get the container image in FLIBS and then publish blog post
16:12:40 <jberkus> yah
16:12:54 <jberkus> #action jbrooks or giuseppe to submit cri-o container image to FLIBS
16:12:56 <jbrooks> jzb had asked me to write something about crio and kube or origin, so it's been on my list
16:13:09 <jberkus> #action jbrooks to write blog about cri-o on AH
16:13:39 <jberkus> might be worth doing one just on cri-o, and then one on origin on cri-o on AH ...
16:13:46 <jberkus> lemme know if you want help
16:13:46 * dustymabe notes these topics/action items seem very similar to something we would discuss in the fedora atomic working group meeting
16:14:02 <jberkus> dustymabe: yah, but they're cross-project
16:14:19 <jberkus> #action dustymabe to add CRI-O to FAH-WG agenda
16:14:20 <jbrooks> jberkus, And I can get it into the centos registry, too
16:14:23 <dustymabe> i agree and disagree :)
16:14:35 <jberkus> ok, anything else on CRI-O?
16:14:46 * ashcrow raises his hand
16:14:54 <jberkus> ashcrow: just type
16:15:03 <ashcrow> jbrooks: I spoke with Jerry about it as well this weekend. We are looking on how we can keep these Dockerfiles in sync ...
16:15:22 <ashcrow> right now we have a burned of trying to keep the files sync'd across 4 repositories which we should nail down before adding new ones IMHO
16:15:24 <jbrooks> ashcrow, yeah, it's kind of a pain
16:15:43 <ashcrow> Just FYI, that is all :-)
16:15:44 <jbrooks> I'm experiencing that w/ kube
16:16:05 <jberkus> 4 repositories?
16:16:22 <ashcrow> I think we will need a process, a tool, or both in the future to avoid the burden
16:16:54 <ashcrow> jberkus: correct, github, fedora, rhel build and centos.
16:17:03 <jberkus> gah
16:17:08 <ashcrow> each want's it's own copy
16:17:23 <jberkus> yah, sounds like we could use a tool if we can't merge any of those
16:17:26 <ashcrow> so a bug fix in one means it has to be merged with whatever requirements have been done to make them happy in other repos
16:17:28 <jbrooks> CentOS could use the upstream one, I think
16:17:43 <jbrooks> Based on how it works -- not all the containers are hosted in the same repo
16:18:44 <ashcrow> I'll start a thread so we can design something together and head this off before support burden gets too large
16:19:03 <ashcrow> right now guiseppe, jerry and I are manually trying to keep it all in sync :-D
16:19:09 <jberkus> #action ashcrow jbrooks to start discussion on how to manage multiple container repos
16:19:24 <jberkus> ashcrow: yah, that doesn't scale. and outside contributors wouldn't go near it
16:19:29 <ashcrow> +1
16:20:35 <jberkus> ok
16:20:41 <maxamillion> +1
16:21:05 <jberkus> #topic container for openshift-ansible
16:21:45 <jberkus> openshift-ansible is the installer for origin, but last I checked there's no official container image for it.  anyone know if there's progress on such, and where we can track it?
16:22:03 <maxamillion> question, why do we want that in a container?
16:22:20 <ashcrow> There is, I'll get a link
16:22:29 <jberkus> maxamillion: among other things, so that you can run it on Atomic
16:22:42 <jbrooks> https://github.com/openshift/openshift-ansible/blob/master/README_CONTAINER_IMAGE.md
16:22:46 <jberkus> maxamillion: also to avoid the installation requirements for a desktop install
16:22:48 <ashcrow> This is the code base https://github.com/openshift/openshift-ansible/tree/master/images/installer
16:23:00 <jberkus> ashcrow, jbrooks thanks!
16:23:04 <maxamillion> yeah, alright ... I guess
16:23:21 <ashcrow> The openshift team also likes the idea that they can stop debugging the environment for library requirements/missing items which today are required to be done before you can use the installer.
16:23:26 <jberkus> maxamillion: why do we want anything in a container?
16:23:45 <jberkus> maxamillion: o-a seems like a perfect example of an app that needs containerization
16:23:55 <jberkus> ashcrow: exactly
16:23:57 <ashcrow> it switches the python lib requirements and versioning to 'do you have docker or runc? you're set!'
16:24:00 <maxamillion> jberkus: no, I know ... but to me it's just a playbook, but the dep chain to run the playbook makes sense
16:24:42 <jberkus> #action jberkus to check into openshift-ansible container, write issues or look at FLIBS/CP inclusion
16:24:55 <maxamillion> ashcrow: not in Fedora land it doesn't, if the python libs aren't in Fedora properly then you still have the same issue ... but that's a Fedora problem and not a Project Atomic one
16:25:12 <dustymabe> i'm just wondering why the o-a team can't produce the containres
16:25:37 <maxamillion> dustymabe: I'm sure they could, they make a bunch of other containers
16:25:56 <dustymabe> i'm just saying. there are so many 'releases' involved with that code
16:26:12 <dustymabe> i wouldn't dare sign up to create a container for it
16:26:21 <jberkus> they probably should.  but if we want them for public FLIBS or CP spec, we might need to help with the initial setup
16:26:27 <dustymabe> unless you want to be doing a lot of release engineering work
16:27:05 <jberkus> #topic website migrations
16:27:14 <dustymabe> honestly I think the better thing would be to have an ansible container
16:27:17 <maxamillion> dustymabe: yeah, fair point
16:27:20 <dustymabe> produced by the ansible team
16:27:38 <dustymabe> and as long as you are running o-a using the official ansible container, then you are good to go
16:27:39 <jberkus> dustymabe: yes.  I have no ability to make that happen, though  Have asked.
16:27:45 <maxamillion> dustymabe: that wouldn't satisfy the needs of openshift-ansible though, that playbook set needs stuff beyond just ansible deps to run
16:27:50 <dustymabe> cool i'll be quiet now
16:28:03 <jberkus> #topic website migrations
16:28:24 <jberkus> as Openshift v2 is shutting down, we're going to migrate the project atomic websites to OpenShift v3
16:28:31 <jberkus> over the next 2 months
16:28:36 <jberkus> here's a summary of what's going to happen
16:28:37 <maxamillion> +1
16:28:52 <jberkus> www.pa.io will move to container CI/CD build on OSv3
16:29:01 <walters> jberkus, one can certainly install openshift-ansible via yum in a container on an Atomic Host
16:29:33 <jberkus> docs.pa.io will move to a new CICD docs system being developed by the Openshift docs team
16:29:39 <jberkus> on OSv3
16:29:52 <jberkus> we will be adding a planet.projectatomic.io
16:29:56 <jberkus> for blog aggregation
16:30:21 <jberkus> ask.projectatomic.io will be going away (more on this later)
16:30:28 <walters> in general i think it's better to execute ansible from a container, though one does have to consider ssh key access
16:30:51 <jberkus> commisaire.io and cockpit.io and cri-o sites will stay on github pages for now
16:31:13 <jberkus> unless the owners of those sites want to move them
16:31:45 <jberkus> questions:
16:32:28 <jberkus> 1) as part of the move of www.pa.io, we're looking at moving to Jeckyll instead of Middleman for site generation.  Does anyone care about platforms, or can that be left up to the OSAS infra team?
16:33:13 <ashcrow> Personally, no objection
16:33:38 <jberkus> walters: if that already works, can you write it up?
16:33:51 <jberkus> ok, I'll take it as a "no" for (1)
16:34:18 <walters> i've definitely been thinking we need a document about the "pet container" pattern and tips and tricks
16:34:26 <jberkus> 2) do any of the owners of commisaire, cri-o, cockpit sites want to move off gitbub pages to OSv3 in the near future?
16:34:59 <ashcrow> commissaire: We're fine staying on github for the time being
16:35:50 <jberkus> 3) are there sites I'm missing from that list?
16:36:58 <jberkus> ... so is that "no" to everything?
16:37:00 <jberkus> assuming so
16:37:58 <dustymabe> anything else?
16:38:03 <jberkus> finally, is anyone interested in helping with the migrations?
16:38:40 <jberkus> dustymabe: there's one more agenda item
16:38:42 <dustymabe> jberkus: i've showed you what I do for my personal setup - if you are interested in picking my brain on that, LMK
16:38:47 <jberkus> dustymabe: sure
16:38:56 <jberkus> #topic shutting down Ask
16:39:15 <jberkus> as part of the website migration, we're going to shut down Ask.pa.io and direct people to Server Fault instead
16:39:33 <jberkus> question: should we flip ask to read-only and retain it, or should we delete it entirely?
16:40:12 <dustymabe> i have no preference
16:40:47 <jberkus> my inclination is to delete it
16:40:49 <ashcrow> Unless there are current, active users of ask I'd say delete.
16:40:58 <jberkus> it has no real google rank, and the answers on there are very dated
16:41:08 <jbrooks> I'm fine w/ deleting it
16:41:10 <jberkus> and it would be one less site to manage
16:41:13 <jberkus> ok, passed
16:41:25 <jberkus> #action jberkus to delete ask.projectatomic.io by end of year
16:41:44 <jberkus> #topic open floor
16:41:57 <jberkus> other topics?  I have one, but someone else should speak
16:42:36 <tsweeney_> As far as deleting action.projectatomic.io goes, is there a place we can put a headline warning that the site will be going away?  And once gone can we put in a redirect type of page?
16:43:50 <jberkus> tsweeney_: good question, I have an issue open with OSAS infra about that
16:44:09 <jberkus> I planned to redirect to a general "getting help" page
16:44:46 <tsweeney_> kk, just in case we've a few hold outs come january, it would be nice to move them along rather than 404.
16:45:58 <jberkus> yah
16:46:31 <jberkus> anything from anyone else?  if not, I have one more question
16:46:45 <jberkus> dustymabe: did you have something?
16:47:18 <dustymabe> nope
16:47:40 <jberkus> ok, last question:
16:47:49 <jberkus> we have some Github projects which are now obsolete
16:48:19 <jberkus> should I create a projectatomic-archive namespace and move them to that, to indicate that they're not maintained and declutter the main projectatomic namespace?
16:49:08 <ashcrow> I like that idea
16:49:11 <jbrooks> +1
16:49:20 <dustymabe> +1
16:49:36 <jberkus> ok
16:49:46 <jberkus> #action jberkus to create projectatomic-archive namespace on github
16:50:03 <jberkus> #action jberkus to start discussion of which projects to archive on atomic-devel
16:50:12 <jberkus> ok, if that's all
16:51:14 <dustymabe> lunch calls
16:51:31 <jberkus> #endmeeting