atomic_community
LOGS
16:02:35 <jberkus> #startmeeting atomic_community
16:02:35 <zodbot> Meeting started Mon Jul 24 16:02:35 2017 UTC.  The chair is jberkus. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:35 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:02:35 <zodbot> The meeting name has been set to 'atomic_community'
16:02:35 <centbot> Meeting started Mon Jul 24 16:02:35 2017 UTC.  The chair is jberkus. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:35 <centbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:02:44 <jberkus> #topic roll call
16:03:06 <dustymabe> .hello dustymabe
16:03:07 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
16:03:11 <aweiteka> .hello aweiteka
16:03:14 <zodbot> aweiteka: aweiteka 'Aaron Weitekamp' <aweiteka@redhat.com>
16:03:24 <jberkus> .hello jberkus
16:03:25 <zodbot> jberkus: jberkus 'Josh Berkus' <josh@agliodbs.com>
16:03:53 <jlebon> .hello jlebon
16:03:54 <zodbot> jlebon: jlebon 'None' <jlebon@redhat.com>
16:04:10 <dustymabe> dwalsh rangerpb ashcrow-afk walters giuseppe miabbott - atomic community meeting
16:04:23 <miabbott> .hello miabbott
16:04:24 <zodbot> miabbott: miabbott 'Micah Abbott' <miabbott@redhat.com>
16:05:08 <jbrooks> .hello jasonbrooks
16:05:09 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
16:05:29 <jberkus> #chair dustymabe jbrooks jberkus miabbott jlebon aweiteka
16:05:29 <zodbot> Current chairs: aweiteka dustymabe jberkus jbrooks jlebon miabbott
16:05:29 <centbot> Current chairs: aweiteka dustymabe jberkus jbrooks jlebon miabbott
16:06:13 <jligon> .hello jligon
16:06:16 <zodbot> jligon: jligon 'Jeff Ligon' <jligon@redhat.com>
16:06:30 <jberkus> #chair dustymabe jbrooks jberkus miabbott jlebon aweiteka jligon
16:06:30 <zodbot> Current chairs: aweiteka dustymabe jberkus jbrooks jlebon jligon miabbott
16:06:30 <centbot> Current chairs: aweiteka dustymabe jberkus jbrooks jlebon jligon miabbott
16:06:49 <jberkus> #topic fate of Atomic Registry
16:07:29 <aweiteka> sadly, “fate” is the appropriate word. i’ll provide a recap of where we are…
16:08:09 <dwalsh> .hello dwalsh
16:08:10 <zodbot> dwalsh: dwalsh 'Daniel J Walsh' <dwalsh@redhat.com>
16:08:10 <aweiteka> in short, atomic registry is really just the openshift internal registry.
16:08:16 <jberkus> #chair dustymabe jbrooks jberkus miabbott jlebon aweiteka jligon dwalsh
16:08:16 <zodbot> Current chairs: aweiteka dustymabe dwalsh jberkus jbrooks jlebon jligon miabbott
16:08:16 <centbot> Current chairs: aweiteka dustymabe dwalsh jberkus jbrooks jlebon jligon miabbott
16:08:38 <aweiteka> the piece we were maintaining is really just a simple deployment method that is now better served by minishift and oc cluster up methods.
16:09:21 <aweiteka> the deployment doesn’t always work and we don’t have maintainers to resolve issues. so we need to do the right thing to direct people to use supported methods.
16:09:38 <aweiteka> the question is, how do we make this happen?
16:10:07 <jberkus> aweiteka: well, there's two places we cover registry
16:10:18 <jberkus> (1) github and (2) pa.io/docs
16:10:29 <aweiteka> we’ve pulled atomic registry from projectatomic.io home page. so that’s good.
16:11:13 <jberkus> basically we need to (a) update the github README and (b) replace current docs with a page explaining how to do the self-container openshift registry
16:11:23 <jberkus> er, self-contained
16:11:28 <aweiteka> we have this landing page, first hit on goog http://www.projectatomic.io/
16:11:34 <aweiteka> er… http://www.projectatomic.io/registry/
16:12:14 <aweiteka> i can update that page ^^ with oc cluster up/minishift opts. should we remove the docs page yet? http://docs.projectatomic.io/registry/
16:12:44 <jberkus> question: is the registry github still the development place for the openshift registry?
16:12:58 <jbrooks> minishift isn't even using atomic though, right?
16:13:20 <jzb> jbrooks: last I looked, no
16:13:22 <aweiteka> source is here: https://github.com/openshift/origin/tree/master/examples/atomic-registry
16:13:38 <jbrooks> I think we should point to something that someone can run on atomic -- wasn't there a howto about setting the origin-based registry
16:13:45 <aweiteka> i don’t understand the question: “minishift isn’t even using atomic”? what does that mean?
16:13:56 <aweiteka> you can’t run minishift on atomic host?
16:13:59 <aweiteka> or…?
16:14:03 <jbrooks> minishift is about running origin on a vm, righy?
16:14:05 <jbrooks> right
16:14:21 <jzb> jbrooks: I think there are options to swap out the ISO it uses
16:14:24 <aweiteka> ok, so oc cluster up is our recommendation for atomic?
16:14:28 <jzb> whether it will work on Atomic or not, I'm not sure.
16:14:36 <jzb> s/on/with/
16:15:09 <jbrooks> oc cluster up gives you a full single node origin setup -- ppl who are running kubernetes on atomic will want a registry option
16:15:27 <jbrooks> I think that's the sort of person who had been asking for help w/ atomic-registry
16:15:41 <aweiteka> oc cluster up includes registry last i checked, no?
16:16:03 <jberkus> yeah, but that's not a production registry, is it?
16:16:14 <jbrooks> So you're running a kube cluster, and you want a registry, so alongside that you run a dev-mode origin cluster
16:16:18 <jberkus> I mean, oc cluster up is only suitable for demos right now, no?
16:16:34 <jbrooks> Maybe we don't have an answer for this
16:16:35 <aweiteka> atomic registry was never an HA production solution
16:17:13 <aweiteka> oc cluster up is very similar to what atomic registry installer was doing, similar deployment arch
16:17:15 <jbrooks> I think that it seemed like we did have an answer, w/ the presence and promotion of atomic registry
16:17:46 <jbrooks> I guess it points to the need for some sort of incubation area for project atomic, so it's less disruptive when things like this or atomicapp die
16:18:14 <aweiteka> fair. i was involved in both. what does that say about me ?!?!
16:18:17 <aweiteka> :)
16:18:26 <jbrooks> You're dynamic!
16:18:31 <aweiteka> haha
16:18:32 <whenry> :)
16:18:51 <jbrooks> Heh, it's no big deal, but I think we do need to message better when we come out w/ new things that might go away
16:18:53 <jberkus> trying to find blog post now
16:19:14 <jzb> jbrooks: even MS Paint goes away eventually ;-)
16:19:23 <jberkus> jbrooks: true, although that pretty much describes the entire container ecosystem
16:19:25 <whenry> I still don't understand the issues based on this thread. Atomic registry not really ready? Only works running a certain way? Disrupting some other activities?
16:19:38 <whenry> based on lifecycle
16:20:00 <jberkus> whenry: we're looking for an option for users who want the registry but don't want a full openstack setup
16:20:00 <whenry> It's going away?
16:20:02 <aweiteka> whenry: it’s broken right now, no maintainers, oc cluster up provides a more stable deployment, similar arch
16:20:15 <whenry> ack or a full Openshift setup… correct?
16:20:39 <jberkus> what's wrong with this method?  http://www.projectatomic.io/blog/2017/05/oo-standalone-registry/
16:21:18 <whenry> Are we assuming that someone that wants an Atomic Registry is doing openshift or raw Kubernetes?
16:21:33 <aweiteka> that ^^ was an attempt to move folks off of atomic registry. a very solid deployment method, openshift-ansible.
16:21:47 <aweiteka> a good step down the path for atomic host users.
16:22:12 <dustymabe> dmsimard: was also using that method I think
16:22:29 <dmsimard> o/
16:22:42 <dmsimard> nothing wrong, we've been running a standalone registry in production for a while and it's been working great for us
16:22:53 <aweiteka> that’s probably the best place to point people that’s not just “sorry, atomic community has nothing for you. go to another community”
16:22:57 <dmsimard> although I still need to merge two PRs
16:23:18 <dmsimard> also still need to write about it :/
16:24:15 <jberkus> aweiteka: so for oc cluster up, (1) is there a way to activate/use just the registry (2) to use that registry for external services (Kube, Swarm, etc.) (3) to run it on Atomic Host?
16:24:59 <aweiteka> i think we’re covered for all cases. we should verify
16:25:22 <jberkus> ok.  could you?
16:25:33 <jberkus> if so, then it's just a matter of writing a doc
16:26:39 <strigazi> .hello strigazi
16:26:40 <zodbot> strigazi: strigazi 'Spyros Trigazis' <strigazi@gmail.com>
16:26:41 <aweiteka> sure, i can do that. the “doc” will be lean to minimize maintance, pointing to other docs for details
16:27:35 <dustymabe> #chair strigazi
16:27:35 <zodbot> Current chairs: aweiteka dustymabe dwalsh jberkus jbrooks jlebon jligon miabbott strigazi
16:27:35 <centbot> Current chairs: aweiteka dustymabe dwalsh jberkus jbrooks jlebon jligon miabbott strigazi
16:28:21 <jberkus> #action aweiteka to verify that oc cluster up can be used for standalone registry
16:28:39 <jberkus> #action jberkus to replace Registry docs on pa.io with standalone blog post
16:28:51 <aweiteka> ack
16:29:23 <jberkus> #action jberkus to look into replacing docs.projectatomic.io/registry with directive to that standalone page
16:29:32 <aweiteka> jberkus: i recommend pointing folks to miabbott ’s blog as well: http://www.projectatomic.io/blog/2017/05/oo-standalone-registry/
16:29:45 <jberkus> do we want to announce this?
16:29:59 <aweiteka> since openshift-ansible is the basis for production installs.
16:30:30 <jberkus> aweiteka: we really really need an openshift-ansible contianer image
16:30:35 <jberkus> but that's a task for another time ...
16:30:48 <aweiteka> #action aweiteka to clear some lingering atomic registry GH issues
16:31:13 <jberkus> ok, ready for next topic?
16:31:24 <jberkus> #topic mailing lists and IRC channels
16:31:56 <jberkus> we're going through a bunch of changes to our social media
16:32:16 <jberkus> here's the changes planned, which involve using the #atomic stuff more
16:32:35 <jberkus> - fedora atomic host team will be using this channel #atomic as its main discussion channel
16:32:51 <jberkus> - same for centos atomic host (mainly for meetings on monday nights)
16:33:21 <jberkus> - fedora atomic team will be moving to using atomic-devel as primary "discussion" mailing list
16:33:58 <jberkus> some questions:
16:34:37 <jberkus> 1. we'd like to move atomic-devel@pa.io to fedora infra, in order to get it running on Mailman 3.  Does anyone see a problem with this?
16:35:10 <dustymabe> jberkus: only thing I'd like to make sure of is that we can keep our domain name
16:35:42 <jberkus> 2. do we have too many mailing lists?  atomic@ is particularly anemic.  should we be directing people to atomic-devel instead?
16:36:19 <jberkus> or, alternately, should we just consolidate atomic@ and atomic-announce@?
16:36:20 <jzb> jberkus: not problem, but you'll need to work with misc to move DNS
16:36:52 <jzb> or just set up MX anyway
16:37:02 <dustymabe> for #2 - i think it makes sense to send atomic@ people to atomic-devel
16:37:16 <jberkus> yeah, there may be technical issues, I still need to talk to some folks in fedora infra.  I was more asking if there were problems people can see from this group, especially socially.
16:37:21 <dustymabe> we can revisit if we start getting heavy traffic
16:38:07 <dustymabe> jberkus: should we start using a 'meeting' channel for this meeting since this is now a primary discussion channel for more people?
16:38:09 <jbrooks> jberkus, I'm +1 to redirecting atomic ppl to atomic-devel
16:38:29 <jberkus> dustymabe: I'd like to wait on that and see if there's an actual problem
16:38:31 <dustymabe> like i have a question I'd like to ask someone right now, but we're in the middle of a meeting
16:39:22 <jbrooks> I think we can wait -- having meetings in the main channel is the norm for projects other than fedora -- I think it helps w/ visibility
16:39:47 <jberkus> oh, one other thing on social media
16:39:50 <dustymabe> off to #fedora-atomic I go :)
16:39:58 <jberkus> CRI-O has launched a blog on Medium
16:40:07 <jberkus> we'll let people know how that works out
16:40:36 <jberkus> ok, last topic
16:40:43 <dustymabe> jberkus: i assume the pa twitter will be promoting that content?
16:40:50 <jberkus> dustymabe: yes
16:41:01 <jberkus> #topic kubernetes-sig
16:41:05 <jberkus> dustymabe?
16:41:11 <jberkus> or, better, jbrooks
16:41:16 <dustymabe> :)
16:41:45 <jbrooks> We've split off a kubernetes sig from the fedora atomic sig. There's an issue tracker here: https://pagure.io/atomic/kubernetes-sig
16:42:07 <dustymabe> so it's under the atomic umbrella, but focused on k8s
16:42:18 <dustymabe> so that people who just care about kube can work through issues there
16:42:33 <dustymabe> this was an attempt to engage kubernetes community members more directly
16:42:43 <dustymabe> s/was/is/
16:42:49 * dustymabe waves at strigazi
16:42:56 <strigazi> :)
16:44:10 <jberkus> note that, while this is a fedora project, it's intended to include kubernetes-on-CAH as well
16:44:11 <dustymabe> EOM
16:44:17 <jbrooks> I think that's all for that -- we can raise issues that require discussion in these meetings
16:44:26 <jberkus> since we'll need a bunch of the same plumbing for both
16:44:31 <jbrooks> right
16:44:44 <dustymabe> jbrooks: jberkus sure - i see them mostly overlapping
16:44:59 <jberkus> ok, open floor
16:45:03 <jberkus> #topic open floor
16:45:06 <jberkus> anyone?
16:45:18 <dustymabe> jberkus: docs VFAD
16:45:23 <dustymabe> mind mentioning it
16:45:27 <jberkus> yes!
16:45:36 <jberkus> we're doing a Fedora Atomic docs VFAD on Friday
16:45:42 <jberkus> dustymabe: do we have a link for htat?
16:45:56 <dustymabe> https://pagure.io/atomic-wg/issue/294
16:46:20 <jberkus> hmmm, we need to put up a wiki page
16:46:42 <jberkus> anywya, we'll be organizing the Atomic Host docs
16:46:51 <jberkus> so all are encouraged to attend
16:47:38 <jberkus> anything else?
16:48:15 <dustymabe> countdown
16:48:20 <jberkus> 5
16:48:21 <jberkus> 4
16:48:22 <jberkus> 3
16:48:24 <jberkus> 2
16:48:25 <jberkus> 1
16:48:30 <jberkus> ok, thanks for meeting!
16:48:34 <jberkus> #endmeeting