ansible_windows_working_group
LOGS
19:59:59 <nitzmahone> #startmeeting Ansible Windows Working Group
19:59:59 <zodbot> Meeting started Tue Oct  6 19:59:59 2020 UTC.
19:59:59 <zodbot> This meeting is logged and archived in a public location.
19:59:59 <zodbot> The chair is nitzmahone. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:59:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:59:59 <zodbot> The meeting name has been set to 'ansible_windows_working_group'
20:00:03 <jborean93> oof
20:00:03 <nitzmahone> bah
20:00:08 <nitzmahone> #chair jborean93
20:00:08 <zodbot> Current chairs: jborean93 nitzmahone
20:00:17 <jborean93> missed it by that much
20:00:31 <briantist> hey hey
20:00:34 <nitzmahone> howdy
20:00:36 <jhawkesworth> Hey
20:00:41 <nitzmahone> hey Jon!
20:01:19 <jborean93> hey
20:01:32 <jhawkesworth> Heya. Still finishing kids bedtime but keeping half an eye out
20:01:33 <nitzmahone> There's actually something on the agenda!
20:01:38 <nitzmahone> #topic https://github.com/ansible/community/issues/517#issuecomment-703943913
20:01:38 <jhawkesworth> Yay
20:01:41 <jborean93> \o/
20:02:04 <nitzmahone> so first: https://github.com/ansible-collections/ansible.windows/pull/113
20:03:36 <jborean93> I've yet to actually review it but I'm personally fine with the concept
20:03:58 <jborean93> probably good to document/test that an empty string/null value for a key will unset the env vr
20:04:16 <nitzmahone> Same- I might have some comments about the return value, but def +1 on concept and impl at a glance
20:04:30 * nitzmahone adds to review queue
20:05:05 <briantist> happy to answer any questions, doesn't have to be reviewed here just figured I'd post it in case to get some 👀
20:05:27 <nitzmahone> +1
20:05:34 <jborean93> sounds good to me
20:05:56 <jhawkesworth> I will take a look but also like the general idea
20:05:58 <briantist> `probably good to document/test that an empty string/null value for a key will unset the env vr` I think that would throw an error actually (same as before), and I think there's already a test for it, but I will take a look to confirm
20:07:07 <jborean93> coupled with state it doesn't make sense, I just konw that setting an env var using that .NET method with an empty string as a value will unset the var. I can't remember what logic we had to check that though
20:07:07 <nitzmahone> Also the Hacktoberfest thing- anything you want to add about that briantist?
20:07:46 <nitzmahone> (well, anything else about the win_environment PR first, I guess)
20:07:56 <nitzmahone> Nothing else from me on that one until I review
20:08:06 <briantist> sure, it's a fun thing but it started out across all of github and then I guess that generated a lot of spam
20:08:53 <nitzmahone> So is that a "maybe we shouldn't", or >?
20:08:58 <briantist> so now it's opt-in only, and for your PRs to count, either the project needs the `hacktoberfest` topic, or the individual PR needs `hackertoberfest-accepted` label
20:09:14 <briantist> no I think we should, if possible
20:09:19 <jborean93> trouble is I believe you need to be a maintainer to add topics
20:09:37 <jborean93> sorry I'm thinking labels
20:09:37 <briantist> right, hence why I'm asking here :)
20:09:54 <nitzmahone> Topics too, I think, but that's not a problem ;)
20:10:09 <nitzmahone> I'd probably lean toward the topic over the label
20:11:22 <jborean93> I'm fine with doing it, I just have no idea what is expected for us
20:11:29 <nitzmahone> Probably actually a better topic for the main meeting and a gundalow question, but I'm +1 for it
20:11:36 <briantist> same, I lean toward topic, but if there was opposition I was going to ask for the  labels on my own PRs :-p
20:12:17 <briantist> nothing expected as far as I know except to maybe mark some PRs as spam if they in fact are (but that seems rare at least on the Windows repos)
20:12:24 <nitzmahone> Probably just a little extra attention to new PRs during October; people get credit for them if they're at least approved in a properly-topic'd project IIUC
20:12:30 <gundalow> Oh, yes, should be addex
20:12:36 <gundalow> Added
20:12:41 <briantist> yeah I thought I'd test the waters here and maybe bring it up to the larger meeting
20:12:50 <briantist> oh hey gundalow
20:12:56 <nitzmahone> October's getting away from us quickly ;)
20:13:01 <jhawkesworth> Hey gundalow
20:13:41 <nitzmahone> I'm less excited about it for ansible/ansible, but def for the collection repos
20:13:52 <gundalow> If someone wants to add it go for it
20:14:15 <briantist> nitzmahone yeah that makes sense with the much smaller scope of ansible/ansible now
20:14:23 <gundalow> I'm happy with it on collections and ansible/ansible
20:14:41 <gundalow> Though if others don't want it in a/a I'm OK with that
20:14:49 * gundalow drops offline again
20:14:50 <nitzmahone> gundalow: only issue there is it needs a repo owner to do it- I don't know who's got enough perms on the various collection repos to do that
20:14:58 <gundalow> OK
20:15:03 <nitzmahone> (not me, anyway)
20:15:10 <gundalow> What's the exact string that needs adding?
20:15:14 <jborean93> yea I only have admin on the Windows ones
20:15:55 <briantist> one sec finding the page with the exact string
20:17:31 <nitzmahone> IIRC it's `hacktoberfest` in the `topics` section of the main repo page (under "About")
20:17:40 <briantist> https://hacktoberfest.digitalocean.com/details
20:17:47 <briantist> yup that's it nitzmahone
20:18:02 <nitzmahone> (so click the gear on "About", then add `hacktoberfest` under "topics")
20:19:13 <nitzmahone> OK, we'll try to make that happen on the collection repos
20:19:20 <nitzmahone> #topic open floor
20:19:27 <briantist> thanks folks!
20:20:11 <gundalow> Added for the main ones
20:20:20 <briantist> woot! thanks gundalow
20:20:28 <jborean93> nothing to add for me
20:21:12 * gundalow reminds people it's Ansible Fest next week, and main Contributors Summit in Thursday 15th
20:21:47 <nitzmahone> Yeah, I think we aren't doing regular IRC meetings next week due to fest
20:22:17 <nitzmahone> #action nitzmahone will set room topic to reflect no meeting next week
20:23:01 <nitzmahone> briantist / jhawkesworth are you planning to do virtual fest and/or contrib summit  next week?
20:23:11 <jhawkesworth> Hope it's a good one. Up to ears, unlikely to be doing anything fest related this time
20:23:12 <nitzmahone> Would be fun to see yall
20:23:17 <jhawkesworth> Sad face
20:23:20 <nitzmahone> :(
20:23:29 <briantist> I keep meaning to look into it, I would like to, at least at some level
20:23:32 <briantist> thanks for the reminder!
20:23:41 <nitzmahone> It's free, can't beat the price or convenience :)
20:24:01 <jborean93> except when you don't live in a useful timezone :)
20:24:20 <nitzmahone> It's not gonna be quite the same, though the contrib summit will be arguably better virtual, since there's no "in room discussion" that's hard for remote folks to hear
20:24:27 <briantist> is there a separate sign up for each?
20:24:30 <nitzmahone> yeah
20:26:13 <nitzmahone> https://www.reddit.com/r/ansible/comments/j2tven/the_bullhorn_issue_eleven/
20:26:24 <nitzmahone> IIRC the contrib summit links are in there --^
20:26:32 <nitzmahone> (you probably don't care about the Monday thing)
20:27:00 <nitzmahone> more direct link: https://github.com/ansible/community/wiki/Contributor-Summit
20:28:38 * nitzmahone should probably just subscribe to that, because I'm missing a bunch of stuff
20:28:48 <nitzmahone> OK, well, if nothing else, we'll close in 2!
20:29:08 <nitzmahone> #info contrib summit info at https://github.com/ansible/community/wiki/Contributor-Summit
20:29:57 <jhawkesworth> Cheers for the links. If a miracle occurs and my time frees I will see if I can join for a bit
20:30:13 <nitzmahone> noice
20:30:39 <jhawkesworth> Otherwise, have a good time. Cheers
20:31:32 <nitzmahone> Thanks all, until next week!
20:31:35 <nitzmahone> #endmeeting