ansible_windows_working_group
LOGS
20:00:00 <nitzmahone> #startmeeting Ansible Windows Working Group
20:00:00 <zodbot> Meeting started Tue Apr 30 20:00:00 2019 UTC.
20:00:00 <zodbot> This meeting is logged and archived in a public location.
20:00:00 <zodbot> The chair is nitzmahone. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:00 <zodbot> The meeting name has been set to 'ansible_windows_working_group'
20:00:18 <nitzmahone> right on the dot- I should win a prize
20:00:27 <jhawkesworth> hey
20:00:33 <nitzmahone> #chair jborean93 jhawkesworth
20:00:33 <zodbot> Current chairs: jborean93 jhawkesworth nitzmahone
20:00:35 <ShachafGoldstein> hi
20:00:37 <nitzmahone> Sup Jon!
20:00:46 * jhawkesworth grants nitzmahone magical on-time award
20:00:58 <jborean93> hey
20:01:02 <jhawkesworth> hey back from some away-from-screen time
20:01:33 <jhawkesworth> how's it goin'?
20:01:47 <jborean93> not too bad, how about yourself
20:02:16 <nitzmahone> (we'll give it another minute or so before diving in)
20:02:28 <jhawkesworth> yeah good to have a break, more energy for everything now
20:03:06 <nitzmahone> Hey Jon, I'm bringing the family to the UK for a few weeks in August- I'll buy you a beer or something if you're around
20:03:46 <jhawkesworth> that would be awesome, a few family commitments in August but would be great to catch up
20:04:02 <jhawkesworth> I don't think I'm going to make to 'fest this year
20:04:19 <nitzmahone> We'll chat more when it gets closer
20:04:28 <nitzmahone> OK, let's get to it
20:04:30 <jhawkesworth> great
20:04:39 <nitzmahone> #topic https://github.com/ansible/community/issues/420#issuecomment-487778153
20:05:23 <jhawkesworth> looks like a good thing to land early on in dev cycle
20:05:39 <jborean93> I've put some feedback on the original PR that is still relevant to changes in here
20:05:49 <jborean93> Don't particularly want to review it again for the same things
20:05:53 <Shachaf92> Ill check them out
20:06:16 <Shachaf92> the original got messed up with too many irrelevent changes
20:06:40 <jhawkesworth> other than a trailing ; I didn't spot anything out of place
20:06:54 <jborean93> be extra careful with the WMI to CIM cmdlet changes. There's some slight behaviour differences that could bite us
20:07:12 <Shachaf92> this PR actually passes all integ tests
20:07:22 <nitzmahone> Doesn't mean it's not breaking stuff
20:07:27 <Shachaf92> and im very familiar with the changes so all should be good
20:07:40 <nitzmahone> Test coverage is all over the place, so that's not always the best indicator ;)
20:07:43 <Shachaf92> yeah but im still happy about that
20:07:56 <nitzmahone> In general we're OK with this sort of thing when it's noninvasive and fixing rules we want to enforce, but we should probably talk about more invasive things like what it sounds like you're proposing for the future...
20:08:30 <jhawkesworth> hmm, wondering why the ci failed...
20:08:33 <Shachaf92> yeah, i don't mind moving to other stuff if it's not really something you want to solve atm
20:08:34 * jhawkesworth goes to look
20:08:53 * bcoca removes random_fail() function from CI
20:09:10 <Shachaf92> the last ci failed on a network miss in one test, checked it before but i don't know how to make ot run without a push
20:09:25 <jborean93> you can just close and reopen a PR to rerun the tests
20:09:34 <jborean93> otherwise you can push an empty commit, just a bit more work
20:09:35 <Shachaf92> great
20:10:01 <Shachaf92> yeah i just spen 10 minutes understanding how to squash all my commits to make it pretty
20:10:02 <bcoca> jborean93: he, i find the latter 'less work'
20:10:35 <jborean93> keep in mind, we can't get rid of all the ignored rules in modules. Some are there for a reason
20:10:41 <Shachaf92> btw, do you know the ssl binding section never really got implemented in the website module?
20:10:45 <jborean93> but trimming down that list is nice
20:11:00 <Shachaf92> or should i bring that up later
20:11:00 <nitzmahone> Yeah, let's get this one to a merge-able state, then if you want to talk about others in the future, we're open to it (esp removing ignores on rules in old code), just need to balance loss of "blame" and potential instabliity from non-formatting changes
20:11:29 <Shachaf92> k, the rest of the rules are a lot more problematic
20:11:36 <jborean93> there's a few TODO stuff in there, usually they are just placeholders for future work
20:12:09 <Shachaf92> i see
20:12:34 <Shachaf92> anything else in this one you want me to look
20:12:44 <Shachaf92> change*
20:14:24 <jborean93> go through the issues list and see what takes your fancy/think you can do
20:14:34 <nitzmahone> Probably just go with the review comments- so long as everything's addressed...
20:14:41 <nitzmahone> OK, next thing: https://github.com/ansible/ansible/pull/53362
20:14:45 <nitzmahone> #topic https://github.com/ansible/ansible/pull/53362
20:14:50 * jborean93 sorry, thought you were asking about in general
20:15:04 <Shachaf92> both :)
20:15:18 <nitzmahone> Jon- I'm fine with merging that stuff for 2.9 now, just remember, you break it, you bought it ;)
20:15:21 <jborean93> If CI is green, you've attempted to contact the module author and had no reply then I would personally merge
20:15:27 * bcoca sees xml and hides
20:15:32 * jborean93 but I'm not going to touch win_xml
20:15:52 * bcoca makes space in anti-xml bunker for jborean93
20:15:55 <jhawkesworth> yeah well I've got form for hanging around this project
20:16:11 <jhawkesworth> so if it borks, I'll fix it
20:16:22 <jborean93> sounds like we have a new win_xml maintainer :)
20:16:37 * nitzmahone makes note to buy Jon two beers now
20:16:41 <jhawkesworth> 1 maintainer, 2 users by the sound of things
20:16:45 <Shachaf92> why is win_xml so frightening?
20:16:50 <jborean93> because XML
20:17:08 <jborean93> lots of use cases, difference of ideas on interfaces
20:17:15 <nitzmahone> Making idempotent changes to text is painful, making them to XML is worse
20:17:19 <jborean93> can't please everyone
20:17:24 <Shachaf92> yeah
20:17:33 <jhawkesworth> yeah its all horrible
20:17:50 <nitzmahone> There are absolutely use cases where it makes sense, but I personally try to avoid/workaround them wherever possible with templating instead
20:19:01 * nitzmahone hovers finger over merge button
20:19:08 <jhawkesworth> for me turned out to be the best way to make sure that devs haven't left debug level logging on in production systems
20:19:32 <jhawkesworth> object now.. or moan at me later :-)
20:19:47 <jborean93> I choose the latter :)
20:19:52 * nitzmahone ships it
20:20:09 <jhawkesworth> yay
20:20:25 <nitzmahone> #topic open floor
20:20:30 <nitzmahone> (mind the gap)
20:20:47 <jhawkesworth> I'm out of the loop is 2.8 release still on course?
20:20:56 <nitzmahone> Yep, RC2 this week I think
20:21:26 <Shachaf92> can you help me understand what really needs work / important for you guys?
20:21:31 <jhawkesworth> neat.  Need it for azure project
20:22:14 <jhawkesworth> dag made a list on the wiki a little while back of good suggestions.
20:22:16 <nitzmahone> Shachaf92: validation of reported issues is huge
20:22:32 <nitzmahone> proposed fixes on confirmed ones even better :)
20:22:51 <Shachaf92> k
20:22:53 <nitzmahone> The bot's pretty good about tagging Windows-specific issues
20:23:06 <Shachaf92> yeah i saw, but there are a mess of stuff
20:23:07 <jhawkesworth> feature parity with linux equivalent modules is good too, where possible
20:23:08 <nitzmahone> so you can just search for `label:windows`
20:23:35 <Shachaf92> about the parity, what exactly do you mean?
20:23:46 <Shachaf92> same vars? output?
20:24:05 <zoredache> just getting the same functionality in some cases?
20:24:07 <nitzmahone> If there's a Linux equivalent module, we *try* in most cases to ensure the behavior/module UI match
20:24:30 <jhawkesworth> some of the win_<module_name> don't do quite the same things as the <module_name> modules do
20:24:32 <nitzmahone> Sometimes that doesn't make sense, or the POSIX module does something in a brain-dead way, so we'll deviate in those cases
20:24:34 <Shachaf92> the list is of ones you know aren't?
20:24:35 <bcoca> command/win_command
20:24:44 <bcoca> but no systemd/win_systemd
20:25:10 * jhawkesworth wants a bunker to hide from win_systemd in!
20:25:24 <jhawkesworth> let me dig out the list on the wiki
20:25:45 <bcoca> he,  systemd hate lives across OS platforms ...
20:25:50 * nitzmahone hasn't dug through the wiki in awhile: https://github.com/ansible/community/wiki/Windows
20:26:17 <jhawkesworth> doh yeah its all linked off https://github.com/ansible/community/wiki/Windows
20:26:51 <jhawkesworth> so https://github.com/ansible/community/wiki/Windows:-progress-tracker#feature-parity-with-python-modules for example
20:27:28 <nitzmahone> I'm pretty sure I'll have return value deprecation in for 2.9- working on it actively right now and I think I've solved the issues that were blocking it last time... That'll probably open up a bunch more "we should clean up return values" cases...
20:27:48 <jborean93> will be nice
20:27:53 <nitzmahone> There's also the renaming of non-facts `_facts` modules
20:28:34 <nitzmahone> (should be on deck for 2.9, though not sure if we've completely nailed down the process yet)
20:29:38 * nitzmahone suspects we may have untested corner cases for deprecated Windows modules
20:29:59 <nitzmahone> Anything else to discuss today?
20:30:08 <jborean93> I'm good
20:30:11 <jhawkesworth> nothing from me
20:30:21 <nitzmahone> #info Red Hat Summit is next week, jborean93 and I will be there, but not sure if we should cancel this meeting
20:30:40 <nitzmahone> (might be best since I know my schedule is still up in the air)
20:30:55 <jhawkesworth> sounds like a plan.  Hope you have a good Summit
20:31:25 <nitzmahone> Unless somebody else *really* wants to run this, we'll probably just cancel for next week
20:31:47 <nitzmahone> OK, well, until next time- thanks all for the discussion!
20:31:49 <jborean93> probably for the best
20:31:52 <jhawkesworth> I vote just cancel.  We can chat on channel or via PRs if anything does come up
20:31:55 <Shachaf92> enjoy
20:31:59 <jhawkesworth> cheers
20:32:02 <nitzmahone> #agreed cancel WWG meeting for next week
20:32:05 <nitzmahone> #endmeeting