ansible_windows_working_group
LOGS
20:00:36 <nitzmahone> #startmeeting Ansible Windows Working Group
20:00:36 <zodbot> Meeting started Tue Apr  9 20:00:36 2019 UTC.
20:00:36 <zodbot> This meeting is logged and archived in a public location.
20:00:36 <zodbot> The chair is nitzmahone. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:36 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:36 <zodbot> The meeting name has been set to 'ansible_windows_working_group'
20:01:00 <nitzmahone> #chair jborean93 dag jhawkesworth
20:01:00 <zodbot> Current chairs: dag jborean93 jhawkesworth nitzmahone
20:01:03 <jhawkesworth> hey
20:01:22 <jborean93> Hey
20:01:35 * jborean93 on a train so will be slow to respond
20:01:56 <nitzmahone> So the only item on the meeting agenda is what to do about the problems introduced to win_domain_membership from the Get-ADObject changes
20:02:42 <jborean93> Unless it’s an easy swap over to the .NET classes we should revert and try again for 2.9
20:02:43 * jhawkesworth re-reading the PR
20:02:52 <nitzmahone> That's what I'm leaning toward as well
20:02:55 <chopraaa> iirc there's adsi
20:03:07 <chopraaa> im not sure if itd work here though since i dont do much .net
20:03:08 <nitzmahone> That module needs to keep working reliably
20:03:22 <jborean93> The credentials bit is the hardest
20:03:32 <nitzmahone> I'm sure we can make it work, but I don't want it to be unstable for a couple releases of 2.8 while we figure it out
20:03:50 <slobber> coworker says this works https://gist.github.com/smaslennikov/c0921fe7a26a8bd9cccf3b175955162b
20:03:51 <nitzmahone> Anybody have major objections to reverting for 2.8?
20:04:10 <jhawkesworth> yes it would be better if it was in a 2.8.something release than borked, so no objection from me to reverting
20:04:22 <nitzmahone> Well, it'd be 2.9
20:04:28 <jhawkesworth> sorry yeah 2.9
20:04:35 <chopraaa> next major release
20:04:41 <jhawkesworth> 13th hour at the keyboard today so far, not at my best!
20:04:47 <chopraaa> hehe likewise
20:04:57 <nitzmahone> #agreed revert https://github.com/ansible/ansible/pull/53542
20:05:02 <chopraaa> +1
20:05:25 <nitzmahone> OK, sounds good
20:05:28 <nitzmahone> #topic open floor
20:05:59 <nitzmahone> 2.8 "full freeze" is Wednesday night Pacific
20:06:14 <jhawkesworth> cool
20:06:15 * chopraaa looks at the time
20:06:22 <chopraaa> tonight :o
20:06:34 <jhawkesworth> early testing so far has been pretty smooth
20:06:40 <dag> Anything we need to add to v2.8 still ?
20:06:41 <nitzmahone> It's been delayed a few times for various reasons, but looks like it's a go this time (~28 hours from now)
20:07:03 <jhawkesworth> I think my win_xml refactor has missed the boat now
20:07:29 <jhawkesworth> pleased to get improved win_nssm and win_format in though
20:07:29 <chopraaa> wasnt that good to go last time?
20:07:50 <jhawkesworth> still waiting on review from original module author
20:08:34 <chopraaa> i was curious how that worked, because the author of the proxmox module is MIA is as well and it's broken as hell
20:09:29 <nitzmahone> If someone's willing to take over an abandoned thing and can show they have enough chops to keep it up, we'll usually let them
20:10:28 * chopraaa nudges jhawkesworth
20:10:39 <jhawkesworth> I don't think win_xml is abandoned at this point
20:10:46 <nitzmahone> Oh, jhawkesworth, I hadn't seen you actually marked win_xml as good to go; I can review that and merge it assuming no blockers
20:11:13 <nitzmahone> or would you rather have all of 2.9 dev cycle to let it "soak"? (basically merge after we branch 2.8)- your call
20:11:23 <jhawkesworth> thanks yeah sorry it was work-in-progress for a long time
20:11:32 <jhawkesworth> yeah actually 2.9 much better idea
20:12:00 <jhawkesworth> i changed it a lot and its possible there are xpaths out there that will now do things they didn't before
20:12:34 <jhawkesworth> (cos it doesn't just pick first matching node/nodes any more, but processes list of nodes that the xpath matched
20:14:32 <jhawkesworth> nothing else from me.  Anyone else?
20:15:21 <chopraaa> nothing here
20:15:46 <nitzmahone> OK, if nothing else, closing in 5..
20:15:49 <nitzmahone> 4..
20:15:52 <nitzmahone> 3..
20:15:56 <nitzmahone> 2..
20:15:58 <nitzmahone> 1..
20:16:03 <nitzmahone> Thanks all- til next week!
20:16:05 <nitzmahone> #endmeeting