vmware_weekly
LOGS
16:06:53 <Goneri> #startmeeting VMware weekly
16:06:53 <zodbot> Meeting started Mon Nov  4 16:06:53 2019 UTC.
16:06:53 <zodbot> This meeting is logged and archived in a public location.
16:06:53 <zodbot> The chair is Goneri. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:06:53 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:06:53 <zodbot> The meeting name has been set to 'vmware_weekly'
16:06:59 <Goneri> #chair alongchamps
16:06:59 <zodbot> Current chairs: Goneri alongchamps
16:07:16 * alongchamps waves
16:07:17 <Goneri> #topic vmware_host_firewall_manager script
16:08:01 <Goneri> alongchamps, could you repeat what you just said, this way it will be recorded.
16:08:10 <alongchamps> sure
16:08:17 <alongchamps> I actually had a discussion on Friday at length with someone who was using the vmware_host_firewall_manager script
16:08:51 <alongchamps> and to use the ip_address part, they had to change the script
16:08:56 <alongchamps> the error they were getting was this: TypeError: Value of unknown type: <type 'exceptions.ValueError'>, ['10.100.101.1'] does not appear to be an IPv4 or IPv6 address\n
16:09:20 <alongchamps> which makes sense because parsing ['192.168.100.1'] for an IP address (script expects '192.168.100.1' and not a list, it would fail
16:09:24 <Goneri> did he open a bug?
16:09:31 <alongchamps> not as far as I know
16:10:50 <alongchamps> he did mention that this line helped: ipaddress.ip_address(ip.decode()) instead of ipaddress.ip_address(ip)
16:10:56 <alongchamps> so I'm not sure what decode was doing for it there
16:11:30 <Goneri> alongchamps, did he try with 2.9.0 or devel?
16:11:45 <alongchamps> actually that part was frustrating. he was all over the place with versions
16:11:53 <alongchamps> 2.8.*, 2.9
16:12:10 <alongchamps> I haven't been able to test it yet today
16:13:09 <Goneri> https://github.com/ansible/ansible/pull/63567 should be backported in 2.9
16:13:23 <alongchamps> that's my expectation
16:13:39 <alongchamps> is that if we can reproduce it, it'll show up
16:14:06 <alongchamps> I got 2.9.0 installed this morning: ansible --version => ansible 2.9.0
16:16:26 <Goneri> ok, I will prepare a backport PR for https://github.com/ansible/ansible/pull/63567 later this week
16:16:43 <Goneri> unless anyone can/wants to do it before.
16:17:32 <Goneri> do we have anything else for today?
16:17:43 <alongchamps> I know I won't have much time for this, unfortunately
16:18:31 <Goneri> alongchamps, no problem Aaron :-)
16:20:04 <Goneri> #action goneri will backport https://github.com/ansible/ansible/pull/63567
16:20:13 <Goneri> #endmeeting