ansible_vmware_working_group_meeting
LOGS
16:01:26 <akasurde> #startmeeting Ansible VMware Working Group Meeting
16:01:26 <zodbot> Meeting started Mon Mar  4 16:01:26 2019 UTC.
16:01:26 <zodbot> This meeting is logged and archived in a public location.
16:01:26 <zodbot> The chair is akasurde. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:26 <zodbot> The meeting name has been set to 'ansible_vmware_working_group_meeting'
16:01:34 <akasurde> Hello Everyone
16:01:39 <adarobin> Hi
16:02:03 <alongchamps> hi akasurde
16:02:11 <akasurde> #chair alongchamps
16:02:11 <zodbot> Current chairs: akasurde alongchamps
16:02:21 <akasurde> alongchamps, hi, how are you ?
16:03:02 <alongchamps> not bad; haven't been able to work on my firewall script as much lately but I am working on learning some more about formatting output for my playbooks
16:03:31 <akasurde> alongchamps, no problem
16:03:36 <alongchamps> how are you?
16:03:45 <akasurde> I am doing good
16:07:13 <akasurde> We don't anything else on agenda
16:07:21 <akasurde> alongchamps, you want to discuss anything ?
16:07:37 <alongchamps> I don't have anything to discuss myself
16:07:53 <alongchamps> I haven't had as much time lately because of other work stuff going on
16:08:37 <akasurde> OK
16:10:04 <alongchamps> adarobin: did you have anything?
16:10:28 <adarobin> I had a question/observation I posted in here the other day
16:10:44 <akasurde> #chair adarobin
16:10:44 <zodbot> Current chairs: adarobin akasurde alongchamps
16:10:48 <akasurde> adarobin, go ahead
16:11:13 <adarobin> Does anyone know if there is a technical reason the new vmware_host_snmp module doesn't support vCenter?  Also, the auto generated docs are confusing because it says you can put a vCenter in for hostname, but that doesn't work with this particular module.
16:12:04 <adarobin> I can take a try at adding an esxi_hostname parameter that is required if the specified host is a vCenter like in some of the other modules, but I just wanted to make sure there wasn't a technical reason that would not work.  I also didn't want to start on something else until I got those tests done for the PR I have open.
16:12:07 <alongchamps> that sounds like a 5.5 thing
16:12:15 <alongchamps> or I should say <5.5
16:12:26 <alongchamps> since they didn't add HostSystem.ConfigManager.snmpManager for a while
16:12:31 <alongchamps> they being VMware
16:12:36 <adarobin> Ah, interesting
16:13:12 <adarobin> I guess I can just try it and see if it works, I don't think it would need much code.
16:13:16 <akasurde> adarobin, vmware_host_ modules are supposed to run vCenter and individual ESXi
16:13:43 <akasurde> I will take a look for vmware_host_snmp module for the doc part
16:15:25 <alongchamps> it does seem to be more of a docs thing, akasurde after taking a quick look at the code
16:15:35 <alongchamps> so that's an easy fix :)
16:16:38 <akasurde> technically it should work with vCenter connection as well
16:17:07 <akasurde> I mean if user specifies vCenter and hostname it should work
16:17:19 <alongchamps> lines 157..161 throw an exception if it's a vCenter
16:17:24 <akasurde> also, if user provides vCenter and cluster name then it should also work
16:17:44 <akasurde> yes, not sure if it is correct
16:18:04 <akasurde> because this kind of check is not available in other vmware_host_*
16:18:06 <akasurde> modules
16:18:59 <alongchamps> so I just checked a 5.5 host, it did have hostSystem.configManager.snmpSystem so I want to say it would work for any ESXi host >= 5.5
16:19:21 <alongchamps> from a vCenter
16:19:38 <alongchamps> it used to be the case you had to go straight to the host to do this
16:20:14 <akasurde> alongchamps, ok
16:21:21 <adarobin> So its probably a matter of just implementing something similar to what I did in PR 47062
16:22:44 <akasurde> adarobin, correct, PR welcome
16:23:03 <adarobin> though multiple hosts and cluster_name would be easier to implement in this case as well
16:23:14 <akasurde> adarobin, yes
16:25:17 <alongchamps> so we then have a couple of different connection schemes, single ESXi host OR vCenter with cluster OR vCenter with single host
16:25:25 <alongchamps> s/couple/few
16:26:04 <akasurde> yes
16:26:38 <akasurde> alongchamps, we try to generalize the connection options, people do lot of things depending on inventory list
16:26:51 <alongchamps> yep
16:26:55 <akasurde> some uses ESXi hosts and some uses Cluster to manage things
16:30:59 <akasurde> Can we review some of the PRs while we are here ?
16:31:26 <akasurde> #info https://github.com/ansible/ansible/pulls?q=is%3Aopen+is%3Apr+label%3Avmware
16:31:50 <alongchamps> sure
16:32:43 <alongchamps> what do we want to start with akasurde
16:32:46 <akasurde> https://github.com/ansible/ansible/pull/53158
16:34:53 <alongchamps> LGTM
16:35:33 <alongchamps> should I 'Approve' it on GitHub or just leave a comment
16:36:15 <akasurde> alongchamps, you can write shipit
16:36:26 <akasurde> or just add comment saying LGTM
16:36:40 <alongchamps> I'll do shipit since I haven't done that before
16:37:07 <akasurde> Cool
16:38:39 <alongchamps> https://github.com/ansible/ansible/pull/53084/ seems easy enough
16:40:29 <alongchamps> though I wonder if we want more of the examples to be vCenter based
16:40:54 <alongchamps> it's technically correct to use it for a single host's config, but I feel like that would be uncommon
16:41:26 <adarobin> Under notes it says "You can only create the VMKernel adapter on a vDS if authenticated to vCenter and not if authenticated to ESXi."
16:41:44 <adarobin> So I'm thinking that is why not all the examples were changed
16:42:29 <akasurde> adarobin, you can add your observations under in PR so that PR owner will take a decision. I also agree with you
16:43:04 <alongchamps> LGTM after that
16:44:36 <akasurde> #action akasurde Add a comment in #53084 stating to add a note
16:44:41 <akasurde> Done next
16:49:45 <akasurde> https://github.com/ansible/ansible/pull/53056
16:50:41 <alongchamps> seems good and adarobin and I have comments on it now
16:51:50 <akasurde> alongchamps, adarobin thanks
16:51:52 <akasurde> https://github.com/ansible/ansible/pull/53050
16:52:51 <alongchamps> couple of comments on that one
16:53:11 <akasurde> This fix was introduces as collecting properties from VM object is very slow and which makes inventory gathering with host_vars very slow
16:54:19 <akasurde> alongchamps, yes tell me
16:54:58 <alongchamps> oh I was just pointing it out
16:55:33 <alongchamps> so this change will only start by bringing back name and guest.ipAddress it looks like?
16:56:13 <adarobin> looks like the default is to bring back everything as before
16:56:18 <adarobin> but you can override it and bring back less
16:56:22 <adarobin> to make it faster
16:56:46 <akasurde> yes
16:56:59 <akasurde> sometimes you just need ansible_host and name or something
16:57:09 <adarobin> looks good to me
16:57:35 <akasurde> So no sense in bringing all properties. also performance increases
16:58:11 <alongchamps> do we need the runtime.MaxMemoryUsage and CPU hot add/remove properties?
16:58:24 <alongchamps> asking since the maxMemoryUsage one seems like it may go to the stats database
16:59:02 <akasurde> alongchamps, yes we can
16:59:08 <akasurde> PR welcome
17:00:33 <adarobin_> looks like my internet dropped briefly
17:01:53 <alongchamps> seems OK after looking through it now
17:06:24 <alongchamps> looks like you're both having internet issues!
17:06:34 <akasurde> yes
17:06:38 <akasurde> https://github.com/ansible/ansible/pull/52952
17:07:12 <alongchamps> I need to get going actually, not sure if adarobin is still able to review
17:07:28 <akasurde> No problem
17:07:34 <akasurde> Will continue in next meeting
17:07:41 <alongchamps> yep
17:07:45 <akasurde> since we are over the meeting time
17:07:45 <adarobin> I actually had to start walking to another meeting (probably why my connection dropped).
17:08:09 <akasurde> alongchamps, adarobin thanks for the presence and reviews
17:08:19 <alongchamps> no problem
17:08:31 <akasurde> #endmeeting