ansible_network_working_group
LOGS
16:01:25 <Qalthos> #startmeeting Ansible Network Working Group
16:01:25 <zodbot> Meeting started Wed Dec 12 16:01:25 2018 UTC.
16:01:25 <zodbot> This meeting is logged and archived in a public location.
16:01:25 <zodbot> The chair is Qalthos. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:25 <zodbot> The meeting name has been set to 'ansible_network_working_group'
16:02:00 <Qalthos> #chair dagrawal ganeshrn justjais nilashishc trishnag Anil_Lenovo  allan_k ankitb_07
16:02:00 <zodbot> Current chairs: Anil_Lenovo Qalthos allan_k ankitb_07 dagrawal ganeshrn justjais nilashishc trishnag
16:02:09 <Qalthos> #topic Core Updates
16:03:48 <Qalthos> This week is a release week for roles
16:04:30 <Qalthos> #info cisco_ios 2.7.0 was released
16:04:41 <Qalthos> #info cisco_iosxr 2.7.1 was released
16:05:00 <Qalthos> #info network_engine 2.7.2 was released
16:05:39 <Qalthos> We put these out every two weeks if there are changes to be had in a particular role
16:06:13 <Qalthos> Here are some other things the team has been working on:
16:06:33 <Qalthos> #info working with skydive network topologies
16:06:47 <Qalthos> #info Worked on ansible_facts generation with gather_facts for network platforms.
16:07:12 <Qalthos> #info Updated nxapi & eapi httpapi plugins to be more in-line with how httpapi plugins are expected to work
16:07:54 <Qalthos> #link https://github.com/ansible/community/labels/network is the place you can always find out agenda for this meeting
16:08:05 <IPvSean> 👍
16:08:24 <Qalthos> And it doesn't look like anyone has snuck anything last-minute, so
16:08:29 <Qalthos> #topic Open Floor
16:09:05 <Qalthos> Anyone have anything they want to discuss?
16:09:19 <allan_k> Hello! I am fairly new in this "world" so apologies if I am going to say somting stupid :)
16:09:29 <allan_k> I am trying to develop and ios_ntp module
16:10:15 <allan_k> is that something that could be of any interest?
16:10:52 <ankitb_07> @Qalthos, This is my https://github.com/ansible/ansible/pull/46773. I have made the necessary changes as requested by one of the team members. I would like to know when will this get merged into ansible-core?
16:11:34 <Qalthos> allan_k: That seems like a fine thing
16:12:38 <Qalthos> If you want any help or more specific feedback, you are welcome to open a PR at any stage of progress to share what you are doing
16:13:39 <Qalthos> Just make sure to start the title with "[WIP]" if it is not ready to be considered for merge
16:14:20 <allan_k> Will do  as I need for some support. I am using some modules as blueprint and I am struggling to understand few thinghs
16:17:52 <Qalthos> #action Qalthos follow-up on https://github.com/ansible/ansible/pull/46773
16:18:13 <Qalthos> ankitb_07: I'll see to it that it gets whatever attention it needs
16:19:49 <ankitb_07> Thank you so much. I appreciate that. Thanks to the ansible-network team, you guys are doing an amazing job.
16:21:39 <ankitb_07> One last question, Are the upcoming modules going to be included in Ansible-2.8 release?
16:22:56 <allan_k> is there any specific blueprint that I can follow to write a module?
16:23:49 <Qalthos> ankitb_07: I'm not sure to which modules you are referring, but everything in devel will be in for 2.8
16:24:34 <Qalthos> So if it gets merged, then yes
16:24:44 <allan_k> I ma writing an ios_ntp module, is the first ansible module I ma trying do create, so I was wondering if there are some guidelines (apart from thos on ansible docs) or some blueprint that can be taken as example
16:25:54 <ankitb_07> That answers my question. Thanks. I was just curious about my pull request and what version of ansible release it might get merged into. Thanks again.
16:26:14 <Anil_Lenovo> allan_k: I have seen nxos has a similiar module, have u looked into it ?
16:26:53 <Qalthos> allan_k: As far as I know, we have no network-specific development guides
16:27:33 <allan_k> Yeap, what I am trying hard to understand is the "architecture" of the module itself. for example, there is param method that I don t quite get what it does.
16:27:38 <Qalthos> The way most of the modules get written is, as Anil_Lenovo says, looking at similar modules and adapting them to your platform
16:28:46 <Qalthos> allan_k: A lot of the basics are in https://docs.ansible.com/ansible/latest/dev_guide/developing_modules_general.html
16:29:44 <Qalthos> If you have questions about conventions that seem to be specific to network modules, feel free to ask them in this channel
16:30:26 <allan_k> Ok, thank you very much :)
16:30:27 <Qalthos> Even if we're not running a meeting, there is usually someone around who can answer questions
16:40:39 <Anil_Lenovo> Nothing from my side, I am yet to raise PR for cnos_interface changes. Will do by friday..
16:41:11 <Qalthos> Anil_Lenovo: Well thanks for coming by anyway
16:41:41 <Qalthos> Unless anything else comes up, I'll close this at :45
16:45:38 <Qalthos> Thanks everyone for coming!
16:45:43 <Qalthos> #endmeeting