ansible_network_working_group
LOGS
16:00:15 <gundalow> #startmeeting Ansible Network Working Group
16:00:15 <zodbot> Meeting started Wed Mar 28 16:00:15 2018 UTC.  The chair is gundalow. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:15 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:15 <zodbot> The meeting name has been set to 'ansible_network_working_group'
16:00:25 * Qalthos 🌊🌊
16:00:50 <Qalthos> I think we're all winners, there
16:00:56 <gundalow> :D
16:01:15 <gundalow> #topic Core update
16:01:15 * ganeshrn waves
16:01:31 <gundalow> #chair caphrim007 Qalthos ganeshrn jmcgill298
16:01:31 <zodbot> Current chairs: Qalthos caphrim007 ganeshrn gundalow jmcgill298
16:02:12 <gundalow> #info Ansible 2.5.0 has been released! Thank you all that have contributed code, testing, support, coffee
16:03:55 <gundalow> #chair samerd
16:03:55 <zodbot> Current chairs: Qalthos caphrim007 ganeshrn gundalow jmcgill298 samerd
16:04:47 <trishnag> o/
16:04:49 <gundalow> #info Expect 2.5.1 in a few weeks. We've just unlocked `stable-2.5` branch so we will start cherry-picking fixes into that
16:05:12 <funzo> o;
16:05:57 <Qalthos> #chair trishnag funzo
16:05:57 <zodbot> Current chairs: Qalthos caphrim007 funzo ganeshrn gundalow jmcgill298 samerd trishnag
16:06:23 <gundalow> #info What we cherry will cherry-pick, along with any other things that need fixing in 2.5.* can be seen in https://github.com/ansible/ansible/projects/20 if you think anything is missing please ping us on IRC
16:07:45 <gundalow> caphrim007: samerd jmcgill298 You aware of anything that we need to put into 2.5.1?
16:07:56 <jmcgill298> I am not
16:08:24 <gundalow> #info NO MORE UNABLE TO OPEN SHELL
16:08:29 <itdependsnetwork> I mentioned yesterday on IRC, I do get a stack trace on some timeout's not sure why though
16:08:52 <gundalow> #chair itdependsnetwork acozine1
16:08:52 <zodbot> Current chairs: Qalthos acozine1 caphrim007 funzo ganeshrn gundalow itdependsnetwork jmcgill298 samerd trishnag
16:09:16 <samerd> gundalow: I see my both commits, although one of them still not merged in devel barnch
16:09:29 <samerd> appreciate if you can review and merge
16:10:11 <gundalow> samerd: sure, ping me the links and I'll do it later today
16:10:15 <samerd> https://github.com/ansible/ansible/pull/37651
16:10:26 <brampling> I have several doc fixes I need to do in the NIOS modules, https://github.com/ansible/ansible/pull/37765 is the only one committed right now and waiting for merge.
16:10:28 <gundalow> itdependsnetwork: did a bug get raised, or were people investigating further?
16:10:39 <gundalow> #chair brampling
16:10:39 <zodbot> Current chairs: Qalthos acozine1 brampling caphrim007 funzo ganeshrn gundalow itdependsnetwork jmcgill298 samerd trishnag
16:10:48 <samerd> gundalow: tahnks, I'll send you a reminder after the meeting
16:10:49 <itdependsnetwork> I have not, difficult with it being on customer network
16:11:13 <privateip> brampling: i should be able to get those merged this week
16:11:25 <privateip> i have been waiting for 2.5.1 to open so i can CP
16:11:51 <gundalow> I've merged 37765. I'll add it to the cherry-pick list
16:12:05 <privateip> thanks
16:12:23 <brampling> Thanks, I'll try to do the others ASAP
16:12:54 <privateip> i hope to tackle the open issues as well this week yet
16:14:32 <brampling> Most of the other PRs I have open are new or changed modules so they're bigger, no rush. https://github.com/ansible/ansible/pull/37578 is a small one that should be done first.
16:14:38 <gundalow> samerd: merged 37651 and I've added it oto "Need CP into 2.5.1" list
16:14:52 <gundalow> Anything else?
16:14:58 <gundalow> Or questions on 2.5?
16:15:10 <privateip> good to know, thanks
16:15:31 <samerd> gundalow: thanks so much, appreciate it.
16:16:49 <gundalow> samerd: brampling I'm sure you know, though doesn't hurt to repeat. We only backport bug fixes. Any feature work (including changes to a modules interface) will not be backported. Meaning sometime you may wish to have two PRs (bug fix + feature work).
16:17:14 <gundalow> Not seen anyone doing anything wrong, just a general reminder since we've released 2.5
16:19:13 <itdependsnetwork> not  too helpful, but something: https://github.com/ansible/ansible/blob/3886f80e440b7525236142d11c4f58439defd4ec/lib/ansible/utils/path.py#L72
16:19:26 <brampling> I have been documenting the new stuff I've been doing as 2.6. I am just hoping to have some doc fixes rolled into the 2.5 line on the existing modules.
16:19:31 <itdependsnetwork> wrong link: https://github.com/ansible/ansible/issues/38048
16:19:57 <gundalow> itdependsnetwork: Thanks
16:20:29 <gundalow> #info Team updates
16:20:31 <gundalow> erm
16:20:37 <gundalow> #topic Team updates
16:22:31 <gundalow> #info you may noticed that we've stopped doing daily standup status in here (#ansible-network). We didn't get much feedback, and we though that this was partly due to the bitty task-level updates. So we've decided to give weekly project updates in here, therefore they will end up in the IRC logs https://meetbot.fedoraproject.org/sresults/?group_id=ansible-network&type=channel
16:22:55 <Qalthos> So, I have the first of several proposals for the 2.6 cycle up
16:22:58 <Qalthos> #link https://github.com/ansible/proposals/issues/102
16:23:18 <gundalow> Qalthos: If youcould #info the main bits that should stand out more in the log
16:23:21 <gundalow> Over to you :)
16:23:37 <Qalthos> #info This covers the work for a new connection plugin for eAPI transport
16:24:15 <Qalthos> Coming soon will be one for nxapi as well
16:24:48 <Qalthos> If anyone wants to have a chat about it, it's on the agenda as well, so we can come back to it
16:25:10 <Qalthos> [EOF]
16:25:26 <gundalow> :)
16:25:47 <gundalow> #info This week I've been getting up to speed with Zuul, which is the CI framework that it used by OpenStack (and friends). For those that know about DCI (Distributed CI) this will be the *pre* commit replacement for that framework that allows us to test PRs against a varity of test machines, including those in partners labs. Nothing to currently demo or show, lots of learning how to glue parts together.
16:26:21 <gundalow> [EOF]
16:27:28 <acozine1> #info This week I'm revising end-user network documentation for 2.5. I also started a project for tracking documentation changes at https://github.com/ansible/ansible/projects/24 - if you have docs issues that I've not added to the project, please add them.
16:27:33 <acozine1> [EOF]
16:27:46 <ganeshrn> #info currently working on yang2spec action plugin which will be used in openconfig role. Spec for openconfig role will be available for review in https://github.com/ansible-network/network-proposals by next week
16:29:41 <jmcgill298> For the eapi plugin, shouldn't there be a generic http plugin?
16:30:13 <gundalow> jmcgill298: Great question, though I'll let Qalthos explain the current thoughts about that
16:30:18 <trishnag> #info currently going through network-engine for template-engine and text-parser https://github.com/ansible-network/network-engine. Started working on cli_config specification. Will have the proposal ready probably next week.
16:32:17 <Qalthos> jmcgill298: Ideally yes. That's one of the things getting hashed out as we put together the proposal for nxapi. If it is not too awful to generalize, they should ultimiately be the same connection, but that would probably involve creating a new plugin type to handle serializing to the device's format
16:33:20 <Qalthos> gundalow: Is that everyone?
16:33:45 <gundalow> privateip: Anything you wanted to update on?
16:36:03 <gundalow> #topic Open Floor
16:36:08 <gundalow> #chair
16:36:08 <zodbot> Current chairs: Qalthos acozine1 brampling caphrim007 funzo ganeshrn gundalow itdependsnetwork jmcgill298 samerd trishnag
16:36:19 <gundalow> Anyone got anything else they'd like to discuss?
16:36:29 <gundalow> Hope the team updates are useful
16:36:53 <itdependsnetwork> Is there more to the 2.6 road map?
16:37:35 <gundalow> #action gundalow to update 2.6 roadmap https://github.com/ansible/ansible/pull/37926/files
16:37:46 <brampling> I've built 5 new Infoblox modules, modified another, and have a roadmap of stuff I'm working on in response to some customer requirements. Not sure if you want those updates?
16:37:47 <gundalow> itdependsnetwork: It's in my tab, will get that fleshed out with network section
16:37:57 <gundalow> (one of my many tabs)
16:38:26 <gundalow> brampling: Sure. Feel free to #info the key points, will make them stand out more in the meeting log
16:40:31 <brampling> #info I built and PR'd NIOS modules for A, AAAA, CNAME, MX, and SRV records. Modified the nios_zone module to include support for name server groups and restart_if_needed flag.
16:43:09 <gundalow> :)
16:43:28 <gundalow> Anyone got anything else?
16:45:48 <Qalthos> Anyone else want to talk about eAPI?
16:46:50 <jmcgill298> I personally don't care about eAPI, but there are several APIs that need connection_plugins, and it seems that there should be some consistent code base
16:46:55 <gundalow> is dag around
16:47:00 <gundalow> jmcgill298: ACI?
16:47:05 <jmcgill298> also, you should talk to Dag who has worked on ACI plugin
16:47:09 <gundalow> :D
16:47:21 <jmcgill298> you are too fast for me @gundalow
16:47:55 <gundalow> I mentioned to Dag we were going to be producing specs for them
16:48:05 <gundalow> Does ACI have session cookies?]
16:48:16 <gundalow> eAPI doesn't, however NX-API does
16:49:11 <jmcgill298> I'm pretty sure it is cookies and they have another solution that Dag added to the existing connection code
16:49:25 <gundalow> jmcgill298: Any others apart from ACI you think we should ensure are aware of the connection work
16:49:47 <Qalthos> or from anyone else for that matter?
16:49:54 <gundalow> Yup
16:50:03 <gundalow> Would be good to get peoples views on the spec
16:50:25 <jmcgill298> it is using certificates actually, which is the preferred way and handles certain problems with frequent requests that other solutions get flagged as ddos
16:50:50 <Qalthos> The more connections we know about, the easier it is to make sure whatever we come up with is easily extensible
16:53:06 <jmcgill298> https://github.com/ansible/ansible/blob/devel/lib/ansible/module_utils/network/aci/aci.py#L291
16:54:18 <Qalthos> jmcgill298: If you want to briefly summarize what you've put here on https://github.com/ansible/proposals/issues/102, that would be a help
16:55:02 <jmcgill298> okay, but like I said, it would be helpful to talk with Dag who has done more of this work
16:56:27 <Qalthos> Right, and I'm sure we will, but a basic, 'hey, I want this for ACI, too' with some context would be useful
16:56:55 <jmcgill298> will add after lunch
16:57:05 <Qalthos> jmcgill298++
16:57:19 <gundalow> It's late in the evening in Dagland, so hopefully we will get some info later
16:57:22 <gundalow> Thanks
16:57:34 <gundalow> Anyone got anything else, otherwise I'll close shortly
17:00:52 <gundalow> OK, thanks everyone
17:00:54 <gundalow> #endmeeting