ansible_molecule_working_group
LOGS
19:00:05 <gundalow> #startmeeting Ansible Molecule Working Group
19:00:05 <zodbot> Meeting started Wed Mar 20 19:00:05 2019 UTC.
19:00:05 <zodbot> This meeting is logged and archived in a public location.
19:00:05 <zodbot> The chair is gundalow. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:05 <zodbot> The meeting name has been set to 'ansible_molecule_working_group'
19:00:07 <themr0c> + learned how to use github pages
19:00:12 * gundalow waves, who's around?
19:00:18 * tima waves
19:00:43 <decentral1se> o/
19:01:23 <themr0c> o/
19:02:51 <ChrisShort> ahoy
19:02:51 <gundalow> #chair tima decentral1se themr0c
19:02:51 <zodbot> Current chairs: decentral1se gundalow themr0c tima
19:02:52 <ChrisShort> ish
19:03:02 <gundalow> #stool ChrisShort
19:03:19 <gundalow> #topic Molecule v2.20
19:03:30 <gundalow> #info Lets get Molevule 2.20 out
19:03:33 <decentral1se> straight to the chase
19:04:03 <gundalow> #info v2.20 Project Board https://github.com/ansible/molecule/projects/2
19:04:05 <gundalow> shows only Docker
19:04:09 <gundalow> urgh
19:04:16 <decentral1se> yep ;)
19:04:25 <gundalow> so I've not managed to get this to do what we wanted
19:04:26 <decentral1se> all actions and agreements from last meeting are dealt with
19:04:33 <decentral1se> #info https://meetbot.fedoraproject.org/ansible-molecule/2019-03-13/ansible_molecule_working_group.2019-03-13-19.00.html
19:04:35 <gundalow> excellent
19:04:46 <gundalow> https://quay.io/repository/ansible/molecule?tab=tags
19:04:48 <fabianvf> hello
19:04:51 <decentral1se> heyo
19:04:55 <gundalow> #chair fabianvf
19:04:55 <zodbot> Current chairs: decentral1se fabianvf gundalow themr0c tima
19:05:09 <gundalow> So in Quay.io `latest` = the most recent built
19:05:21 <gundalow> and `master` = the most recent build for the `master branch`
19:05:45 <gundalow> which means `latest` = `master`, which you can see by the blue line after the SHA256 on https://quay.io/repository/ansible/molecule?tab=tags
19:06:25 <gundalow> I manually created a `devel` tag from `master`, though as soon as another commit was made to master no update was made to `devel`
19:08:03 <tima> Shouldn't `latest` be the latest *stable* release and not necessarily what's `master`?
19:08:06 <themr0c> forget aboyt the devel tag then ?
19:08:16 <gundalow> tima: that's what we want, yes
19:08:22 <decentral1se> yep, what we agreed to was
19:08:24 <decentral1se> #info https://github.com/ansible/molecule/issues/1818#issuecomment-473307752
19:08:40 <decentral1se> so, after the release, people using the docker image might get a wild master build instead of stable ;)
19:08:41 <tima> +1 to fotgetting `devel`
19:09:08 <tima> @gundalow: was confused by "which means `latest` = `master`"
19:09:34 <tima> Thought that meant they'll remain the same.
19:09:39 <gundalow> tima: ah, `quay:latest` = `quay:master` on https://quay.io/repository/ansible/molecule?tab=tags
19:10:04 <gundalow> ^ is always true when if people only commit to master branch
19:11:29 <decentral1se> well, I liked the tags scheme, I wouldn't want to just throw it out just yet
19:11:41 <decentral1se> can we get quay permissions? themr0c,zbc,myself?
19:11:50 <gundalow> decentral1se: sure, let me do that now
19:11:55 <decentral1se> %s/zbc/zbr.
19:12:05 <decentral1se> cool, thanks
19:12:20 <decentral1se> even if we drop `devel` now, we'd still have a potentially surprising `latest`
19:12:51 <gundalow> decentral1se: zbr themr0c can you please sign into https://quay.io/repository/ via GitHub auth
19:12:57 <decentral1se> but look, there is the other side of it: is this really enough to stop us pushing it out now?
19:13:05 <gundalow> Good question
19:13:16 <decentral1se> @gundalow: done
19:13:17 <gundalow> If we want people to be able to use the docker image maybe
19:13:18 <gundalow> oh
19:13:44 <gundalow> actually, if we just tag and release then we can tell people to use the `2.20`image (and not `latest`)
19:14:05 <decentral1se> great, that'd cover us for now
19:14:08 <zbr> i am logged in but I do not see options to remove tags. i guess i was not added.
19:14:21 <zbr> we should publish only master and releases
19:14:21 <tima> +1 @gundalow
19:14:40 <zbr> and clean-up branch ones
19:15:03 <themr0c> done
19:16:26 <gundalow> zbr: themr0c added
19:16:31 <gundalow> decentral1se: It can't find you
19:16:42 <gundalow> what was your old name `lwm`, it can't see that either
19:16:50 <decentral1se> `lwm0` is my quay username, I think
19:16:53 <decentral1se> old account ...
19:17:34 <gundalow> decentral1se: can you see settings on https://quay.io/user/lwm0
19:17:41 <gundalow> just want to make sure I set the right person
19:18:18 <decentral1se> meh, I should create a proper account
19:18:20 <decentral1se> we can skip me for now
19:18:27 <gundalow> OK :)
19:18:37 <decentral1se> so, this work around, can we get it done?
19:18:40 <gundalow> themr0c: zbr You should have options
19:19:12 <gundalow> so I think
19:19:12 <gundalow> 1) Check docs say install named Quay.io version (not lastest)
19:19:12 <gundalow> 2) Update changelog
19:19:12 <gundalow> 3) Tag and release
19:19:15 <zbr> gundalow: yep, and i already removed the bogus tags from temporary branches. need to check travis file to avoid doing them.
19:19:18 * themr0c can access settings in molecule quay
19:19:29 <gundalow> Excellent, thanks
19:20:10 <gundalow> CONTRIBUTING.rst has `docker pull quay.io/ansible/molecule:latest`
19:20:33 <gundalow> as does `doc/source/examples.rst`
19:20:55 <decentral1se> Ah, I had https://github.com/ansible/molecule/pull/1838 for docs on this
19:21:44 <zbr> gundalow: i think you should update the trigger, probably recreate it and trigger only on master/tags. i see not option to edit the trigger.
19:21:56 <gundalow> zbr: Yup, I'll do that now
19:22:31 <gundalow> only on tags/`\d.*` (only tags starting with a number). I incorrectly created tags starting with `v` before
19:23:15 <gundalow> Do both parts of ^ sound right?
19:23:19 <zbr> i was personally expecting for the build to happen on travis and do a push for there, but is not. anyway we will see if this is a real issue or not.
19:23:36 <gundalow> Ah, for Quay.io it's a webhook
19:27:13 <gundalow> Do the docs need updating to say use a named version rather than latest?
19:29:01 <decentral1se> so instead of `latest` we say `version-number`?
19:29:05 <gundalow> #info quay.io has been updated so it will only build on `tags/\d.*`
19:29:12 <decentral1se> great
19:29:26 <gundalow> decentral1se: yup, `docker pull quay.io/ansible/molecule:2.20` (no leading `v`)
19:29:53 <decentral1se> ok, I'm doing this now
19:30:40 <decentral1se> and we're dropping `devel`, right?
19:30:40 <gundalow> Thanks
19:34:17 <gundalow> decentral1se: correct I've just deleted `devel` from quay.io
19:34:29 <decentral1se> Ok
19:37:09 <decentral1se> ok, what about https://github.com/ansible/molecule/pull/1838/files
19:38:50 <themr0c> +1
19:39:17 <decentral1se> #agreed use numbered versions for quay tags, drop `devel` and clean up branch tags
19:39:19 <decentral1se> let's mark that :)
19:39:24 <zbr> themr0c: something seems weid
19:39:28 <gundalow> Thanks
19:39:33 <gundalow> zbr: oh?
19:39:40 <zbr> docs sais "latest" -> master
19:39:58 <zbr> i was expecting latest = lastest-release
19:40:18 <zbr> and to have another tag named master or devel which would be the "bleading" one.
19:40:20 <gundalow> In the "old" dockerhub days retr0h only pushed Docker build manually on stable release
19:41:49 <themr0c> is quay pushing in the direction to have latest == latest build ?
19:42:11 <gundalow> yup
19:42:40 <zbr> gundalow: any link to doc/article regarding that?
19:42:43 <gundalow> Hence in the docs we need to make people be explicit in which version that should be using
19:43:27 <gundalow> From quay.io support
19:43:27 <gundalow> > Yes you are right by convention latest tag is always considered as current stable build.
19:43:43 <zbr> i personally want two floating tags: one to point to last release, and one to point last pushed master.
19:43:44 <gundalow> I don't think I explained the issues we were having very well
19:44:01 <gundalow> zbr: yup, same. Though I think that will take a bit more work
19:44:06 <zbr> yeah: "latest stable build" is a very fluid concept
19:44:14 <gundalow> and I'd like to see 2.20 get released
19:44:15 <zbr> i would not call stable any merge to master
19:44:34 <pabelanger> are you depending on quay.io to build the images? or are you pushing images to quay.io?
19:44:46 <gundalow> #chair pabelanger
19:44:46 <zodbot> Current chairs: decentral1se fabianvf gundalow pabelanger themr0c tima
19:44:49 <zbr> for me, only releases are stable, and even those (with hope in mind)
19:45:09 <decentral1se> zbr: we couldn't get the tags to match as we had originally agreed, so this is basically a work around
19:45:32 <gundalow> pabelanger: Hi :) quay.io has a webhook on GitHub that will trigger a build if the branch/tag matches a regexp
19:45:34 <decentral1se> we just need a 2.20 tag so we can make the 2.20 release
19:45:38 <zbr> pabelanger: i think that current implementation is to rely on quay to build them. not a big fun of it, but ok for the moment.
19:46:51 <pabelanger> okay, so not right now. But, if you are able to manually tag, outside of quay.io webhooks, you could write post jobs to build images, publish the quay.io then tag the specific versions
19:46:51 <gundalow> I've added some other comments on https://github.com/ansible/molecule/pull/1838/files
19:47:32 <pabelanger> then you'll have master, for master branch, and latest for when you tag
19:48:11 <themr0c> gundalow, nice
19:48:17 <decentral1se> @gundalow: great, fixed up
19:48:23 <zbr> pabelanger: yep, makes sense. as a random user, if I go to molecule and I see "latest" and "master" i would not need to read the docs to figure it out.
19:49:28 <decentral1se> ah, updated the installation.rst as well
19:51:37 <gundalow> decentral1se: looks good
19:51:43 <decentral1se> someone hit the big green button in the sky!
19:52:03 <ChrisShort> *pushes*
19:52:10 <ChrisShort> nothing happened
19:53:41 <decentral1se> :)
19:54:31 <gundalow> decentral1se: Do we want `Document sudo/user change + tags for image` in 2.20 as well?
19:54:42 <gundalow> bah
19:54:58 <gundalow> I meant https://github.com/ansible/molecule/pull/1853/files
19:56:19 <decentral1se> I think most are reading the `latest` docs, which is the master build (let's not go there ...)
19:56:30 <decentral1se> which is another can of worms because a lot of users are not sure what is in what version ...
19:56:44 <decentral1se> so, I am just for making this 2.20 release and let's drop everything else :)
19:57:05 <decentral1se> we can merge that afterwards, it will be in the latest docs and that should be fine
19:57:12 <gundalow> ah, good point well made
19:58:39 <decentral1se> @zbr: https://github.com/ansible/molecule/pull/1838#discussion_r267519231
19:59:16 <gundalow> https://travis-ci.com/ansible/molecule/builds/105189674 is green, merging
19:59:29 <Not-e6c6> [molecule] gundalow closed pull request #1838: Document sudo/user change + tags for image - https://git.io/fjebL
19:59:50 <zbr> gundalow: i am sure is possible but before doing this, at least do not use latest and use master instead
19:59:50 <gundalow> zbr: Is this your bot ^, could it say "merged"
20:00:21 <zbr> gundalow: not my bot, hosted, cannot configure message format.
20:00:22 <decentral1se> as shown in https://github.com/ansible/molecule/issues/1818, there are multiple ways to do "latest"
20:00:42 <decentral1se> it is a discussion for after, I think
20:00:53 <decentral1se> we have a numbered tag, we can stick to that tradition and that is what we're offering right now
20:01:15 <zbr> sure, not a reason the miss the release
20:01:58 <zbr> especially as I do not know if the number of people using the docker version in production is other than null
20:02:44 <decentral1se> right
20:03:13 <zbr> for me the docker version makes no sense because my DOCKER_HOST points to a remote machine, so any attempt to use it with molecule would fail badly as volume mounts do not work.
20:03:32 <Not-e6c6> [molecule] decentral1se closed issue #1818: Quay tags: stable/latest/pre-release etc. - https://git.io/fjfa9
20:04:15 <Not-e6c6> [molecule] gundalow created tag 2.20 - https://git.io/fjfaH
20:04:17 <Not-e6c6> [molecule] gundalow tagged 99e03ea as 2.20 https://git.io/fjfaQ
20:04:18 <gundalow> TAGGED
20:04:19 <decentral1se> https://github.com/ansible/molecule/projects/2 is empty!
20:04:28 <decentral1se> oh shhitttttttttt
20:05:07 * gundalow tries to work out if decentral1se is joking
20:05:16 <decentral1se> haha sorry
20:05:23 <decentral1se> I meant in a kinda of 'BOOM' way
20:05:36 <decentral1se> oh wait
20:05:41 <decentral1se> damn text communication lol
20:05:52 <decentral1se> I MEANT: THIS IS GOOD, THANK YOU
20:06:12 <gundalow> #info Molecule 2.20 is building
20:06:15 <gundalow> Thanks all
20:06:20 <themr0c> yeah
20:06:21 <gundalow> Guess we are done for today
20:06:49 <themr0c> oh may i annonce it to french side of belgium tommorrow ?
20:06:57 <themr0c> that's awesome
20:07:15 <decentral1se> well done folks
20:07:24 <decentral1se> yep, I'm out, nice one!
20:07:51 <gundalow> themr0c: yup
20:07:55 <gundalow> Great work all
20:07:57 <gundalow> #endmeeting