ansible_core_public_irc_meeting_(part_deux)
MINUTES

#ansible-meeting: ansible core public irc meeting (part deux)

Meeting started by abadger1999 at 16:23:48 UTC (full logs).

Meeting summary

  1. tombstoning (abadger1999, 16:24:03)
    1. https://github.com/ansible/ansible/blob/devel/lib/ansible/plugins/loader.py#L448-L459 (felixfontein, 16:24:41)
    2. https://github.com/ansible/ansible/blob/devel/lib/ansible/config/ansible_builtin_runtime.yml#L2163-L2166 (felixfontein, 16:24:57)
    3. there must be removal_version and removal_date (mutually exclusive and one required?) and warning_text (optional) (abadger1999, 16:28:41)
    4. https://github.com/ansible/ansible/blob/devel/hacking/build_library/build_ansible/command_plugins/file_deprecated_issues.py (abadger1999, 16:32:20)
    5. AGREED: dates in YAML can either be a YAML date or YYYY-MM-DD (ISO xxxx) - that's for plugin/module documentation, meta/runtime.yml, and its ansible-base equivalent (felixfontein, 16:37:46)

  2. Getting 69796 merged before beta (abadger1999, 16:38:21)
    1. AGREED: 69313 is going through final review for merging today (abadger1999, 16:44:16)
    2. ACTION: mattclay is doing final review on 69313 (abadger1999, 16:44:28)
    3. a followup PR to change how ansible-doc displays name as FQCN in its human-text output would be appropriate for after beta (but not --json output) (abadger1999, 16:45:24)
    4. ACTION: abadger1999 to look at https://github.com/ansible/ansible/pull/69968 and merge (acozine wrote and felixfontein approved) (abadger1999, 16:47:32)
    5. ACTION: abadger1999 will merge https://github.com/ansible/ansible/pull/69796 [ felixfontein and bcoca now think it is ready] (abadger1999, 16:57:03)
    6. ACTION: acozine will update the ansible-doc integration test to use shortname (abadger1999, 16:57:25)

  3. open floor (abadger1999, 16:57:48)
    1. https://github.com/ansible/ansible/pull/70007 (cyberpear, 16:57:57)

  4. https://github.com/ansible/ansible/pull/70007 config: singular ANSIBLE_COLLECTIONS_PATH (abadger1999, 16:58:26)
    1. AGREED: 70007 is ready to merge (+1 from nitzmahone) (abadger1999, 17:05:40)
    2. ACTION: abadger1999 will merge after the meeting. (abadger1999, 17:05:53)


Meeting ended at 17:06:50 UTC (full logs).

Action items

  1. mattclay is doing final review on 69313
  2. abadger1999 to look at https://github.com/ansible/ansible/pull/69968 and merge (acozine wrote and felixfontein approved)
  3. abadger1999 will merge https://github.com/ansible/ansible/pull/69796 [ felixfontein and bcoca now think it is ready]
  4. acozine will update the ansible-doc integration test to use shortname
  5. abadger1999 will merge after the meeting.


Action items, by person

  1. abadger1999
    1. abadger1999 to look at https://github.com/ansible/ansible/pull/69968 and merge (acozine wrote and felixfontein approved)
    2. abadger1999 will merge https://github.com/ansible/ansible/pull/69796 [ felixfontein and bcoca now think it is ready]
    3. abadger1999 will merge after the meeting.
  2. acozine
    1. abadger1999 to look at https://github.com/ansible/ansible/pull/69968 and merge (acozine wrote and felixfontein approved)
    2. acozine will update the ansible-doc integration test to use shortname
  3. bcoca
    1. abadger1999 will merge https://github.com/ansible/ansible/pull/69796 [ felixfontein and bcoca now think it is ready]
  4. felixfontein
    1. abadger1999 to look at https://github.com/ansible/ansible/pull/69968 and merge (acozine wrote and felixfontein approved)
    2. abadger1999 will merge https://github.com/ansible/ansible/pull/69796 [ felixfontein and bcoca now think it is ready]
  5. mattclay
    1. mattclay is doing final review on 69313


People present (lines said)

  1. felixfontein (53)
  2. abadger1999 (41)
  3. nitzmahone (24)
  4. acozine (16)
  5. cyberpear (14)
  6. zodbot (7)
  7. bcoca (5)
  8. mattclay (3)


Generated by MeetBot 0.1.4.