ansible_core_public_irc_meeting
MINUTES

#ansible-meeting: ansible core public irc meeting

Meeting started by gundalow at 15:31:28 UTC (full logs).

Meeting summary

  1. ansible-base 2.10 beta 1 (gundalow, 15:32:32)
    1. ansible-base beta 1 will be released on 2020-06-01 (gundalow, 15:33:18)
    2. https://github.com/ansible/ansible/pull/69727 - fixes deprecation of modules in collections: right now ansible-test will scream at you if you don't want to remove a module for a ansible-base version (felixfontein, 15:37:29)
    3. https://github.com/ansible/proposals/issues/178 and https://github.com/ansible/ansible/pull/69680 make sure that people know *WHAT* exactly is deprecating something (or *WHERE* a new feature was added) - no matter whether it's about versions or dates (felixfontein, 15:38:32)
    4. https://github.com/ansible/ansible/projects/39 also appears to have a fair bit of open stuff in (gundalow, 15:40:57)
    5. ACTION: https://github.com/ansible/ansible/pull/69313 use antsibull-changelog for ansible/ansible (felixfontein, 15:54:25)

  2. https://github.com/ansible/ansible/pull/69313 use antsibull-changelog for ansible/ansible (abadger1999, 16:04:13)
    1. ACTION: mattclay and nitzmahone to review 69313 to get it merged before 2.10beta1. (abadger1999, 16:11:45)
    2. if not merged before 2.10beta1, ansible-base RMs can get it working before 2.10 final but there will be a lot of additional work to make that happen. (abadger1999, 16:13:17)
    3. ACTION: felixfontein to look at splitting the per-collection-changelog functionality into its own package. (abadger1999, 16:27:34)
    4. AGREED: https://github.com/ansible/ansible/pull/69313 is a 2.10 blocker... will attempt to get it in before 2.10beta1 (abadger1999, 16:35:09)

  3. 18:11 <@abadger1999> #action mattclay and nitzmahone to review 69313 to get it merged before 2.10beta1. (felixfontein, 16:35:18)
  4. https://github.com/ansible/ansible/pull/69727 (felixfontein, 16:35:26)
    1. AGREED: https://github.com/ansible/ansible/pull/69727 is a 2.10beta1 blocker. (abadger1999, 16:40:27)
    2. ACTION: nitzmahone and mattclay to review today. (abadger1999, 16:40:37)
    3. in broad overview, this looks good. (abadger1999, 16:40:56)

  5. https://github.com/ansible/ansible/pull/69680 and https://github.com/ansible/proposals/issues/178 (felixfontein, 16:41:28)
    1. AGREED: https://github.com/ansible/ansible/pull/69680 is a 2.10beta1 blocker (abadger1999, 16:51:08)
    2. ACTION: nitzmahone and mattclay to review https://github.com/ansible/ansible/pull/69680 today (abadger1999, 16:51:20)

  6. open floor (abadger1999, 16:57:36)
  7. testing of website build for ansible-2.10 (abadger1999, 17:01:57)
    1. one issue we have is that the non-website-build ansible-test tests do not check the whole schema (abadger1999, 17:28:43)
    2. ACTION: abadger1999 to talk to mattclay about some possibilities he has for rectifying the schema. (abadger1999, 17:29:09)
    3. AGREED: we do not have to do anything in ansible/ansible to solver people are not running the docs tests against their collections. (abadger1999, 17:30:07)
    4. AGREED: we can rely on the current tests in ansible-test (ansible-doc parsing for everything and avlidate-modules does a 90% shcema validation for modules) to cover the most problematic test cases for 2.10. (abadger1999, 17:48:16)
    5. AGREED: ansible/ansible will continue to test all parts of the docsite that ship within the ansible/ansible repo (abadger1999, 17:49:06)
    6. AGREED: updates to the website build test which only runs against ansible/ansible can be put in after freeze. (abadger1999, 17:49:28)
    7. ACTION: abadger1999 to update the website build and website build test (abadger1999, 17:49:48)
    8. ACTION: acozine to add "please test against the stable ansible-base version you are targeting" to https://docs.ansible.com/ansible/devel/dev_guide/developing_collections.html#testing-collections (abadger1999, 18:05:20)
    9. AGREED: need to figure out a way to start using requires_ansible_version for building ansible for 2.11 (abadger1999, 18:05:53)
    10. ACTION: abadger1999 to open a bug to look into requires_ansible_version for building ansible for 2.11 (abadger1999, 18:06:09)


Meeting ended at 18:06:16 UTC (full logs).

Action items

  1. https://github.com/ansible/ansible/pull/69313 use antsibull-changelog for ansible/ansible
  2. mattclay and nitzmahone to review 69313 to get it merged before 2.10beta1.
  3. felixfontein to look at splitting the per-collection-changelog functionality into its own package.
  4. nitzmahone and mattclay to review today.
  5. nitzmahone and mattclay to review https://github.com/ansible/ansible/pull/69680 today
  6. abadger1999 to talk to mattclay about some possibilities he has for rectifying the schema.
  7. abadger1999 to update the website build and website build test
  8. acozine to add "please test against the stable ansible-base version you are targeting" to https://docs.ansible.com/ansible/devel/dev_guide/developing_collections.html#testing-collections
  9. abadger1999 to open a bug to look into requires_ansible_version for building ansible for 2.11


Action items, by person

  1. abadger1999
    1. abadger1999 to talk to mattclay about some possibilities he has for rectifying the schema.
    2. abadger1999 to update the website build and website build test
    3. abadger1999 to open a bug to look into requires_ansible_version for building ansible for 2.11
  2. acozine
    1. acozine to add "please test against the stable ansible-base version you are targeting" to https://docs.ansible.com/ansible/devel/dev_guide/developing_collections.html#testing-collections
  3. felixfontein
    1. felixfontein to look at splitting the per-collection-changelog functionality into its own package.
  4. mattclay
    1. mattclay and nitzmahone to review 69313 to get it merged before 2.10beta1.
    2. nitzmahone and mattclay to review today.
    3. nitzmahone and mattclay to review https://github.com/ansible/ansible/pull/69680 today
    4. abadger1999 to talk to mattclay about some possibilities he has for rectifying the schema.
  5. nitzmahone
    1. mattclay and nitzmahone to review 69313 to get it merged before 2.10beta1.
    2. nitzmahone and mattclay to review today.
    3. nitzmahone and mattclay to review https://github.com/ansible/ansible/pull/69680 today


People present (lines said)

  1. felixfontein (141)
  2. abadger1999 (134)
  3. mattclay (79)
  4. acozine (60)
  5. nitzmahone (48)
  6. samccann (27)
  7. gundalow (19)
  8. shertel (15)
  9. jtanner (15)
  10. cyberpear (14)
  11. zodbot (7)
  12. dmellado (5)
  13. geerlingguy (2)
  14. jimi|ansible (1)
  15. relrod (1)
  16. sdoran (0)


Generated by MeetBot 0.1.4.