ansible_core
MINUTES

#ansible-meeting: ansible core

Meeting started by thaumos at 15:00:05 UTC (full logs).

Meeting summary

  1. filesystem module refactor merge request (thaumos, 15:04:19)
    1. https://github.com/ansible/ansible/pull/25519 (thaumos, 15:04:58)
    2. ACTION: bcoca to do final review & merge on https://github.com/ansible/ansible/pull/25519 (gundalow, 15:08:29)

  2. Discuss a preferred method to handle playbook adjacent group_vars directories (thaumos, 15:13:42)
    1. https://github.com/ansible/ansible/issues/33177 (thaumos, 15:14:00)
    2. In Ansible 2.3, it appears that the function _get_hostgroup_vars from the Inventory class handled the scenario of a playbook that included another playbook and kept the path of the original playbook in scope. However, in 2.4 with the transition to inventory plugins, the basedirs for the playbook are determined by the DataLoader which doesn't appear to have any knowledge of the original playbook that did the include/import. I would lik (gundalow, 15:14:19)
    3. ACTION: sivel to provide an explanation in the issue, and update the porting guide for 2.4 (sivel, 15:31:50)
    4. ACTION: sivel to document the playbook dir change in the porting guide and on the bug report (abadger1999, 15:31:51)
    5. ACTION: again as above (thaumos, 15:32:02)

  3. LooseVersion comparison in py3 is subject to exceptions due to comparing int and str. DO weo go with that PR or do something else? (thaumos, 15:32:34)
    1. https://github.com/ansible/ansible/pull/34427 (thaumos, 15:32:47)
    2. ACTION: we will address each LooseVersion failure on it's own for now (sivel, 15:45:39)
    3. ACTION: sivel will talk to chouse about galaxy versions, and documenting a spec (sivel, 15:45:55)
    4. ACTION: sivel will update galaxy code to catch exception, and error to the user pointing to glaxy version spec (sivel, 15:46:24)
    5. ACTION: sivel to talk to chouseknecht about plans for versioning specification of galaxy roles (abadger1999, 15:59:36)

  4. Open floor (abadger1999, 16:00:57)
    1. https://github.com/ansible/ansible/issues/34272 since bcoca is in holiday, can I bring attention to that bug ? (misc, 16:01:35)
    2. ACTION: abadger1999 will have jimi|ansible look into 34272 and then will write up a porting guide entry if it's really a bugfix. (abadger1999, 16:05:14)
    3. https://github.com/ansible/community/issues/291#issuecomment-355960628 (andol, 16:17:17)

  5. cloudflare_dns bugfix ansible/ansible#31800 (gundalow, 16:19:09)
    1. ACTION: akasurde to merge PR (thaumos, 16:23:37)
    2. ACTION: andol to reach out to jtanner about getting added to botmeta for maintainership of module (thaumos, 16:24:00)


Meeting ended at 16:24:27 UTC (full logs).

Action items

  1. bcoca to do final review & merge on https://github.com/ansible/ansible/pull/25519
  2. sivel to provide an explanation in the issue, and update the porting guide for 2.4
  3. sivel to document the playbook dir change in the porting guide and on the bug report
  4. again as above
  5. we will address each LooseVersion failure on it's own for now
  6. sivel will talk to chouse about galaxy versions, and documenting a spec
  7. sivel will update galaxy code to catch exception, and error to the user pointing to glaxy version spec
  8. sivel to talk to chouseknecht about plans for versioning specification of galaxy roles
  9. abadger1999 will have jimi|ansible look into 34272 and then will write up a porting guide entry if it's really a bugfix.
  10. akasurde to merge PR
  11. andol to reach out to jtanner about getting added to botmeta for maintainership of module


Action items, by person

  1. abadger1999
    1. abadger1999 will have jimi|ansible look into 34272 and then will write up a porting guide entry if it's really a bugfix.
  2. akasurde
    1. akasurde to merge PR
  3. andol
    1. andol to reach out to jtanner about getting added to botmeta for maintainership of module
  4. jimi|ansible
    1. abadger1999 will have jimi|ansible look into 34272 and then will write up a porting guide entry if it's really a bugfix.
  5. jtanner
    1. andol to reach out to jtanner about getting added to botmeta for maintainership of module
  6. sivel
    1. sivel to provide an explanation in the issue, and update the porting guide for 2.4
    2. sivel to document the playbook dir change in the porting guide and on the bug report
    3. sivel will talk to chouse about galaxy versions, and documenting a spec
    4. sivel will update galaxy code to catch exception, and error to the user pointing to glaxy version spec
    5. sivel to talk to chouseknecht about plans for versioning specification of galaxy roles
  7. UNASSIGNED
    1. bcoca to do final review & merge on https://github.com/ansible/ansible/pull/25519
    2. again as above
    3. we will address each LooseVersion failure on it's own for now


People present (lines said)

  1. abadger1999 (90)
  2. sivel (77)
  3. jimi|ansible (51)
  4. thaumos (34)
  5. maxamillion (18)
  6. gundalow (17)
  7. misc (15)
  8. tdtrask (11)
  9. zodbot (10)
  10. andol (8)
  11. dag (5)
  12. akasurde (5)
  13. jtanner (3)
  14. Pilou (2)
  15. gregdek (2)
  16. rcarrillocruz (1)
  17. mikedlr (1)


Generated by MeetBot 0.1.4.