testing_working_group
LOGS
17:00:34 <mattclay> #startmeeting Testing Working Group
17:00:34 <zodbot> Meeting started Thu Apr 13 17:00:34 2017 UTC.  The chair is mattclay. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:34 <zodbot> The meeting name has been set to 'testing_working_group'
17:01:09 <mattclay> Who's here?
17:01:25 * resmo waves
17:01:57 <mattclay> #chair resmo
17:01:57 <zodbot> Current chairs: mattclay resmo
17:02:27 <mattclay> gundalow had a conflicting meeting, so he won't be here for today's meeting.
17:02:57 <mattclay> #topic Ansible 2.3.0 FINAL has been released.
17:03:05 <resmo> ok then
17:03:12 <mattclay> Thanks to everyone who contributed/tested for this release.
17:03:34 <mattclay> Please, test the new release and open issues as needed.
17:04:01 <mattclay> #topic Contributors Summit
17:04:17 <mattclay> #info If anyone is interested in joining the Contributors Summit (in person or remote), ping @gundalow directly.
17:04:52 <resmo> nice, is there a special ticket for it?
17:05:07 <resmo> for the fest the day after
17:05:08 <mattclay> I'm not sure. You'll need to ask gundalow.
17:05:15 <resmo> ok, I will
17:05:36 <mattclay> #topic Holidays / PTO
17:05:58 <mattclay> Most of the Ansible Core Team will be off tomorrow, since Friday is a holiday.
17:06:30 <mattclay> Also, I'll be on PTO all next week. gundalow will be keeping an eye on Shippable while I'm out.
17:07:02 <mattclay> Also, jtanner is on PTO next week, so the bot SLA will be less than usual.
17:07:55 <mattclay> #topic CloudStack testing (https://github.com/ansible/community/issues/114#issuecomment-292908029)
17:08:15 <resmo> this one is from me
17:09:24 <resmo> the tests are runnable and can be integrated, I don't now how to bring this into ansible test setup. I would need some help.
17:09:30 <mattclay> I still have it on my list to implement support for this in ansible-test. However, I won't be getting to it until after I'm back from PTO.
17:09:46 <resmo> that would be fine,
17:10:09 <resmo> I just wondered if you wait for me to do any further task
17:10:38 <mattclay> The integration is more complex than just adding additional tests, since it's going to have a dedicated test command, just like we do for windows-integration.
17:11:29 <resmo> yes, I also think this integration could be an example for others like e.g. gitlab modules, jenkins modules, etc
17:12:26 <resmo> so, it is on your list. all fine.
17:12:39 <resmo> let me know if I can help.
17:12:46 <mattclay> I will.
17:12:52 <mattclay> #topic Open Floor
17:13:54 <mattclay> I have a PR open for adding `rstcheck` to CI which should be getting merged soon: https://github.com/ansible/ansible/pull/23550
17:14:45 <mattclay> This should help us catch many docs issues earlier without having to run the docs build in CI (which is quite slow).
17:15:07 <resmo> nice
17:15:21 <mattclay> It should help avoid mistakes as we convert existing .md files to .rst.
17:16:34 <mattclay> I've updated the "other" tests on Shippable to mostly run under python 3.5 now (instead of 2.7). If you notice any differences in behavior between Shippable and local testing  for sanity tests, this change may be responsible.
17:17:12 <mattclay> That's all I have.
17:17:17 <mattclay> resmo: Anything else from you?
17:17:26 <resmo> regarding new modules and ANSIBLE_METADATA, abadger1999 mentioned that new modules should have "preview". This would probably also make sense to add in the tests, what do you think?
17:17:54 <mattclay> That seems like a reasonable check to add to the module validator.
17:19:11 <mattclay> resmo: Do you want to add that to validate-modules?
17:19:46 <resmo> mattclay: ack
17:20:56 <resmo> that's it from me, will you be in london?
17:21:04 <mattclay> #action resmo to add check in validate-modules for new modules being marked "preview"
17:21:19 <mattclay> No, I won't. I'm actually traveling to China next week.
17:21:30 <resmo> uff, ok. have a nice trip!
17:22:43 <mattclay> Does anyone else have anything?
17:23:16 * mattclay suspects nobody is lurking
17:24:06 <mattclay> #endmeeting