testing_working_group
MINUTES

#ansible-meeting: Testing Working Group

Meeting started by gundalow at 17:25:11 UTC (full logs).

Meeting summary

  1. Testing Procedures (gundalow, 17:26:18)
    1. https://gist.github.com/bcoca/ddae02808f5cb778351bf2dfeb0b76f2 <= same play as bug, working! (bcoca, 17:38:15)

  2. How to deal with PRs that fail CI *after* merge (but passed PR CI) (gundalow, 18:06:08)
    1. https://github.com/ansible/community/issues/114#issuecomment-289768234 (gundalow, 18:06:16)
    2. The short answer is to fix them quickly. There isn't anything we can do with GH to prevent this from happening (gundalow, 18:06:59)
    3. ACTION: gundalow to email Core and tell them to check date of last commit before merging, if > 1w, rerun CI. Add to triage (gundalow, 18:23:39)
    4. AGREED: rerun CI if last commit is over a week (gundalow, 18:24:33)
    5. ACTION: gundalow ignore triage comment (gundalow, 18:25:41)
    6. ACTION: mattclay to submit bot feature requests for 1) labeling stale_ci, 2) gating auto-merge on stale_ci, 3) extending "shipit" to all PRs (mattclay, 18:44:33)
    7. We'll need to work out some details on how we want extend "shipit" to support all PRs. Perhaps at the next TWG. (gundalow, 18:47:34)


Meeting ended at 18:53:58 UTC (full logs).

Action items

  1. gundalow to email Core and tell them to check date of last commit before merging, if > 1w, rerun CI. Add to triage
  2. gundalow ignore triage comment
  3. mattclay to submit bot feature requests for 1) labeling stale_ci, 2) gating auto-merge on stale_ci, 3) extending "shipit" to all PRs


Action items, by person

  1. gundalow
    1. gundalow to email Core and tell them to check date of last commit before merging, if > 1w, rerun CI. Add to triage
    2. gundalow ignore triage comment
  2. mattclay
    1. mattclay to submit bot feature requests for 1) labeling stale_ci, 2) gating auto-merge on stale_ci, 3) extending "shipit" to all PRs


People present (lines said)

  1. gundalow (98)
  2. bcoca (46)
  3. mattclay (40)
  4. jtanner (40)
  5. bjornar_ (37)
  6. sivel (11)
  7. zodbot (4)
  8. abadger1999 (3)
  9. funzo (2)
  10. nitzmahone (1)


Generated by MeetBot 0.1.4.