ansible_core_meeting
MINUTES

#ansible-meeting: Ansible Core Meeting

Meeting started by gundalow at 19:01:06 UTC (full logs).

Meeting summary

    1. Agenda https://github.com/ansible/community/issues/156 (gundalow, 19:01:53)

  1. Core Update (gundalow, 19:01:58)
    1. Ansible 2.3 RC2 has been released, PLEASE TEST IT :) (gundalow, 19:02:20)
    2. https://groups.google.com/forum/#!topic/ansible-devel/cmYsumCc4kA (gundalow, 19:02:46)

  2. Discuss extending the module "shipit" workflow to non-modules (gundalow, 19:06:31)
    1. https://github.com/ansible/community/issues/156#issuecomment-283631658 (gundalow, 19:06:43)
    2. https://github.com/ansible/ansibullbot/issues/437 (gundalow, 19:06:52)
    3. 2.3RC3 will probably be Thurrsday (abadger1999, 19:10:31)

  3. Versioned Docs (gundalow, 19:14:57)
    1. PRGRESS (gundalow, 19:15:01)
    2. https://github.com/ansible/proposals/issues/60 Versioned Docs Proposal (gundalow, 19:15:33)
    3. https://github.com/ansible/ansible/pull/22546 (gundalow, 19:34:06)

  4. RST (gundalow, 19:34:27)
    1. AGREED: RST is the format that's agreed on (gundalow, 19:34:44)
    2. AGREED: now that stable-2.3 has been branched we can update devel to use rst for CHANGELOG etc (gundalow, 19:35:10)
    3. AGREED: MD is EVIL needs blocking. Review all MD, review https://ansible.sivel.net/pr/byfile.html for any PRs in flight that change MD (gundalow, 19:36:49)
    4. AGREED: add some CI to block is a .md file is aded (gundalow, 19:37:17)
    5. if we come up with some legit reason for one to exist later we can always whitelist. (gundalow, 19:37:34)
    6. code-smell can be used to do this (gundalow, 19:37:53)

  5. expand doc fields (gundalow, 19:40:52)
    1. https://github.com/ansible/proposals/issues/58 (gundalow, 19:40:59)
    2. https://github.com/ansible/ansible/blob/devel/test/sanity/validate-modules/schema.py (gundalow, 19:42:06)
    3. https://github.com/ansible/ansible/pull/22353/files#diff-2b9fb4f33282b91405036e352004be12 is where this was implmented (gundalow, 19:46:26)
    4. ACTION: bcoca to pick a name and update whatever needs updating (gundalow, 19:53:59)
    5. bcoca updated code to use 'options' (bcoca, 19:55:25)
    6. http://docs.ansible.com/ansible/eos_banner_module.html is an example of 1 (gundalow, 20:00:51)
    7. letsmoveon (bcoca, 20:02:20)

  6. Open Floor (gundalow, 20:02:30)
  7. do we implement group_vars/host_vars as vars plugins? or eliminate vars_plugins and fold them into inventory plugins (gundalow, 20:03:19)
    1. https://github.com/ansible/ansible/pull/23001 (bcoca, 20:08:51)


Meeting ended at 20:32:55 UTC (full logs).

Action items

  1. bcoca to pick a name and update whatever needs updating


Action items, by person

  1. bcoca
    1. bcoca to pick a name and update whatever needs updating


People present (lines said)

  1. gundalow (114)
  2. bcoca (99)
  3. nitzmahone (51)
  4. jtanner (22)
  5. abadger1999 (21)
  6. sivel (16)
  7. mattclay (6)
  8. ryansb (6)
  9. zodbot (4)
  10. dharmabumstead (3)
  11. shertel (1)
  12. funzo (1)
  13. jimi|ansible (1)
  14. Qalthos (0)
  15. alikins (0)


Generated by MeetBot 0.1.4.