ansible_core_meeting
MINUTES

#ansible-meeting: Ansible Core Meeting

Meeting started by gundalow at 19:00:29 UTC (full logs).

Meeting summary

    1. Agenda, feel free to add things https://github.com/ansible/community/issues/150 (gundalow, 19:02:26)

  1. Proposal Process (gundalow, 19:04:23)
    1. Need to work out who has the action to document the proposed Proposal Workflow (gundalow, 19:05:50)
    2. the proposal update should be done in a PR which updates https://github.com/ansible/proposals/blob/master/proposals_process_proposal.md (gundalow, 19:11:10)
    3. ACTION: allanice001 has kindly offered to raise a PR to update proposals_process_proposal.md (gundalow, 19:12:49)
    4. In the future we can look at moving this under docs.ansible.com/ansible/NEWDIR/process_proposal.html (though that's not a priority at the moment, and required gundalow to think about better names) (gundalow, 19:13:41)
    5. gundalow to move the doc under rst once it's been agreed (gundalow, 19:14:18)
    6. gundalow wants to create a new docs section for other things, but isn't sure what to call it yet, details about our release process, proposal process, etc will go there, rather than under dev_guide. Need to bikeshed a name (gundalow, 19:16:46)

  2. ansible/ansible#18453 "pycrypto not listed in the Python package requirements list" (gundalow, 19:19:22)
    1. https://github.com/ansible/ansible/issues/18453 (gundalow, 19:19:34)
    2. This issue highlighted: 1) Update the requirements in documentation 2) Prevent future desync between setup.py and docs (gundalow, 19:20:13)
    3. Sivel suggested: Maybe we could move the requirements to install into a requirements.txt file that is referenced by setup.py as well as the instructions specifying to utilize the requirements.txt instead of listing the packages separately in 2 locations? Just a thought, as I've seen this done elsewhere. (gundalow, 19:21:20)
    4. ACTION: abadger and sivel to figure out how to implement docs and stup.py using the same requirements.txt to install dependencies. (abadger2000, 19:39:27)
    5. https://github.com/google/google-apputils (bcoca, 19:39:48)
    6. Docs side we change it to: pip install -r requirements.txt (gundalow, 19:40:04)

  3. ansible/ansible#21299 Add "idempotence check" section to module docs (gundalow, 19:40:18)
    1. (gundalow, 19:40:27)
    2. https://github.com/ansible/ansible/issues/21299 (gundalow, 19:40:36)
    3. a) not all modules are idempotent (gundalow, 19:43:29)
    4. b) that can get complicated (gundalow, 19:43:39)
    5. c) notes; already exist as well as you can add to descriptions of 'state' (gundalow, 19:43:49)
    6. d) all the more docs to become outdated with (gundalow, 19:43:58)
    7. -1: jtanner, thaumos, ryansb, gundalow, abadger2000, mattclay, sivel, allanice001 (8) (gundalow, 19:52:23)
    8. +0: bcoca (gundalow, 19:52:30)
    9. AGREED: No to updating a new field (gundalow, 19:54:02)
    10. ACTION: gundalow to add some words to developing_modules_documenting.html's notes: regarding "for example if check_mode is only supported with some parameters" (gundalow, 19:58:32)

  4. Open Floor (gundalow, 19:59:06)
  5. Commits to devel (gundalow, 19:59:53)
  6. Open Floor (gundalow, 20:00:14)
    1. note to all ... needs_revision is a constant work in progress with the bot. Please point out irregularities or inconsistencies to jtanner (gundalow, 20:00:32)
    2. All code changes to devel must go via PRs. Shippable is their to help you, look before merging (gundalow, 20:01:17)
    3. AGREED: (allanice001, 20:05:28)
    4. If you have anything for next meeting please add to https://github.com/ansible/community/issues/150 (gundalow, 20:05:37)


Meeting ended at 20:05:53 UTC (full logs).

Action items

  1. allanice001 has kindly offered to raise a PR to update proposals_process_proposal.md
  2. abadger and sivel to figure out how to implement docs and stup.py using the same requirements.txt to install dependencies.
  3. gundalow to add some words to developing_modules_documenting.html's notes: regarding "for example if check_mode is only supported with some parameters"


Action items, by person

  1. allanice001
    1. allanice001 has kindly offered to raise a PR to update proposals_process_proposal.md
  2. gundalow
    1. gundalow to add some words to developing_modules_documenting.html's notes: regarding "for example if check_mode is only supported with some parameters"
  3. sivel
    1. abadger and sivel to figure out how to implement docs and stup.py using the same requirements.txt to install dependencies.


People present (lines said)

  1. gundalow (98)
  2. abadger2000 (43)
  3. allanice001 (37)
  4. bcoca (34)
  5. sivel (22)
  6. jtanner (20)
  7. thaumos (16)
  8. zodbot (6)
  9. ryansb (4)
  10. mattclay (2)
  11. akasivel (2)
  12. resmo (1)
  13. shertel (1)
  14. jimi|ansible (1)
  15. nitzmahone (1)
  16. Qalthos (0)


Generated by MeetBot 0.1.4.