community
LOGS
19:32:38 <gregdek> #startmeeting Community
19:32:38 <zodbot> Meeting started Mon Feb 29 19:32:38 2016 UTC.  The chair is gregdek. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:32:38 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:32:38 <zodbot> The meeting name has been set to 'community'
19:32:57 <gregdek> #topic Waffle Board Review
19:33:11 <gregdek> #link https://waffle.io/ansible/community
19:33:43 <gregdek> Hm, looks like meetbot doesn't have op.
19:33:51 <gregdek> Adding that as a ticket!
19:34:52 <gregdek> https://github.com/ansible/community/issues/25
19:34:57 <rbergeron> #action gregdek to add that as a ticket
19:35:01 <jimi|ansible> dowe want a bot to have ops?
19:35:19 <gregdek> Standard practice; they do it in the #fedora channels.
19:35:23 <jimi|ansible> pretty sure that's step one to SkyNet
19:35:29 <gregdek> And since this is a meeting channel... :)
19:35:37 <jimi|ansible> ;)
19:35:39 <gregdek> I would say no for most channels, but yes for a meeting channel
19:36:04 <gregdek> #topic validate that bot has op
19:36:14 <gregdek> #topic
19:36:32 <gregdek> The real question is, is Zodbot smart enough to reset the topic when the meeting ends?
19:36:35 <jimi|ansible> gregdek: -> [14:36] [Notice] -ChanServ- Flags +Oo were set on zodbot in #ansible.
19:36:40 <jimi|ansible> doh!
19:36:45 <jimi|ansible> just realized i screwed that up...
19:37:01 <gregdek> Well, I just opped it myself...
19:37:07 <gregdek> with the /op command...
19:37:09 <jimi|ansible> yep, but now it will be done automatically
19:37:14 <gregdek> not smart enough to do it the "right" way.
19:37:15 <gregdek> Oh! Thanks!
19:37:18 <gregdek> Awesome :)
19:37:23 <jimi|ansible> so close that issue :)
19:37:30 <gregdek> WITH PLEASURE
19:37:40 <jimi|ansible> while i'm at it...
19:39:53 <rbergeron> @gregdek: can you #addchair rbergeron
19:40:07 <gregdek> #addchair rbergeron
19:40:09 <gregdek> LOL
19:40:13 <gregdek> Remembering how meetbot works!
19:40:16 <rbergeron> yeah. been a while :)
19:40:18 <gregdek> Been a while.
19:40:24 <rbergeron> #action gregdek rbergeron remember how meetbot works
19:41:00 <gregdek> https://github.com/ansible/community/issues/5
19:41:02 <jimi|ansible> thanks for speaking at the right time rbergeron, reminded me to add you to the flags too while adding newtMcKerr and nitzmahone_
19:41:05 <gregdek> "Promote best tools".
19:41:38 <gregdek> We can leave this out there for a community person to do, but we don't want to leave it there forever.
19:41:51 <gregdek> We need to sort out the right level of "curation" for this kind of thing.
19:41:55 <gregdek> For instance:
19:42:03 <gregdek> * We know that we want ansible-lint here.
19:42:15 <gregdek> Are there any other tools we know should be added?
19:42:19 <rbergeron> Right. And what's the difference between that and https://github.com/jdauphant/awesome-ansible ?
19:42:28 <rbergeron> Or is awesome-ansible one of those things for ansible best tools? :)
19:42:38 <rbergeron> Ansible Community-recommended tools might be different from awesome-ansible.
19:42:41 <rbergeron> But maybe not.
19:42:44 <gregdek> Maybe not!
19:42:55 <rbergeron> We may just concur with awesome-ansible, generally :) and need to promote *that* with more love.
19:43:13 <gregdek> Should we pull it into ansible repo then?
19:44:35 <gregdek> I think we require a stricter level of scrutiny for this kind of "official-ness".
19:44:52 <rbergeron> yeah
19:44:56 <gregdek> Welp! Let's leave it open for now.
19:45:20 <rbergeron> #actions link to this irc convo in the ansible-best-tools ticket
19:45:20 <gregdek> #topic planetansible.org
19:45:22 <gregdek> https://github.com/ansible/community/issues/6
19:45:39 <gregdek> So how do we promote this better and get more cool feeds on it
19:45:40 <gregdek> ?
19:45:58 <rbergeron> So: I think we could ask rwolters if he wants to (in lieu of any other process) take tickets for folks to be added to planet
19:46:31 <rbergeron> via the community issue list
19:46:33 <gregdek> Yeah, we could do that.
19:47:02 <gregdek> The trouble is, there's nothing there currently on the planet to say "this is how you get yourself added", and I think we need that.
19:47:15 <rbergeron> I think we would ask roland to add that detail as part of the thing to do
19:47:27 <rbergeron> if he wants to take github issues in that way to add people :)
19:47:31 <gregdek> yep.
19:47:37 <gregdek> ok, who owns it? :)
19:47:37 <rbergeron> Or we ask him either way, even if he doesn't want to take issues.
19:47:47 <gregdek> I have been nominated.
19:47:49 <gregdek> I accept.
19:47:56 <rbergeron> #action gregdek to contact roland re: the above
19:48:03 <rbergeron> #undo
19:48:14 <rbergeron> #action gregdek to contact roland re: planetansible
19:49:55 <gregdek> #topic explicit label for greg/robyn tasks
19:50:04 <gregdek> https://github.com/ansible/community/issues/22
19:50:25 <gregdek> Not sure why we wouldn't just assign it to one of us if we know up front that it belongs to one of us.
19:50:53 <gregdek> i.e. if it's in that class -- i.e. the kind of thing only Robyn or Greg *could* do -- then we'd know that up front and assign it.
19:51:09 <gregdek> And yes, that might mean Robyn and Greg reassigning things back and forth and that's fine. :)
19:51:50 <gregdek> Which implies that if it's a task we think anyone can do, we leave it unassigned.
19:52:08 <gregdek> (And then we are free to pick it up ourselves once we move it into in_progress).
19:52:34 <rbergeron> #action gregdek to close #22
19:53:06 <gregdek> #topic Testing Working Group
19:53:17 <rbergeron> So: thinking about this
19:53:23 <gregdek> https://github.com/ansible/community/issues/9
19:53:38 <rbergeron> and how a group would normally come into existence outside of you or me just saying it magically exists
19:53:54 <rbergeron> ..since I was thinking about this while writing up a draft readme.md for the community repo
19:54:07 <rbergeron> the topic of "how do i start a new group if i want to?" sort of came up.
19:54:26 <rbergeron> And I was thinking that basically: Open up an issue in this repo
19:54:44 <rbergeron> "Start a testing working group"
19:54:49 <rbergeron> (which we already conveniently have)
19:55:18 <rbergeron> and basically say: "if you are interested, put your github ID in this issue and say, I'm interested"
19:56:09 <rbergeron> And when there are ... 2? 3? Whatever, people, then that group will become a thing.
19:56:14 <rbergeron> So the process would basically be:
19:56:30 <rbergeron> Mail to ansible-devel saying, "I'm looking for other people who want to join me on my quest to do X! Add your name here"
19:56:41 <rbergeron> when enough people sign up, then the following things happen:
19:56:58 <rbergeron> (what should those things be?)
19:57:09 <rbergeron> * Schedule your first irc meeting
19:57:34 <rbergeron> * Mail ansible-devel to let people know there is a meeting
19:57:47 <rbergeron> * ????
19:57:50 <rbergeron> Who knows. but basically:
19:57:58 <rbergeron> Create a testing working group!
19:58:10 <gregdek> Interesting.
19:58:11 <rbergeron> Then figure out what you should do next. And maybe once we'er done making the group we should know how people can do it in the future.
19:58:20 <rbergeron> Do they need a repo? No idea.
19:58:31 <gregdek> Well, we know who the principles are.
19:58:31 <rbergeron> Should they be posting to ansible-devel with [special tag], or not? who knows.
19:58:58 <gregdek> So I think this also doubles as "working group management process" or some such.
19:59:14 <gregdek> Make the testing working group the first example of Any Working Group.
19:59:20 <rbergeron> The community team is basically a working group also.
19:59:22 <rbergeron> lol
19:59:26 <gregdek> Yeah, kinda true.
19:59:35 <rbergeron> Just the ones who would handle making a working group happen in some way, i expect.
19:59:38 <gregdek> Should we call ourselves that?
20:00:01 <gregdek> So that means "community working group" is wg#1 and "testing working group" is wg#2
20:00:10 <rbergeron> sure!
20:00:57 <gregdek> ok.
20:01:02 <gregdek> So that implies:
20:01:18 <gregdek> #action robyn will rebrand community team as community working group
20:02:00 <gregdek> #action gregdek will solicit members to the new testing working group by driving people to the appropriate github issue
20:02:14 <gregdek> (going to add/modify those tickets now)
20:04:22 <rbergeron> (gregdek types into #9 while we sit silently waiting)
20:06:05 <gregdek> OK, that's good for today. First Community Working Group meeting done!
20:06:26 <gregdek> #endmeeting