ansible_lockdown_working_group
LOGS
16:03:22 <defionscode> #startmeeting ansible lockdown working group
16:03:22 <zodbot> Meeting started Thu May  2 16:03:22 2019 UTC.
16:03:22 <zodbot> This meeting is logged and archived in a public location.
16:03:22 <zodbot> The chair is defionscode. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:22 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:03:22 <zodbot> The meeting name has been set to 'ansible_lockdown_working_group'
16:04:10 <defionscode> alright so I have no super specific thing to discuss
16:04:30 <defionscode> so the floor is open to anyone
16:04:31 <cyberpear> There was a ticket suggesting that we declare 1.0 on RHEL7 if we remediate a default install to 100%
16:05:06 <cyberpear> there is a gap in what we check/enforce vs what is already compliant in the default configuration
16:05:26 <cyberpear> i.e., some thnigs are compliant that we don't check
16:06:19 <defionscode> which issue? I'm looking now...
16:06:55 <cyberpear> comment on #174
16:07:16 <cyberpear> I'm indifferent but it would allow us to declare 1.0 sooner...
16:08:32 <cyberpear> ok, the exact words were 'ready for release'
16:08:45 <defionscode> yeah I didn't think it meant 100%
16:10:31 <cyberpear> looking at #44, there's 7 general items I think should be addressed + 11 GUI items
16:10:46 <cyberpear> plus 3 complex items that we can't fix, but could detect a non-compliant configuration
16:11:22 <cyberpear> (but I guess this is likely a re-hash of existing info... likely mostly useful for linking #174 to these meeting minutes)
16:12:00 <defionscode> hm yeah
16:12:09 <defionscode> ok that's not a terrible amount of work left to do
16:12:21 <defionscode> I'm ok with leaving UI items for a minor release
16:12:33 <defionscode> since I'd gamble _most_ usage is in a server/headless env
16:13:12 <defionscode> what do you think about cutting 1.0 after those 7 items, then leave the UI items for 1.1.0
16:13:34 <cyberpear> sounds good to me
16:14:09 <cyberpear> ...otherwise, I don't have anything further today, unless you have comments on the open PRs
16:14:30 <defionscode> #agreed release/tag version 1.0.0 after outstanding non-UI items are addressed from #44, release/tag version 1.1.0 after UI items are hit
16:16:09 <defionscode> ok all PRs are now merged
16:16:21 <defionscode> last thing @shepdelacreme suggested moving approving reviews required to 1
16:16:26 <defionscode> I think I'm ok with that too
16:16:30 <cyberpear> +1 from me
16:16:30 <defionscode> sounded like you were too cyberpear_ ?
16:16:33 <defionscode> cool
16:16:37 <cyberpear> (thx for the merges!)
16:16:38 <defionscode> changing that now
16:16:57 <defionscode> #agreed approve PRs with 1 approval from maintainer vs 2
16:17:40 <defionscode> done on RHEL7 repo
16:18:00 <defionscode> all maintainers have admin on repos, those can be updated as needed
16:18:19 <cyberpear> sounds good
16:18:27 <defionscode> anything else from anyone?
16:18:46 <defionscode> otherwise I'll leave the meeting open until 30-past to make sure we dont miss any stragglers then I'll wrap up
16:19:09 <cyberpear> +1
16:32:20 <defionscode> alright
16:32:28 <defionscode> that's a wrap!
16:32:31 <defionscode> #endmeeting