documentation_working_group_aka_dawgs
LOGS
16:01:26 <samccann> #startmeeting Documentation Working Group aka DaWGs
16:01:26 <zodbot> Meeting started Tue Jan 10 16:01:26 2023 UTC.
16:01:26 <zodbot> This meeting is logged and archived in a public location.
16:01:26 <zodbot> The chair is samccann. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
16:01:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:26 <zodbot> The meeting name has been set to 'documentation_working_group_aka_dawgs'
16:01:43 <samccann> @room Meeting time! Who is here to talk the docs?
16:01:52 <briantist> o/
16:02:02 <thedoubl3j> o/
16:02:14 <acozine> o/
16:02:34 <samccann> hmm not sure if we're goiong to have the meeting bot here today or not?
16:02:54 <samccann> #chair thedoubl3j acozine
16:02:54 <zodbot> Current chairs: acozine samccann thedoubl3j
16:02:59 <samccann> and we hope it catches up??
16:03:20 <acozine> seems like it's asleep at the wheel
16:03:43 <samccann> yeah. not sure why we keep losing that functionality, but it's ...annoying
16:03:58 <samccann> and doesn't seem to happen on other channels
16:04:25 <samccann> oh there it goes!
16:04:30 <samccann> #chair briantist
16:04:30 <zodbot> Current chairs: acozine briantist samccann thedoubl3j
16:04:32 <samccann> phew.
16:04:44 <thedoubl3j> it was just finishing up its other meeting
16:04:46 <thedoubl3j> ;0
16:04:50 <samccann> heh
16:04:58 <samccann> Raise your ascii hand (o/) to say hi or any other way you want to let us know you are here. And Welcome to any new folks!
16:05:31 <samccann> To any newcomers - again, welcome. We chair all attendees as a way of recognizing your time spent here. And it opens it up for people to add to the meeting minutes with commands like #info or #link (to add a link)
16:05:42 <samccann> General run of the meeting - We go over action items, give docs updates.. maybe have a topic or two, and go over doctooling updates (all the fun stuff behind the scenes that get us docs.ansible.com!)
16:05:52 <samccann> Official agenda is https://github.com/ansible/community/issues/678#issuecomment-1369999279
16:06:14 <samccann> #topic Action Item updates:
16:06:24 <samccann> #info open - oraNod - to look into getting community maintainer(s) for the sphinx ansible theme
16:06:39 <samccann> #info open samccann to finalize personas for community review
16:07:19 <samccann> #info open Write up what the different types of callback mean. aka notification was supposed to be for callbacks that 'notify other systems/apps/apis' while aggregate are those that add info to sdtout one
16:07:31 <samccann> I feel like there's a PR for ^^ somewhere but maybe I dreamt it?
16:07:36 * samccann needs to stop dreaming of PRs
16:07:54 <oranod> o/
16:08:23 <oranod> hey samccann sorry I'm late had personal stuff to deal with there
16:08:26 <samccann> #chair Don Naro
16:08:26 <zodbot> Current chairs: Don Naro acozine briantist samccann thedoubl3j
16:08:30 <acozine> https://github.com/ansible/ansible/pulls?q=is%3Aopen+is%3Apr+label%3Adocs+callback+in%3Atitle - looks lik there are three PRs?
16:08:33 <samccann> no worries
16:08:33 <oranod> hi all
16:08:36 <acozine> s/lik/like
16:08:50 <acozine> oh, wait, those are backports
16:08:54 <samccann> oh excellent thanks!!
16:09:01 <samccann> so yeah the original must be somewhere as well
16:09:04 <acozine> not sure they're what you were looking for
16:09:21 <samccann> #undo
16:09:21 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x7f1633d7c780>
16:09:46 <acozine> here's the original of those backports: https://github.com/ansible/ansible/pull/79651
16:09:53 <samccann> #info closed Write up what the different types of callback mean. aka notification was supposed to be for callbacks that 'notify other systems/apps/apis' while aggregate are those that add info to sdtout one
16:10:08 <samccann> yep those are the fixes that related to this action item. Thanks for the sleuth work!
16:11:10 <samccann> #info open samccann dnaro - to figure out a discussion or two for Contrib summit on personas and docsite revamp
16:11:23 <samccann> mostly I repeat the open action items each week or I'll forget them.
16:11:45 <samccann> Don Naro brought up the last time that I really need to turn them into issues 'somewheres' instead of this, but...I haven't yet
16:12:27 <oranod> #info for the sphinx ansible theme I plan to send a shout on the bullhorn to call for community contributors. I thought I'd wait until this week.
16:12:37 <oranod> I guess I'm catching up with the agenda a little
16:12:40 <samccann> oh cool thanks!
16:12:57 <samccann> I think once you do that, we can close the action item.
16:13:05 <oranod> sounds good
16:13:20 <felixfontein> o/
16:13:25 <felixfontein> sorry, got side-tracked...
16:13:27 <samccann> #chair felixfontein
16:13:27 <zodbot> Current chairs: Don Naro acozine briantist felixfontein samccann thedoubl3j
16:13:30 <samccann> welcome welcome
16:13:31 <samccann> #info open ansible/ansible docs issue to add links to the new collection envvar index page after the next antsibull-docs release
16:15:06 <felixfontein> samccann: there's a PR for that :)
16:15:13 <Dule_Martins0383> I have been reading and catching up
16:15:21 <samccann> #undo
16:15:21 <zodbot> Removing item from minutes: INFO by samccann at 16:13:31 : open ansible/ansible docs issue to add links to the new collection envvar index page after the next antsibull-docs release
16:15:27 <samccann> #info closed ansible/ansible docs issue to add links to the new collection envvar index page after the next antsibull-docs release
16:15:34 <samccann> woot!  Thanks felixfontein
16:15:47 <felixfontein> https://github.com/ansible/ansible/pull/79666
16:15:50 <samccann> #chair Dule_Martins#0383
16:15:50 <zodbot> Current chairs: Don Dule_Martins#0383 Naro acozine briantist felixfontein samccann thedoubl3j
16:15:53 <samccann> welcome welcome!
16:16:31 <Dule_Martins0383> Hey, samcann (@_discord_930864645756035143:ansible.im) can we talk about the writer community
16:16:41 <samccann> sure thing!
16:16:47 <samccann> #topic community-writers
16:17:09 <samccann> for other folks - Dule_Martins#0383 is one of the leaders of the community-writers group - folks willing to help out on docs in ansible land
16:17:20 <Dule_Martins0383> Cause I have been thinking about them and what this years holds for the community
16:17:31 <samccann> cool. Love to hear your thoughts
16:18:27 <Dule_Martins0383> Working a plan and activities that involve us to use the voice channel here on discord to drive engagement and keep the community activated for others
16:19:12 <Dule_Martins0383> Would love if job posting could be share in the #job-posting  channel too to drive engagement
16:19:22 <acozine> that sounds awesome Dule_Martins#0383
16:19:50 <samccann> oh that is a fabulous idea
16:20:04 <samccann> #action samcann to search for writer reqs at Red Had and post links on discord
16:20:07 <Dule_Martins0383> We are looking at increase member and contribution to ansible docs but I think people like appreciate and it has it's way of encouraging and inspiring people to do more
16:20:20 <samccann> yep for sure
16:20:32 <Dule_Martins0383> Hey, acozine. Thanks for the acknowledgment
16:22:14 <Dule_Martins0383> What if the contributor with the highest PR been merged as get a post of appreciate on twitter using the official ansible twitter handle and also on linkedin
16:22:46 <Dule_Martins0383> This could create something for them
16:23:10 <Dule_Martins0383> like a booster or what word could I used? hmmmmmmmmm
16:23:21 <Dule_Martins0383> Hope this was clear enough ?
16:23:22 <samccann> #info for community-writers engagement - consider positng contrats on twitter/linked in to the contributor with the highest merged PR count
16:23:41 <anwesha[m]> Dule_Martins#0383:  wonderful idea
16:25:01 <anwesha[m]> This is so essential that we recognize and appreciate the members of our community on a regular day basis :)
16:25:59 <Dule_Martins0383> Yap?
16:26:24 <acozine> so a quarterly shout-out for the person with the most PRs merged?
16:26:27 <acozine> that could be fun
16:27:02 <samccann> Yep. anwesha does this sound like something we could also share on the BullHorn newsletter?
16:27:47 <Dule_Martins0383> I just have this idea!
16:27:47 <Dule_Martins0383> Imaging using the Youtube channel for Ansible to interview the contributor with the most PRs merged.
16:28:16 <samccann> hmm not sure who runs the youtube channel but someone must know
16:29:05 <acozine> the marketing team? Kaete, maybe?
16:29:15 <Dule_Martins0383> What this will mean is that we are creating content for the youtube channel and twitter. drive traction to this pages and increasing the chances of the unemployed contributors to be spotted by prospective recruiters
16:29:39 <Dule_Martins0383> I think Ansible wins and community writers wins as well.
16:29:47 <samccann> yep I agree
16:30:02 <Dule_Martins0383> With these in place we can archive what I talk about during the Ansible Contributors Summit.
16:30:16 <samccann> and that's been the goal here - to give these volunteers some visible credit etc so they can use it to help job search and grow their experience etc
16:30:17 <Dule_Martins0383> Swag too
16:30:53 <Dule_Martins0383> Ya!
16:31:39 <samccann> #info in general, find ways to extend the visibility of these community-writers as a way to help further their careers for the work they are doing in Ansibleland
16:31:51 <Dule_Martins0383> I will the docs once am done. It contain info about the community and plans of activities for the year
16:32:02 <Dule_Martins0383> then samcann (@_discord_930864645756035143:ansible.im) can do a review
16:32:19 <samccann> cool that sounds great
16:32:39 <anwesha[m]> <samccann> "Yep. anwesha does this sound..." <- Yes,  absolutely we should. Let us make a plan before we publish it in Bullhorn.
16:32:39 <thedoubl3j> on the youtube comment, depending on which youtube channel you want to publish to changes who owns. this one is run by marketing https://www.youtube.com/@AnsibleAutomation
16:33:06 <thedoubl3j> I will also go ahead and slow down hope of anything getting anything there either. it is under tight lock and key
16:33:19 <thedoubl3j> but the community one I am pretty sure carol has the keys to
16:33:32 <samccann> heh thanks for the reality check thedoubl3j ... good to know
16:33:32 <thedoubl3j> because we push the contrib summit stuff there correct?
16:33:42 <thedoubl3j> no worries, just had to do it with the awx team as well
16:33:57 <samccann> yeah was thinking if we didn't already have a community youtube channel, it may be something in the planning
16:34:12 <thedoubl3j> https://www.youtube.com/@AnsibleCommunity
16:34:13 <anwesha[m]> samccann: This is so essential to have new contributors on board.
16:34:37 <thedoubl3j> this might pair well with what the awx team is moving with as well. might be good to make it an ansible wide thing
16:35:05 <Dule_Martins0383> This is great thedoubl3j!
16:35:05 <Dule_Martins0383> I think this is too tight and restricted for Ansible as a product. Content for contributors not such if will be welcome here.
16:35:56 <thedoubl3j> community recognition etc, their is a big push for that there with new contributors/engineers
16:36:14 <Dule_Martins0383> The goal of the YouTube thing is to attract Open Source Contributors and promotion the adoption of contributing to Open Source among developers and designers and writers.
16:36:16 <samccann> ok cool
16:36:28 <Dule_Martins0383> ok cool
16:37:35 <thedoubl3j> the goal is to attract folks to contribute etc in whatever way they feel best at so whatever we can do to help that I think is a good move
16:37:46 <samccann> yep
16:37:56 <thedoubl3j> doubling up here so I will shut up now lol
16:38:06 <samccann> AAHAHA well it IS in your name :-)
16:38:21 <samccann> anything else on community-writers before we move on?
16:38:46 <Dule_Martins0383> Nothing, captain
16:38:58 <Dule_Martins0383> * Nothing
16:39:13 <samccann> hah and here I was lookin for a captain emoji!
16:39:16 <Dule_Martins0383> if any I will let you know
16:39:23 <Dule_Martins0383> lol
16:39:38 <samccann> thanks and do bring up community-writers ideas here whenever you have them!
16:40:43 <Dule_Martins0383> If only I could see it first 👮🏻‍♀️
16:41:28 <samccann> ok gonna open the floor next
16:41:32 <samccann> #topic Open Floor
16:41:39 <samccann> Anyone have a topic to bring up on docs?
16:43:05 <samccann> ok I have one if no one else does :-)
16:43:37 <samccann> We're working on developing personas for community Ansible. You can see a rough draft at  https://hackmd.io/KJInEFJmRfWsFGBGxEzviw?view
16:44:02 <samccann> But the TL;DR; - we are debating a small set of personas - user, developer, contributor
16:44:18 <felixfontein> I wanted to ask if there are some final remarks on https://github.com/ansible-community/antsibull-docs/pull/90 before I merge it
16:44:34 <felixfontein> so far nobody commented on the wordings, so I'm not sure whether someone actually looked :)
16:44:40 <oranod> felixfontein: I was looking at that and it seemed fine to me
16:44:52 <samccann> but of course there's a lot of overlap. Anyone can be a contributor.... and are developers really seprate from contributors etc.  Just curious what your thoughts are
16:44:57 <acozine> samccann: I think starting with a small set of personas is a good idea, we can iterate from there
16:45:30 <acozine> the goal of personas is to make it easier for people to find the specific documentation they need
16:46:11 <acozine> so that person who's a developer and a contributor is generally looking for docs relevant to one or the other at any given time
16:46:25 <oranod> felixfontein: I suppose adding an approval at least shows that someone has looked at it. I'd also really appreciate the opportunity to learn more about antsibull-docs and wanted to ask if maybe we could have a brief meeting some time?
16:46:27 <samccann> felixfontein: I found a grammar nit... I'll post after the meeting
16:46:48 <samccann> well, I think it's in the code.. but may be in the collection itself lol... time will tell
16:47:05 <samccann> "Additional aggregate or notification callbacks be enabled though"
16:47:24 <samccann> should be callbackes can be enabled though
16:48:08 <samccann> acozine: that was my thought as well. Would you consider yourself a user or developer? (we already know you are a contributor ;-)
16:49:06 <samccann> felixfontein: it is in the PR so I'll submitt suggested edits shortly
16:51:05 <acozine> heh, I'm not really doing any development these days, but if I needed or wanted to, persona-based docs would help me find what I needed
16:51:25 <samccann> what do you define as development work?
16:51:26 <felixfontein> samccann: thanks!
16:51:52 <felixfontein> oranod: I guess we can do that :) not sure when exactly, this week is pretty full, but hopefully next will be better
16:52:36 <acozine> Interesting question. I'd say for Ansible anything that involves writing Python is development work, but there are probably other things that "count" as development
16:52:36 <Dule_Martins0383> Sorry guys, I have to leave but will catch up. I'm limited by my internet service providers.
16:52:43 <samccann> thanks Dule_Martins#0383 !!
16:52:53 <acozine> bye Dule_Martins#0383, thanks for coming!
16:52:53 <felixfontein> bye Dule_Martins0383!
16:54:24 <oranod> felixfontein: cool. thanks, I'll ping you next week. I've been trying to piece things together and would really appreciate any time you might have to help me understand.
16:54:32 <oranod> bye Dule_Martins#0383
16:55:03 <samccann> ok we have about 5 min left. Any other items to discuss today?
16:55:46 <oranod> #info the package docs publishing action topic at: https://github.com/ansible-community/community-topics/issues/174
16:56:12 <oranod> thought I might give a quick update on that one
16:56:47 <samccann> sure!
16:56:58 <oranod> #info I set CPUS=1 which helped the build get a bit farther. it does all the collections docs but still seems to be running out of steam.
16:57:50 <oranod> #info plan now is to investigate a self-hosted runner. I looked at a jenkins webhook earlier today, which is ok but kind of a half-baked solution for the community imo.
16:58:17 <oranod> I'll update again but that's the direction I'm going if anyone has any thoughts
16:58:43 <briantist> oranod: I have not used this yet, but have kept it open in a browser tab: https://cirun.io/
16:58:43 <oranod> thanks
16:59:05 <briantist> it makes it easier to set up pools of self-hosted GHA runners in your own cloud accounts
16:59:23 <oranod> that looks great. thanks briantist
16:59:28 <acozine> yeah, hooking into a process the community cannot see (Jenkins) would maintain the old unsatisfactory state
16:59:31 <briantist> it may be overkill/not needed if you just need to set up a couple of static runners, but it's really nice if you want ephemeral instances
16:59:34 <samccann> does a jenkins webhook mean all the scripting etc happens in the open community, but it triggers 'something' there that calls an internal to RH jenkins job?
17:00:03 <acozine> samccann: that's how I interpreted it
17:00:26 <oranod> samccann: yeah, that's pretty much it in a nutshell
17:01:07 <samccann> acozine: the newer jenkins jobs here have all their script code out in github. Alas, a private github, but that could change.  I think if  the Github actions could be triggered by a community member, it might not be 'so bad' if the thing actually running the script is internal jenkins.  But only if those webhooks actually allow the jenkins results to be fed back into the open so to speak.
17:01:52 <acozine> yeah, it would be great if everyone could see the outcome
17:02:15 <samccann> coolness
17:02:28 <samccann> we're a couple of minutes over... anything else to add here before we end the meeting?
17:04:10 <samccann> ok cool
17:04:13 <samccann> #endmeeting