documentation_working_group_aka_dawgs
MINUTES

#ansible-docs: Documentation Working Group aka DaWGs

Meeting started by samccann at 15:00:57 UTC (full logs).

Meeting summary

  1. opening chatter (samccann, 15:01:06)
  2. Documentation Updates (samccann, 15:04:01)
    1. https://github.com/ansible-collections/community.windows/issues/394 and https://github.com/ansible/community/issues/643#issuecomment-1180358267 (samccann, 15:05:16)
    2. AGREED: do not move the windows developer guide to a collection. It's more generic and belongs where it is (samccann, 15:07:19)
    3. - if you need an editor to review docs PRs or do light editing (edit on github) we have a team of community writers willing to help. See https://github.com/orgs/ansible-community/projects/3/views/1?sortedBy%5Bdirection%5D=asc&sortedBy%5BcolumnId%5D=Status and ping us here if you need access to add your PRs/easyfix issues to that board. (samccann, 15:08:46)

  3. doctools (samccann, 15:10:24)
    1. - redirects based on referrers to redirect old EOL docs to latest seem to work - https://hackmd.io/0B7n-FUySF6MB3CQeaqUkA?view (samccann, 15:10:44)
    2. this may solve our problems with external search results picking up very old EOL docs within the top few results (samccann, 15:11:16)
    3. Looking for ideas on how to get CI testing to work on rst pages excluded from ansible-core (what ansible/ansible CI covers today) - Please comment on https://github.com/ansible-community/community-topics/issues/111 (samccann, 15:16:51)
    4. https://github.com/ansible/ansible/pull/36901/files#diff-b084faabfc6d6ec38de3459882739152a10e5173d5754e50db49ee423afa38eaR110 (samccann, 15:22:43)
    5. for the docs boolean 'override' - it's not an override - there is no 'default' that the cooder meant. There's only the boolean indication in the code and docs has to decide whether it says true, True, or yes. (samccann, 15:30:04)
    6. must wait for resolution to https://github.com/ansible-community/community-topics/issues/116 before we make any changes. (samccann, 15:30:17)

  4. Open Floor (samccann, 15:32:28)
    1. YAML 1.2 requires true/false but ansible is still on 1.1 and pyyaml hasn't implemented YAML 1.2 for the past 4 yrs or so (samccann, 15:47:45)


Meeting ended at 16:11:13 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. samccann (76)
  2. bcoca (34)
  3. felixfontein (33)
  4. briantist (11)
  5. zodbot (8)
  6. DonNaro[m] (2)
  7. Don (0)
  8. Naro (0)
  9. welcome (0)
  10. welcome! (0)


Generated by MeetBot 0.4.