documentation_working_group_aka_dawgs
LOGS
15:00:54 <samccann> #startmeeting Documentation Working Group aka DaWGs
15:00:54 <zodbot> Meeting started Tue Apr 19 15:00:54 2022 UTC.
15:00:54 <zodbot> This meeting is logged and archived in a public location.
15:00:54 <zodbot> The chair is samccann. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
15:00:54 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:54 <zodbot> The meeting name has been set to 'documentation_working_group_aka_dawgs'
15:01:18 <samccann> #topic opening chatter
15:01:18 <samccann> @room Meeting time! Who is here to talk the docs?
15:01:25 <samccann> Raise your ascii hand (o/) to say hi or any other way you want to let us know you are here. And Welcome to any new folks!
15:01:47 <samccann> briantist: andersson007_ you folks around to talk docs today?
15:01:50 <acozine> o/
15:01:57 <samccann> #chair acozine
15:01:57 <zodbot> Current chairs: acozine samccann
15:02:11 <acozine> good morning!
15:02:11 <samccann> phew... won't be talkin to myself at least ;-)
15:02:23 <acozine> heh
15:03:02 <samccann> Official agenda is at https://github.com/ansible/community/issues/643#issuecomment-1089088434
15:03:54 <samccann> #topid documentation updates
15:03:57 <samccann> heh
15:04:00 <acozine> heh
15:04:02 <samccann> #topic Documentation Updates
15:04:07 <acozine> topid is a good word
15:04:07 <samccann> is is a riter
15:04:13 <acozine> part topic, part PID
15:04:19 <samccann> there ya go
15:04:28 <samccann> #info - very rough draft of distro installs - https://github.com/ansible/ansible/pull/77567
15:05:04 <samccann> really need dmsimard to take a look at that one as whatever we write for details is something he and other community folk need to support so to speak
15:05:34 <samccann> as in keep the docs updated. He's out today but any comments welcome on the PR for sure
15:05:36 <acozine> that page definitely needs a local TOC
15:05:58 <acozine> it's short(ish) now, but it will grow for sure
15:06:55 <samccann> well my hope frankly, is that it won't grow
15:07:23 <samccann> If it's not a package that dmsimard or someone on the internal community team is supporting, or someone here in community steps up to support, I don't think we add docs for it
15:07:32 <acozine> ah, gotcha
15:07:41 <acozine> well, a local TOC is still a nice feature
15:07:44 <samccann> because when it stops working, peeps come to us
15:07:50 <samccann> oh yeah added that locally already thanks!
15:08:15 * samccann shakes fist at crashing vscode
15:08:48 <samccann> My next item was about the wheels, but that might need others in the know as well to answer
15:09:09 <samccann> I think our 'default' pip install will be wheels.  I'm unsure if we need to mention this in the docs or if users won't really care
15:09:35 <samccann> and/or if we need to mention `pip download` is the way to get everything again that was taken out with wheels etc
15:09:43 <briantist> o/
15:09:51 <samccann> hey hey!
15:09:56 <samccann> #chair briantist
15:09:56 <zodbot> Current chairs: acozine briantist samccann
15:09:58 <samccann> welcome!
15:10:03 <briantist> thx
15:10:08 <acozine> hey briantist
15:10:15 <briantist> 👋
15:10:36 <samccann> and here I was thinking the Easter Bunny had kidnapped everyone! 🐰
15:11:30 <samccann> I'm going to plug this next one one last time then close out the issue
15:11:38 <samccann> #info proposed Docs priorities for the coming 18 months or so - https://github.com/ansible-community/community-topics/issues/81
15:11:48 <samccann> I think we've mentioned it enough here.
15:12:30 <briantist> it lgtm, why close out the issue?
15:12:58 <samccann> well it feels odd to just leave it there for the next two years.
15:13:14 <briantist> are you looking for any specific feedback on it?
15:13:34 <samccann> mostly just if you see something you think we should be focused on that isn't listed there.
15:13:56 <samccann> and it's roughly in priority - so like if the last  thing listed really should happen sooner etc
15:14:26 <gwmngilfen-work> i agree with samccann - as a feedback space, it should be closed once you have the feedback. However, I think a "living doc" of the current roadmap/priorities might be worth having?
15:14:49 <samccann> I could add the info to the docs github project
15:15:19 <gwmngilfen-work> might be worth it, then you could PR potential changes and ask for feedback as you go (where suitable)?
15:15:28 <briantist> right, I guess I was thinking it made sense for it to be a living-doc sort of thing if those items are still priorities/being worked on, but maybe that is better off living somewhere else
15:15:52 <gwmngilfen-work> 100% but that doesn't belong in an old issue, it should be more central
15:16:07 <gwmngilfen-work> also hi, I guess 😛
15:16:13 <samccann> heh
15:16:44 <acozine> I suppose you could open individual tickets for the various tasks, and link back to this closed ticket - a sort of "here's a high-priority epic; priorities were set/agreed upon in this old, closed ticket here" thing.
15:16:59 <acozine> hey Gwmngilfen
15:17:11 <samccann> #chair Gwmngilfen
15:17:12 <zodbot> Current chairs: Gwmngilfen acozine briantist samccann
15:18:36 <samccann> #action samccann to find a way to incorporate the docs priority list into the docs github project board for tracking
15:19:01 <samccann> #info always looking for help on the backlog - issues - https://github.com/ansible/ansible/issues?q=is%3Aopen+is%3Aissue+label%3Adocs and PRs - https://github.com/ansible/ansible/pulls?q=is%3Aopen+is%3Apr+label%3Adocs
15:19:26 <samccann> I don' have much else specific to docs vs docs tooling.  anyone else have anything to bring up about words on paper before we move on?
15:19:42 <briantist> nope
15:20:01 <samccann> #topic doctools
15:20:12 <samccann> #info splitting up the antsibull package - https://github.com/ansible-community/antsibull/issues/410
15:20:23 <samccann> I don't think felixfontein is around at the moment to talk about that one
15:21:00 <samccann> TL;DR; splitting the package so changes to the `antsibull-doc` code doesn't trigger an update to collection test containers etc is one biggie in this change
15:21:22 <samccann> there's probably more, but that's the one that sticks in my mind.
15:23:01 <samccann> #info considering removing `known_good_reqs.txt` and using the code-smell requirements file instead - https://github.com/ansible/ansible/blob/devel/test/sanity/code-smell/docs-build.requirements.txt
15:23:19 <samccann> ^^ that would save us from having to keep both in sync.  I'm not sure of there are reprocussions I'm not thinking about
15:23:37 <samccann> except maybe if core changes it and it breaks the build ;-)
15:23:40 <samccann> (docs build)
15:25:40 <samccann> my brain must still be on Easter break.  I don't have much else besides all that today
15:26:31 <acozine> do we have docs for how to use the codesmell approach?
15:26:36 <acozine> from a user perspective?
15:26:36 <briantist> I don't have much either.. been too busy with other things so I'm a little sparse on Ansible work, especially docs-build, even though I really want to make some progress there
15:27:11 <acozine> it looks like basically the same thing, just a different file name?
15:27:35 <samccann> acozine: yes. Basically today we have two files doing mostly the same thing and struggle to keep them in sync
15:27:41 <samccann> (and fail.. .regularly)
15:28:06 <acozine> I'm half here and half trying to track down a mysterious process that is generating ~5 million DNS errors per day
15:28:12 <samccann> We could update any docs we have that mention known-good and replace with a link to the codesmell file instead
15:28:19 <samccann> thats... a lot of DNS errors
15:28:35 <acozine> yeah, our central IT folks are not super happy with the library at the moment
15:28:46 <samccann> heh woopsie
15:28:49 <samccann> Ok time for...
15:28:54 <samccann> #topic Open Floor
15:29:05 <samccann> Anyone have anything they want to discuss docs-related? here's your chance!
15:30:10 <samccann> ok looks like y'all get 30 min of your time back today
15:30:19 <samccann> Thanks everyone!
15:30:32 <samccann> #endmeeting