documentation_working_group_aka_dawgs
MINUTES

#ansible-docs: Documentation Working Group aka DaWGs

Meeting started by samccann at 15:01:49 UTC (full logs).

Meeting summary

  1. opening chatter (samccann, 15:02:01)
  2. Documentation Updates (samccann, 15:06:48)
  3. Troubleshooting collection CI problems (samccann, 15:07:12)
    1. our collection development docs may assume a deeper level of ansible experience than actual new collection owners have (samccann, 15:11:50)
    2. ACTION: put more troubleshooting breadrumbs in the developing/releasing collections to run common ansible-test sanity checks locally first. (samccann, 15:14:04)
    3. ACTION: samccann - verify if Zuul is available for automating any collection publishing to galaxy (samccann, 15:18:24)
    4. https://adhawkins.github.io/ansible-borgbase/collections/adhawkins/borgbase/index.html#plugins-in-adhawkins-borgbase (briantist, 15:19:00)
    5. ACTION: samccann make sure developing collection docs points to the template (samccann, 15:22:56)
    6. https://www.ansible.com/products/ansible-community-training has "Ansible Community - Creating your own Collection" (dmsimard, 15:22:57)
    7. ACTION: - link to the tutorials at https://www.ansible.com/products/ansible-community-training (samccann, 15:23:38)
    8. https://play.instruqt.com/redhat/tracks/ansible-community-creating-your-own-collection is the link directly to the lab (dmsimard, 15:25:13)
    9. tutorial on creating a collection https://play.instruqt.com/redhat/tracks/ansible-community-creating-your-own-collection (samccann, 15:25:59)

  4. Ansible docs project board (samccann, 15:26:07)
    1. - is anyone accessing/using the Docs github project board? is it useful? - https://github.com/ansible/ansible/projects/27? (samccann, 15:26:17)
    2. example of a project board using the new format -https://github.com/orgs/ansible-collections/projects/6/views/1 (samccann, 15:30:29)
    3. - general consensus is that a better project board is not a bad thing, but no one feels they would necessarily use it vs the existing DaWGs agenda/meeting minutes (samccann, 15:37:02)

  5. doctools (samccann, 15:37:31)
    1. splitting up the antsibull package - https://github.com/ansible-community/antsibull/issues/410 (samccann, 15:37:58)
    2. currently planning to split up antsibull in probably three parts: antsibull-core (some shared code), antsibull-docs (with the antsibull-docs CLI tool), and antsibull (with the antsibull-build and antsibull-lint CLI tools, the latter being deprecated) (samccann, 15:42:46)
    3. this would mean `antsibull-doc updates would no longer impact the the publicly visible changelog sanity test or the collections test container (samccann, 15:43:40)

  6. Open Floor (samccann, 15:49:35)


Meeting ended at 16:01:37 UTC (full logs).

Action items

  1. put more troubleshooting breadrumbs in the developing/releasing collections to run common ansible-test sanity checks locally first.
  2. samccann - verify if Zuul is available for automating any collection publishing to galaxy
  3. samccann make sure developing collection docs points to the template
  4. - link to the tutorials at https://www.ansible.com/products/ansible-community-training


Action items, by person

  1. samccann
    1. samccann - verify if Zuul is available for automating any collection publishing to galaxy
    2. samccann make sure developing collection docs points to the template
  2. UNASSIGNED
    1. put more troubleshooting breadrumbs in the developing/releasing collections to run common ansible-test sanity checks locally first.
    2. - link to the tutorials at https://www.ansible.com/products/ansible-community-training


People present (lines said)

  1. samccann (119)
  2. felixfontein (48)
  3. acozine (38)
  4. briantist (24)
  5. bcoca (11)
  6. zodbot (10)
  7. dmsimard (8)
  8. gwmngilfen-work (5)
  9. ariordan (2)


Generated by MeetBot 0.4.