documentation_working_group_aka_dawgs
MINUTES

#ansible-docs: Documentation Working Group aka DaWGs

Meeting started by samccann at 16:00:18 UTC (full logs).

Meeting summary

  1. opening chatter (samccann, 16:00:19)
    1. Agenda - https://github.com/ansible/community/issues/579#issuecomment-988107597 (samccann, 16:02:10)

  2. Documentation work (samccann, 16:03:04)
    1. we are frontloading the agenda now to highlight documentation work (vs the docs tooling that we've focused on a lot in the past) (samccann, 16:03:34)
    2. docs issues if anyone is looking to help https://github.com/ansible/ansible/issues?q=is%3Aopen+is%3Aissue+label%3Adocs (samccann, 16:05:40)
    3. and docs easyfix issues for that quick sense of accomplisment - https://github.com/ansible/ansible/issues?q=is%3Aopen+is%3Aissue+label%3Adocs+label%3Aeasyfix (samccann, 16:06:04)
    4. Do we need a list of new collections 'somewhere' in the porting guide? (samccann, 16:06:48)
    5. the full list of collections is in the changelog https://github.com/ansible-community/ansible-build-data/blob/main/5/CHANGELOG-v5.rst#id216 (samccann, 16:09:07)
    6. https://github.com/ansible-community/community-topics/issues/32 (acozine, 16:09:30)
    7. ACTION: samccann to open an antsibull issue to see if we can list just new collections at top of porting guide. If not, change wording for changelog link to say see it for full list of collections (samccann, 16:14:14)
    8. filter/test plugins docs WIP - https://github.com/ansible/ansible/pull/74963 (samccann, 16:15:29)
    9. split controller from 2.12 still needs docs. There is some starter info here - https://github.com/ansible-collections/overview/issues/45#issuecomment-923507542 that might help if anyone is up for starting this (samccann, 16:17:02)
    10. call for help - Please look at the docs PR backlog and comment/review/approve any you can - https://github.com/ansible/ansible/pulls?q=is%3Aopen+is%3Apr+label%3Adocs_only (samccann, 16:18:40)

  3. Docs-tooling (samccann, 16:20:34)
    1. PR to implement the extra links -https://github.com/ansible-community/antsibull/pull/355 and how they look now - https://ansible.fontein.de/collections/community/dns/ (samccann, 16:22:31)
    2. still iterating on removing html blobs from plugin docs. Latest PR -https://github.com/ansible-community/antsibull/pull/360 to allow us to turn this on/off for memory hogging problems (samccann, 16:24:36)
    3. https://github.com/ansible-community/antsibull/pull/355/files#diff-0b507052df25c0ce3272bb29884026abfc668b8d64c61184b539e78154c7a031R35-R37 seems to be the relevant bit, from a quick skim (gwmngilfen-work, 16:28:04)
    4. https://ansible.fontein.de/collections/community/dns/hetzner_dns_record_module.html#authors (samccann, 16:31:43)

  4. docs examples (samccann, 16:36:02)
    1. example repo is up for docs! -https://github.com/ansible-community/community-examples/issues/2 (samccann, 16:36:12)
    2. looking for a few good examples to seed it and get started (samccann, 16:36:24)

  5. semantic markup (samccann, 16:39:40)
    1. starting with a formal proposal - https://hackmd.io/VjN60QSoRSSeRfvGmOH1lQ (samccann, 16:39:52)
    2. looking for feedback on that so we can finalize (samccann, 16:40:00)
    3. https://github.com/ansible-collections/community.hashi_vault/issues/138 (briantist, 16:55:59)

  6. Open Floor (samccann, 16:57:32)
    1. https://github.com/ansible/ansible/issues/75652 (acozine, 17:00:39)
    2. ACTION: - samccann to try a reminder bot on US and APAC times with links to open issues and prs (but no room bot nag) (samccann, 17:04:03)
    3. ACTION: samccann to get easyfix docs issues into the newsbot (samccann, 17:04:31)


Meeting ended at 17:07:05 UTC (full logs).

Action items

  1. samccann to open an antsibull issue to see if we can list just new collections at top of porting guide. If not, change wording for changelog link to say see it for full list of collections
  2. - samccann to try a reminder bot on US and APAC times with links to open issues and prs (but no room bot nag)
  3. samccann to get easyfix docs issues into the newsbot


Action items, by person

  1. samccann
    1. samccann to open an antsibull issue to see if we can list just new collections at top of porting guide. If not, change wording for changelog link to say see it for full list of collections
    2. - samccann to try a reminder bot on US and APAC times with links to open issues and prs (but no room bot nag)
    3. samccann to get easyfix docs issues into the newsbot


People present (lines said)

  1. samccann (98)
  2. acozine (72)
  3. gwmngilfen-work (32)
  4. briantist (15)
  5. zodbot (8)
  6. remindbot[m] (3)
  7. Gwmngilfen (0)


Generated by MeetBot 0.4.