docs_working_group_aka_dawgs
MINUTES

#ansible-docs: Docs Working Group aka DaWGs

Meeting started by acozine at 15:00:45 UTC (full logs).

Meeting summary

  1. opening chatter (acozine, 15:00:50)
  2. acton item review (acozine, 15:10:20)
  3. redirects on the docsite (acozine, 15:18:28)
    1. ACTION: samcann to try sphinx redirects on test for docker and aws guide moves (samccann, 15:33:24)
    2. community.docker is in Ansible 4 and the version with the moved scenario guide is part of latest so a backport of the stub page is good. AWS collection hasn't released a version that includes the guide yet (samccann, 15:37:43)

  4. adding argspec modifiers to docstrings (acozine, 15:38:52)
    1. https://github.com/ansible/ansible/pull/74873 (acozine, 15:38:54)
    2. ACTION: samccann acozine - find better wording for built-in stub page generation for collections in antsibull (samccann, 15:39:11)
    3. ACTION: abadger1999 to look into whether required_if needs more information. (abadger1999, 15:40:54)
    4. https://github.com/ansible/ansible/pull/74873 (samccann, 15:44:19)
    5. and especially https://github.com/ansible/ansible/pull/74873#issuecomment-880850893 (samccann, 15:44:33)
    6. related work happened at https://github.com/xlab-steampunk/ansible-argspec-gen#writing-module-documentation (samccann, 15:44:48)
    7. The content team specifically needs this for suboptions rather than for the toplevel argument spec. But making it apply to the toplevel is one of the changes abadger199 requested. (samccann, 15:47:04)

  5. open floor (acozine, 15:48:03)
    1. ACTION: all - read the PR https://github.com/ansible/ansible/pull/74873 and associated info shared above for argspec modifiers for modules and be prepared for next week's DaWGs (samccann, 15:48:04)
    2. fedora generates ansible docs so users can read them offline (samccann, 15:51:53)
    3. Fedora needed to patch 2.9 so it could build successfully against sphinx>=4 in rawhide: https://src.fedoraproject.org/rpms/ansible/c/f2669e12902f2fa425bcc49cb0d6a7f6bce7cfce?branch=rawhide (samccann, 15:52:09)
    4. the new ansible theme we use on docs.ansible.com doesn't need this, but the lexer reamains in stable.2.9 and stable-2.10 (samccann, 15:52:57)
    5. optional fedora docs package for ansible - https://src.fedoraproject.org/rpms/ansible/blob/rawhide/f/ansible.spec#_129 (samccann, 15:53:25)
    6. this patch could solve the problem if implemented in 2.9 and 2.10 - https://github.com/ansible/ansible/pull/74798/files (wo the regex change probly) (samccann, 15:57:26)
    7. ACTION: - samccann to investigate if we hit this problem with 2.9 docs ourselves since 2.9 isn't using sphinx ansible theme? (samccann, 15:59:53)
    8. AGREED: if core approves, we implement the one line change so other distros can generate docs with Sphinx 4 (in stable-2.9 and stable-2.10) (samccann, 16:07:16)
    9. ACTION: dmsimard to create PR for 2.9 and 2.10 and test before merging (samccann, 16:07:36)


Meeting ended at 16:08:48 UTC (full logs).

Action items

  1. samcann to try sphinx redirects on test for docker and aws guide moves
  2. samccann acozine - find better wording for built-in stub page generation for collections in antsibull
  3. abadger1999 to look into whether required_if needs more information.
  4. all - read the PR https://github.com/ansible/ansible/pull/74873 and associated info shared above for argspec modifiers for modules and be prepared for next week's DaWGs
  5. - samccann to investigate if we hit this problem with 2.9 docs ourselves since 2.9 isn't using sphinx ansible theme?
  6. dmsimard to create PR for 2.9 and 2.10 and test before merging


Action items, by person

  1. abadger1999
    1. abadger1999 to look into whether required_if needs more information.
  2. acozine
    1. samccann acozine - find better wording for built-in stub page generation for collections in antsibull
  3. dmsimard
    1. dmsimard to create PR for 2.9 and 2.10 and test before merging
  4. samccann
    1. samccann acozine - find better wording for built-in stub page generation for collections in antsibull
    2. - samccann to investigate if we hit this problem with 2.9 docs ourselves since 2.9 isn't using sphinx ansible theme?
  5. UNASSIGNED
    1. samcann to try sphinx redirects on test for docker and aws guide moves
    2. all - read the PR https://github.com/ansible/ansible/pull/74873 and associated info shared above for argspec modifiers for modules and be prepared for next week's DaWGs


People present (lines said)

  1. acozine (103)
  2. samccann (63)
  3. abadger1999 (32)
  4. dmsimard (22)
  5. felixfontein (18)
  6. zodbot (15)
  7. tadeboro (11)
  8. lmodemal (8)
  9. dericcrago[m] (5)
  10. Xaroth (3)
  11. gwmngilfen-work (2)
  12. briantist (1)


Generated by MeetBot 0.1.4.