docs_working_group_aka_dawgs
MINUTES

#ansible-docs: Docs Working Group aka DaWGS

Meeting started by acozine at 15:01:18 UTC (full logs).

Meeting summary

  1. opening chatter (acozine, 15:01:23)
  2. follow up on action items (acozine, 15:07:17)
    1. no feedback yet on semantic markup from core and galaxy teams (samccann, 15:10:48)
    2. summary of semantic markup plan https://github.com/ansible/ansible/issues/75054 (acozine, 15:11:43)
    3. ACTION: acozine to keep requesting feedback on semantic markup plan, especially about the display of the new options in galaxy-ng and in ansible-doc output" (acozine, 15:15:32)

  3. devel docs update and build EOF/OOM issues (acozine, 15:25:25)
    1. the sphinx memory problem stems from building breadcrumbs. Workaround if necessary is to disable them again (samccann, 15:33:41)
    2. ACTION: samccann to test local VM with less memory, then with more memory and more collections to see how much each extra GB of ram gets us (samccann, 15:41:15)
    3. modify the ansible.in or ansible-VERSION.deps locally to add more collections from galaxy (samccann, 15:41:43)
    4. ACTION: abadger1999 to find a way to turn of breadcrumbs so we can get the builds working again, esp for today's release (samccann, 15:42:15)
    5. (ansible.in for devel docs. ansible-VERSION.deps for stable docs) (samccann, 15:42:49)
    6. ACTION: acozine to talk to gundalow/Spredzy once we know for sure that memory is our issue this time (samccann, 15:43:16)

  4. new module documentation fields (acozine, 15:48:56)
    1. new attributes PR - https://github.com/ansible/ansible/pull/73707 (samccann, 15:53:39)
    2. https://docs.ansible.com/ansible/devel/collections/ansible/builtin/import_playbook_module.html#ansible-collections-ansible-builtin-import-playbook-module (samccann, 15:56:27)
    3. this PR breaks the docs output since antsibull isn't recognizing these fields yet. But PR owner plans more changes, so need to decide if we wait for that or revert until it's complete (samccann, 16:02:38)
    4. PR also has no documentation for what it is supporting (samccann, 16:02:52)
    5. ACTION: acozine to follow up on the problems with PR 73707 (acozine, 16:17:25)
    6. ACTION: samccann abadger1999 acozine to followup on how we can havea better process in place to stop changes to ansible-doc etc until the full pipeline has agreed to support said changes (samccann, 16:17:31)

  5. open floor (acozine, 16:18:07)
    1. https://github.com/ansible/ansible/pull/74873 (abadger1999, 16:18:18)
    2. https://github.com/ansible/ansible/pull/74963/files (abadger1999, 16:18:26)
    3. PRs that need input from docs stakeholders: https://github.com/ansible/ansible/pull/74873, https://github.com/ansible/ansible/pull/74963, and possibly https://github.com/ansible/ansible/pull/75116 (acozine, 16:20:34)
    4. agenda items welcome, add a comment to https://github.com/ansible/community/issues/579 (acozine, 16:24:47)


Meeting ended at 16:24:54 UTC (full logs).

Action items

  1. acozine to keep requesting feedback on semantic markup plan, especially about the display of the new options in galaxy-ng and in ansible-doc output"
  2. samccann to test local VM with less memory, then with more memory and more collections to see how much each extra GB of ram gets us
  3. abadger1999 to find a way to turn of breadcrumbs so we can get the builds working again, esp for today's release
  4. acozine to talk to gundalow/Spredzy once we know for sure that memory is our issue this time
  5. acozine to follow up on the problems with PR 73707
  6. samccann abadger1999 acozine to followup on how we can havea better process in place to stop changes to ansible-doc etc until the full pipeline has agreed to support said changes


Action items, by person

  1. abadger1999
    1. abadger1999 to find a way to turn of breadcrumbs so we can get the builds working again, esp for today's release
    2. samccann abadger1999 acozine to followup on how we can havea better process in place to stop changes to ansible-doc etc until the full pipeline has agreed to support said changes
  2. acozine
    1. acozine to keep requesting feedback on semantic markup plan, especially about the display of the new options in galaxy-ng and in ansible-doc output"
    2. acozine to talk to gundalow/Spredzy once we know for sure that memory is our issue this time
    3. acozine to follow up on the problems with PR 73707
    4. samccann abadger1999 acozine to followup on how we can havea better process in place to stop changes to ansible-doc etc until the full pipeline has agreed to support said changes
  3. samccann
    1. samccann to test local VM with less memory, then with more memory and more collections to see how much each extra GB of ram gets us
    2. samccann abadger1999 acozine to followup on how we can havea better process in place to stop changes to ansible-doc etc until the full pipeline has agreed to support said changes


People present (lines said)

  1. acozine (137)
  2. samccann (70)
  3. abadger1999 (65)
  4. felixfontein (26)
  5. zodbot (11)
  6. briantist (7)
  7. lmodemal (3)
  8. zbr (1)
  9. Xaroth (1)


Generated by MeetBot 0.1.4.