ansible_documentation_working_group_aka_dawgs_meeting
MINUTES

#ansible-docs: Ansible documentation Working Group aka DawGs meeting

Meeting started by samccann at 15:01:56 UTC (full logs).

Meeting summary

  1. opening chatter (acozine, 15:08:54)
    1. Contributors Summit is next week https://hackmd.io/0lOyfyEpQ1uKimC4mD6xdw 07:00 - 15:00 UTC (gundalow, 15:10:27)

  2. Contributors' Summit (acozine, 15:11:39)
    1. https://whena.re/ansible-community is helpful to visualize timezones :) (dmsimard, 15:17:22)

  3. devel docs for hte package (acozine, 15:22:32)
    1. details on the ideas are at https://hackmd.io/E5a0dw0tTDCteQVVk4VvJw (samccann, 15:29:52)
    2. https://github.com/ansible-community/antsibull/issues/54 (acozine, 15:29:59)
    3. tracking issue for antsibull work needed - https://github.com/ansible-community/antsibull/issues/54 (samccann, 15:30:23)
    4. goal is to pull the most recent version on galaxy for each included collection to document `devel` for Ansible the package (samccann, 15:30:59)
    5. ACTION: abadger1999 to take some time this week if possible to delve further on this one (samccann, 15:31:32)

  4. template for using collection /docs/ folder (acozine, 15:32:12)
    1. https://docs.ansible.com/ansible/latest/dev_guide/developing_collections_structure.html#docs-directory (acozine, 15:38:15)
    2. the PR for this is merged - https://github.com/ansible-community/antsibull/pull/255 (samccann, 15:38:29)
    3. ACTION: document how to use the collection /docs folder (.md or .rst) at https://docs.ansible.com/ansible/latest/dev_guide/developing_collections_structure.html#docs-directory (samccann, 15:39:06)
    4. first candidates to exercise this may be community.docker, community.crypto and community.general (samccann, 15:40:24)
    5. https://github.com/ansible/ansible/pull/74736 (felixfontein, 15:42:13)
    6. remove docker docs pr is https://github.com/ansible/ansible/pull/74736 (samccann, 15:42:48)
    7. so as soon as we have a package release that includes the version of community.docker that has those docs, we can merge (samccann, 15:43:41)

  5. open floor (acozine, 15:50:54)
    1. filter docs PR for community.general requires a change to either antsibull or the ansible syntax highlighter (acozine, 16:04:53)
    2. https://github.com/ansible-collections/community.general/pull/2680/files (acozine, 16:05:11)
    3. An Ansible Beginner's Guide to Filters might be a good addition to the dev-focused filter docs (acozine, 16:06:37)


Meeting ended at 16:20:40 UTC (full logs).

Action items

  1. abadger1999 to take some time this week if possible to delve further on this one
  2. document how to use the collection /docs folder (.md or .rst) at https://docs.ansible.com/ansible/latest/dev_guide/developing_collections_structure.html#docs-directory


Action items, by person

  1. abadger1999
    1. abadger1999 to take some time this week if possible to delve further on this one


People present (lines said)

  1. acozine (129)
  2. samccann (47)
  3. felixfontein (31)
  4. gundalow (19)
  5. abadger1999 (14)
  6. zodbot (11)
  7. dmsimard (8)
  8. aminvakil (4)
  9. cyberpear (1)
  10. dericcrago (1)


Generated by MeetBot 0.1.4.