docs_working_group_aka_dawgs
MINUTES

#ansible-docs: Docs Working Group aka DaWGs

Meeting started by acozine at 15:00:50 UTC (full logs).

Meeting summary

  1. opening chatter (acozine, 15:00:55)
  2. copyright notices (gundalow, 15:08:51)
    1. https://github.com/ansible/ansible/pull/74643 (acozine, 15:09:17)
    2. updating copyright on docs.ansible.com to drop year/date and credit `Ansible project contributors` see https://github.com/ansible/ansible/pull/74643/files (acozine, 15:14:17)

  3. update on traffic to existing Scenario Guide TOCs (acozine, 15:15:14)
    1. https://docs.ansible.com/ansible/latest/scenario_guides/cloud_guides.html gets 1.2k visitors a month. That is 0.2% of all docs traffic (samccann, 15:16:45)
    2. and 6% of all scenario guide traffic (samccann, 15:17:05)
    3. https://docs.ansible.com/ansible/latest/scenario_guides/ (acozine, 15:22:30)
    4. AGREED: stub out individual scenario guides to point to their new locations as they are moved. Add the stubs to a robots.txt file on the server so google ignores them (samccann, 15:38:06)

  4. updates on long-running topics (acozine, 15:39:19)
    1. - breadcrumbs testing seems to be good. abadger to release and updated antsibull that re-enables it (samccann, 15:44:23)
    2. making some progress on testing the move of a scenario guide to a collection. All still WIP (samccann, 15:46:08)
    3. the moved guides will need a specific anchor like .. _ansible_collections.community.docker.docsite.scenario_guide: (samccann, 15:47:17)

  5. options for including rst documentation in the collection index pages (acozine, 15:48:54)
    1. https://github.com/felixfontein/community.docker/blob/scenario-guide/docs/docsite/index.yml produces https://ansible.fontein.de/collections/community/docker/ (samccann, 15:55:33)
    2. we are looking for a way to inject rst into the existing autogenerated collection index page. (samccann, 15:55:58)
    3. so the index.yml defines what those additional materials should be called on the existing index page, under that collection. (samccann, 15:56:26)
    4. AGREED: use felixfontein's existing PR for collections additional docs from the /docs/ folder, with one small change - name the top-level YAML file `extra-docs.yml` (acozine, 16:07:28)
    5. ACTION: acozine to update AWS collection PR to match (and fix its anchors) (acozine, 16:07:57)

  6. open floor (acozine, 16:08:29)
    1. https://github.com/ansible/ansible/pull/74245 (abadger1999, 16:09:10)
    2. https://github.com/ansible/ansible/pull/74245 breaks html docs for `set_fact` and `user`. We should consider reverting it (samccann, 16:14:50)
    3. https://github.com/ansible/ansible/issues/73995 relates to this problem (acozine, 16:16:43)
    4. example of broken link - https://docs.ansible.com/ansible/devel/collections/ansible/builtin/set_fact_module.html (samccann, 16:22:24)
    5. ACTION: acozine to summarize the problems with https://github.com/ansible/ansible/pull/74245 in a GitHub issue (acozine, 16:22:27)


Meeting ended at 16:25:44 UTC (full logs).

Action items

  1. acozine to update AWS collection PR to match (and fix its anchors)
  2. acozine to summarize the problems with https://github.com/ansible/ansible/pull/74245 in a GitHub issue


Action items, by person

  1. acozine
    1. acozine to update AWS collection PR to match (and fix its anchors)
    2. acozine to summarize the problems with https://github.com/ansible/ansible/pull/74245 in a GitHub issue


People present (lines said)

  1. acozine (140)
  2. samccann (79)
  3. felixfontein (45)
  4. abadger1999 (39)
  5. zodbot (14)
  6. gundalow (8)
  7. tremble (4)
  8. dericcrago (2)
  9. cyberpear (1)


Generated by MeetBot 0.1.4.