docs_working_group_aka_dawgs
LOGS
16:00:45 <acozine> #startmeeting Docs Working Group aka DaWGs
16:00:45 <zodbot> Meeting started Tue Feb 16 16:00:45 2021 UTC.
16:00:45 <zodbot> This meeting is logged and archived in a public location.
16:00:45 <zodbot> The chair is acozine. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:45 <zodbot> The meeting name has been set to 'docs_working_group_aka_dawgs'
16:00:51 <acozine> #topic opening chatter
16:00:54 <acozine> who's around?
16:01:06 <felixfontein> hi!
16:01:12 <acozine> hi felix!
16:01:15 <acozine> #chair felixfontein
16:01:15 <zodbot> Current chairs: acozine felixfontein
16:01:17 <lmodemal> Hey all!
16:01:24 <acozine> hi lmodemal!
16:01:27 <acozine> #chair lmodemal
16:01:27 <zodbot> Current chairs: acozine felixfontein lmodemal
16:02:42 <abadger1999> Morning
16:02:43 <samccann> o/
16:02:50 <felixfontein> #chair abadger1999 samccann
16:02:50 <zodbot> Current chairs: abadger1999 acozine felixfontein lmodemal samccann
16:03:13 <acozine> andersson007_: bcoca dericcrago dmsimard gundalow samccann alongchamps baptistemm briantist cyberpear jmn madonius mrproper sommersoft tremble you folks chatting docs today?
16:03:28 <dmsimard> hello
16:03:48 <alongchamps> I'll just be lurking, have some meetings
16:04:15 <acozine> alongchamps: okay, jump in if/when you can
16:04:19 <acozine> hi dmsimard
16:04:23 <acozine> #chair dmsimard
16:04:23 <zodbot> Current chairs: abadger1999 acozine dmsimard felixfontein lmodemal samccann
16:04:36 <acozine> agenda begins with https://github.com/ansible/community/issues/579#issuecomment-776189919
16:05:15 <sommersoft> o/ (dual meeting for me rn; i'll participate as i can)
16:05:27 <acozine> hi sommersoft
16:05:28 <samccann> thanks sommersoft!
16:05:33 * dericcrago waves
16:05:35 <acozine> okay, I won't make you furniture
16:05:42 <acozine> hi dericcrago
16:05:44 <acozine> #chair dericcrago
16:05:44 <zodbot> Current chairs: abadger1999 acozine dericcrago dmsimard felixfontein lmodemal samccann
16:06:22 <acozine> we'll get started, more folks can join us any time
16:06:34 <acozine> #topic Ansible 3 release and docsite split
16:06:50 <acozine> samccann: you want to take this one?
16:06:53 <samccann> sure
16:07:07 <samccann> this is the PR - https://github.com/ansible/ansible/pull/73616 and it's finally working!
16:07:22 * acozine dances a little jig
16:07:43 <samccann> so we need feedback ASAP because we still need to merge this AND backport it AND test it all out so we are ready for I guess a Thursday Ansible 3 release date?
16:08:47 <acozine> the PR has a test failure, any idea what's failing?
16:08:49 <abadger1999> Yeah, that's what I'm planning on (Thu)
16:09:08 <samccann> acozine - matt clay gave me the solution to that failure and it works locally
16:09:12 <felixfontein> acozine: that's caused by the symlinks, see mattclay's comment
16:09:28 <samccann> yeah and the cp instead of ln works... and I now know where to put a minor 'cleanup
16:09:29 <acozine> ah, excellent
16:09:47 <samccann> of the copy so it's not lingering when someone does a git add locally
16:10:29 <samccann> this is the Ansible 3 docs in test BUT it's from /devel/ right now (until we backport) so the user guide etc are devel not 2.10 - http://docs.testing.ansible.com/ansible/3/index.html
16:11:12 <samccann> and this is ansible core docs (note the url difference) - http://docs.testing.ansible.com/ansible-core/devel/
16:11:48 <samccann> so my question is - once I fix the CI problem - can we merge this this afternoon? Are there any other critical folks who need to review?
16:12:48 <felixfontein> not critical, but: "Ansible releases a new major release of Ansible approximately three to four times per year." <--- better change that to twice per year as well :)
16:13:13 <dmsimard> reviewers so far were webknjaz and mattclay ^
16:13:40 <acozine> felixfontein: good catch
16:13:41 <samccann> thanks felixfontein -I'll add that as a comment to the PR so I don't forget.
16:15:03 <felixfontein> IMO it can be merged once sanity tests pass. but then, I don't know the docs build process that well. I guess the main question is: should the nightly devel site build still work with this?
16:15:40 <acozine> dmsimard: abadger1999 has also reviewed the approach, if not officially the PR
16:15:56 <samccann> The nightly devel build will  continue to work, but there is a separate discussion on that that I'd like to cover ...separately ;-)
16:16:25 <acozine> felixfontein: yes, the devel nightly build should continue to work
16:16:28 <samccann> We have build jobs now that will continue to work with the release process for ansible-core, and will allow manual build of Ansible 3 etc
16:16:29 <felixfontein> I'm for merging (once sanity passes), it's the best way to find out what still works afterwards ;)
16:16:35 <samccann> heh
16:16:49 <acozine> hotfix in production? sure, why not . . .
16:16:55 * acozine is kidding
16:17:03 <abadger1999> samccann: Yeah, I think the PR is sound.
16:17:03 <felixfontein> well, it's not really production, it's testing so to say :)
16:17:13 <acozine> yep
16:17:17 <felixfontein> or to-be-production-in-more-than-a-month
16:17:41 <acozine> all right, let's have a vote for the sake of posterity
16:17:42 <samccann> for those who think the PR is good, can I hit you up for an approval later today before we merge?
16:17:43 <felixfontein> the backport will be more critical, but that doesn't need to be merged to build the docsite I guess
16:17:43 <abadger1999> samccann: I think the fix for the CI problem should be to add the files to the ignore list in the test, though.  I can do that now-ish.
16:18:02 <samccann> felixfontein - actually the backport is critical to Ansible 3 release on thurs
16:18:12 <samccann> we have to build the docsite from stable-2.10
16:18:39 <samccann> abadger1999 - I have that in my local branch so I can continue it and commit later
16:18:39 <felixfontein> samccann: can't you also build the docsite from the backport [4~branch, rebased to the latest stable-2.10 branch?
16:18:40 <briantist> hey folks, kinda lurking
16:18:50 <felixfontein> samccann: I would expect that to yield exactly the same result
16:19:07 <acozine> if we can get this merged to devel today, we can have a backport by end of day and should squeak in under the wire
16:19:11 <samccann> felixfontein you mean build Ansible 3 from my private branch with the pr backported?
16:19:11 <lmodemal> Hi briantist
16:19:13 <acozine> briantist: hi! do you want to be furniture?
16:19:18 <briantist> sure why not
16:19:24 <acozine> #chair briantist
16:19:24 <zodbot> Current chairs: abadger1999 acozine briantist dericcrago dmsimard felixfontein lmodemal samccann
16:19:35 <felixfontein> samccann: yep. not the best solution, especially not long-term, but if people are hesitant to merge the backport, it still works
16:19:50 <samccann> acozine - I can't commit to a backport by end of day today. End of day tomorrow, sure. I still worry what might be lingering in stable-2.10 i've not thought of
16:19:58 <felixfontein> samccann: of course getting it merged as well would be better :)
16:20:09 <bcoca> fyi, releases are on hold for now
16:20:10 <acozine> samccann: I would be willing to give the backport a try today
16:20:19 <acozine> bcoca: can you say more about that?
16:20:27 <acozine> which releases? on hold for what? for how long?
16:20:28 <samccann> #info if push come to shove, we can build Ansible 3 from a private branch w/ the pr backported to stable 2.10 (if we can't get reviews in time to merge into stable-2.10)
16:20:47 <felixfontein> bad weather
16:20:49 <acozine> #chair bcoca
16:20:49 <zodbot> Current chairs: abadger1999 acozine bcoca briantist dericcrago dmsimard felixfontein lmodemal samccann
16:20:52 <bcoca> ansible-base/core, cause RE is unavaialble (texas strom/power outage), idk, depends
16:21:13 <felixfontein> (I first thought it was a joke when glancing at the mail, then re-read it...)
16:21:18 <acozine> oof, that's terrible
16:21:29 <felixfontein> Subject: [ansible-devel] Ansible releases delayed due to extreme weather
16:21:54 <lmodemal> oh wow
16:22:11 <samccann> ooch
16:22:22 <acozine> all right, so the part we can control is merging into devel
16:22:51 <samccann> #action - samccann to fix CI errors by using cp instead of ln and finish other feeback so pr can be merged to devel today
16:22:51 <acozine> VOTE: merge PR 73616 as soon as CI is passing
16:23:02 <felixfontein> +1
16:23:03 <acozine> +1
16:23:04 <samccann> oh haha forgot about the vote ...doh
16:23:06 <samccann> +1
16:23:21 <abadger1999> samccann: Err... I have a better way to fix the CI issue, I think.
16:23:28 <lmodemal> +1
16:23:39 <samccann> abadger1999 ok we can discuss offline or after the meeting
16:23:46 <felixfontein> (luckily the vote doesn't depend on how the CI issues are fixed :) )
16:23:51 <samccann> heh true
16:24:00 <abadger1999> +1
16:24:03 <acozine> heh - framing the question is half the battle
16:24:37 <dericcrago> +1
16:24:40 <abadger1999> We should probably ask relrod if we can backport this while the stable-2.10 release is pending.
16:24:51 <abadger1999> (I mean... merge the backport, not prepare the backport PR)
16:24:57 <acozine> (when he gets back from ice-storm isolation)
16:25:28 <samccann> #info - may not be able to merge the backport to stable-2.10 as it is frozen due to pending release
16:25:36 <samccann> (and frozen in more ways than one, eh!)
16:25:38 <acozine> okay, 6 in favor, none opposed
16:25:39 <acozine> heh
16:25:47 <abadger1999> He may have access to slack, I saw him reply to something earlier.  But it could be transitory.
16:26:07 <acozine> any other discussion about this PR, or about handing the split between /ansible/ docs and /ansible-core/ docs?
16:26:18 <samccann> I think with Felix's idea, we can just publish from a branch if need be. I don't want to upset the ansible release applecart
16:26:36 <samccann> We should discuss what /devel/ means and what the nightly jenkins job will produce as a new topic
16:26:53 <acozine> #topic future of `devel` documentation
16:26:53 <felixfontein> yep, it's probably better to only merge the backport after the next ansible-base 2.10.x release has been made
16:27:08 <sommersoft> (now in single-meeting mode; feel free to chair me)
16:27:11 <acozine> yes, these are special circumstances
16:27:13 <felixfontein> I guess we will have /ansible-core/devel/ and /ansible/devel/ from now on?
16:27:17 <acozine> #chair sommersoft
16:27:17 <zodbot> Current chairs: abadger1999 acozine bcoca briantist dericcrago dmsimard felixfontein lmodemal samccann sommersoft
16:27:44 <acozine> my original thought was that `devel` only makes sense for the ansible-core docs
16:27:52 <samccann> ok so let's start with core yeah
16:28:10 <felixfontein> I guess /ansible-core/devel/ is pretty much the content of the devel branch of ansible/ansible
16:28:23 <samccann> so we will have docs.ansible.com/ansible-core/devel but it's not  the full content of devel
16:28:34 <samccann> it will NOT have any of the scenario guides or the network guide
16:28:44 <acozine> the core docs seem straightforward - we continue to publish from the devel branch, daily or more often, when there are changes to that branch
16:28:54 <samccann> as in `make coredocs` is the new command for core, and it doesn't include those guides
16:28:58 <acozine> samccann: I'd vote yes, the scenario guides should really be in collections
16:29:02 <felixfontein> ok, let me rephrase, it is what will eventually be left in the devel branch once the collection-specific stuff found its new home
16:29:30 <samccann> yeah just want to be sure folks realize this, as developers are the ones most likely to notice/care those guides aren't there
16:30:06 <felixfontein> I guess /ansible/devel/ will still have them?
16:30:11 <samccann> #info docs.ansible.com/ansible-core/devel/ will be what the current nightly build produces after  the docsite split. It will not include scenario or network guides
16:30:23 <samccann> that's the next discussion - what do we do w /ansible/devel?
16:30:29 <acozine> felixfontein: that's where it gets murky
16:31:03 <felixfontein> for now, I guess it should essentially stay the same, i.e. be what ansible/3/ looks like with no collections except ansible.builtin
16:31:06 <samccann> so yes, we can easily produce docs off ansible/ansible devel branch and publish them
16:31:12 <acozine> what should /ansible/devel/ contain? does it make sense, given that the list of included collections can change, and the versions of those collections can change?
16:31:22 <felixfontein> and long term it would be nice if it includes the collections included in Ansible, with whatever version
16:31:28 <samccann> if we want no collections, then we'd need a new/different jenkisn build
16:31:53 <samccann> but rather than discuss what we could do - what do we think and Ansible the package 'devel' means?
16:32:01 <acozine> if we could move the scenario & network guides today, would folks still want to publish /ansible/devel/ docs?
16:32:02 <felixfontein> IMO it should include the collections from the latest Ansible release, but with their latest versions (instead of the versions / version restrictions from the latest Ansible release)
16:32:07 <samccann> i mean no one can 'run it from source' so  to speak, can they?
16:32:39 <acozine> felixfontein: even though there's no easy way for users to install that set of collections?
16:32:40 <felixfontein> acozine: move them to where?
16:32:46 <samccann> felixfontein - so all the same collections in Ansible 3, but the collection version is the most recent in galaxy?
16:32:51 <felixfontein> acozine: yes
16:32:52 <acozine> move them to collections
16:32:53 <felixfontein> samccann: yes
16:33:28 <felixfontein> we had a discussion recently in #ansible-community with tadeboro that there are users  that are confused that the collection documentation in /ansible/latest/ is not for the latest collection versions
16:33:50 <acozine> okay, so how often would we publish? daily? weekly? we don't have an easy way (that I know of) to tell when a new version gets uploaded to Galaxy
16:33:53 <samccann> felixfontein - here's my worry - we publish Ansible devel and it picks up THE MOST RECENT collection - say foo version 4.0.0.  But we are already at an Ansible 4 freeze time, and at the freeze time, foo was at version 3.2.1.
16:34:02 <felixfontein> if /ansible/devel/ would have the latest collection docs, I think it would be more helpful - then users can select between "collections included in the latest Ansible release" and "latest versions of the collections that are included in Ansible"
16:34:04 <samccann> We now have a devel, before 4.0 release, that in fact has 5.0 content
16:34:40 <felixfontein> samccann: yep, that's something that can unfortunately happen. though I think it's ok, if you don't assume that devel contains what the next release will contain
16:34:41 <acozine> samccann: that sounds like the way `devel` docs have always functioned
16:34:50 <abadger1999> samccann: Is that the same as the lead up to an ansible-core release , though?  We fork off stable-2.11 for the release and at that point devel is actually for ansible-core-2.12.
16:34:54 <samccann> yeah thinking the same after I typed it
16:34:58 <samccann> :-)
16:35:06 <acozine> the difference now is, folks can't get `devel` by installing from source the way they used to
16:35:12 <felixfontein> resp. it's similar to ansible before: after feature freeze, when branching happened, devel might already have features that will not end up in the next major release from the frozen branch
16:35:13 <samccann> so a friendly banner might solve that
16:35:14 <acozine> at least, it's a lot more challenging to do it
16:35:36 <abadger1999> Ansible as a Service
16:35:36 <samccann> yeah I'm -1 for giving anyone the knowhow to build their own 'devel' Ansible package personally
16:35:45 <bcoca> acozine: tehy can get 'core' devel, just not 'ansible' pypi package equivalent .. can be simluated with the script i posted last week
16:36:16 <felixfontein> they can also use antsibull to build their ansible 'devel' package
16:36:26 <samccann> ok so it sounds to me like there is some consensus that /ansible/devel/ should happen, and should pick up the most recent versions in galaxy that are part of the 'latest Ansible'
16:36:32 <felixfontein> it's not trivial, but also not THAT hard :)
16:36:55 <bcoca> https://github.com/bcoca/acd/blob/devel/generate_acd.yml <= can be made trivial 'run this playbook'
16:37:11 <bcoca> would just need to add 'ansible-galaxy install acd.tgz' at the end
16:37:13 <felixfontein> also AFAIK antsibull has nightlies
16:37:53 <samccann> are we at a point to vote on what we want Ansible/devel/ to be? and we can discuss offline how to make that happen perhaps post Ansible 3 release?
16:38:24 <felixfontein> https://ansible-community.github.io/nightly-builds/
16:38:30 <felixfontein> (no idea whether they work though, never tried :) )
16:39:15 <acozine> VOTE: `/ansible/devel` (Ansible package "devel") docs should include the `devel` branch of core, plus the most recent versions of all collections known to be included in the next package release
16:39:20 <acozine> #chair
16:39:20 <zodbot> Current chairs: abadger1999 acozine bcoca briantist dericcrago dmsimard felixfontein lmodemal samccann sommersoft
16:39:34 <felixfontein> +1
16:39:53 <abadger1999> +1
16:39:54 <briantist> +1
16:39:55 <samccann> hmm
16:40:01 <samccann> i'm having problems w the wording there
16:40:02 <dericcrago> +1
16:40:04 <acozine> (whether we can do this, or how we do this, TBD)
16:40:16 <acozine> samccann: ah, which parts?
16:40:17 <samccann> 'most recent version of collections known to be in the next package'
16:40:33 <samccann> can we actually do that once the next package has a set of collections and versions assigned?
16:40:39 <bcoca> or should it be devel branch of thsoe collections?
16:40:55 <samccann> or maybe there will be a 'data' file that is just collection names, no versions and that's what we use?
16:40:57 <bcoca> samccann: isn't that also a moving target?
16:41:00 <acozine> bcoca: we can't do that, because we pull collections docs from Galaxy, not from git repos
16:41:05 <samccann> getting into implementation I guess
16:41:14 <felixfontein> bcoca: that's also possible, but somewhat more error-prone since they might be broken more often
16:41:32 <bcoca> yes, but that is nature of /devel/
16:41:33 <samccann> yeah I'd say 'most recent version in Galaxy' for sure
16:41:42 <samccann> if it's not in galaxy, it
16:41:46 <samccann> is not in our devel
16:41:47 <bcoca> otherwise i would not put collections in /devel/ since ethey will be 'stable versions'
16:42:27 <felixfontein> I guess the biggest problem is that collection repositories have no common way to say which version they are
16:42:47 <felixfontein> the version in galaxy.yml might not be there, might be the previous release, might be the next release, or something random
16:42:49 <acozine> bcoca: yes, they will be stable, but they may be different from the versions included in the `latest` Ansible package
16:43:30 <bcoca> acozine: normally interest in devel is so people can contribute and/or see the code develop and handle expectations
16:43:31 <felixfontein> right now, community.general on /ansible/latest/ is version 1.3.x, while on devel it would be 2.0.1 (and tomorrow 2.1.0)
16:43:56 <acozine> bcoca: is that a -1 on the goal for /ansible/devel/ docs?
16:44:25 <bcoca> im mostly abstaining, just pointing out something that i dont think was brought up for consideration
16:44:46 <samccann> my nickel - let's get the most recent Galaxy version working in our devel docs
16:44:52 <acozine> gotcha, thanks bcoca
16:44:54 <abadger1999> samccann: Yeah, as an example, I can create ansible-build-data/4/ansible.in right now.  And then that could be the data source for building the /ansible/devel/ docs. (but need to some code to do the right thing)
16:44:59 <sommersoft> abstain for me as well. i only have more questions to offer on this decision. :)
16:45:01 <felixfontein> I guess we can also use prereleases from galaxy for devel - but I wouldn't use git repos, at least not in the beginning
16:45:02 <samccann> then we can see who else is asking for the stuff that is in the github repos
16:45:54 <abadger1999> git repos will not work.
16:46:09 <acozine> collections may be hosted elsewhere (not on github), or even privately
16:46:18 <acozine> collections docs need to come from Galaxy
16:46:34 <samccann> should we info that?
16:46:39 <felixfontein> acozine: we now require public SCMs (though not necessarily git) for collections included in Ansible
16:46:54 <acozine> ah, TIL
16:47:03 <samccann> time check - 45 minutes into the meeting
16:47:27 <felixfontein> (though >99% will probably have regular public github repos)
16:47:38 <abadger1999> theres's not a standard layout for the git repos so we won't have a standard way to figure out where the files we need are in there.  The build steps to turn the git repo into a collection (intermediary before we turn them into docs) is also non-standard
16:47:51 <samccann> should we agree on /devel/ docs will come from latest version in Galaxy for now and move on?
16:47:58 <abadger1999> +1
16:48:02 <felixfontein> +1
16:48:06 <briantist> +1
16:48:08 <acozine> technically, we're still voting
16:48:10 <acozine> +1
16:48:13 <felixfontein> latest version can explicitly include pre-releases
16:48:13 <samccann> +1
16:48:22 <lmodemal> +1
16:48:27 <samccann> whatever is the latest on galaxy, yeah
16:49:28 <acozine> #agreed goal for `/ansible/devel/` docs is to include the `devel` branch of ansible-core, plus the most recent versions in Galaxy of all included collections for the next ansible package release
16:49:44 <samccann> woot!
16:49:53 <felixfontein> just one warning: this will make the devel build process a lot less stable, since galaxy tends to have random timeouts/network errors (as every antsibull-build user knows...)
16:49:55 <bcoca> wont ansible-core/devel/ have the devel branch info?
16:49:59 <bcoca> of ansilbe-core?
16:50:06 <felixfontein> bcoca: I think it will
16:50:06 <samccann> #action - turn nightly build to core docs once PR is merged into devel
16:50:39 <acozine> bcoca: yes, it will
16:50:46 <samccann> should we move onto the docs folder within collections?
16:51:04 <acozine> sure
16:51:10 <acozine> #topic docs folder in collections
16:51:31 <bcoca> soo its going to duplicate the docs?
16:51:51 <bcoca> ^ fyi, having duplicate content normally incurrs in search engine penalties
16:51:54 <acozine> bcoca: yes
16:51:56 <samccann> bcoca - yes. lots of duplication here
16:52:12 <samccann> we will have canonical urls to help with that and working w/ our internal SEO expert
16:52:43 <acozine> the only reason we are publishing core docs separately is that the versions don't match
16:52:45 <samccann> acozine - do you have an update on the folder proposal etc?
16:53:22 <acozine> IIRC we talked last week about using a sub-folder for "things we will publish to docs.ansible.com"
16:53:43 <samccann> was there a link for the proposal? I forget. doh.
16:54:03 <acozine> because some developers want to use markdown instead of rst for their collection docs
16:54:18 <acozine> non-plugin collections docs, I mean
16:54:36 <samccann> yeah if feels like a clean separation - put stuff in this subfolder and we will bring it up to docs.ansible.com.
16:55:37 <samccann> what are our next steps?
16:55:38 * acozine apparently didn't post last week's minutes
16:55:43 <bcoca> what about galaxy/ah ? thought we had plans to also display extended docs on those sites
16:55:55 <samccann> gah!  sorry. I'll go back and dig them up after this (meeting minutes)
16:56:13 <felixfontein> bcoca: galaxy doesn't look like it will implement ANY new feature anytime soon
16:56:31 <samccann> #action samccann - post last week's meeting minutes on the dawgs agenda
16:56:54 <samccann> bcoca - that is part of an internal discussion we need to have, yes.
16:57:12 <samccann> but they can also start pulling thedocs from this new subfolder.
16:57:29 <acozine> bcoca: displaying docs on galaxy would be lovely, but I don't think it's on the short-term roadmap
16:58:07 <samccann> fwiw the internal network team is happy to be the first test case for this.
16:58:09 <bcoca> thought it was on Ah map, i know galaxy/ng trails on that
16:58:29 <samccann> bcoca - we will doublecheck on that, thanks for the reminder
16:58:42 <felixfontein> bcoca: galaxy is not using galaxy-ng, and doesn't look like it will in the near future, so there won't be docs on galaxy
16:58:45 <samccann> #action samccann acozine - find out where  the /docs folder is in AH roadmap etc
16:59:18 <samccann> time-check - at  the 1 hr mark
16:59:26 <tadeboro> AH renders all markdown files in docs folder already. But last time I checked, there were no plans on supporting rST.
16:59:49 <acozine> sorry, I don't think we can make progress on this today beyond samccann's action item
16:59:52 <samccann> tadeboro - if you stumble on an example of that, can you let us know?
16:59:52 <bcoca> felixfontein: there was plan to unify the codebases, as much as 'galaxy' itself wont be updated the point of ng was to migrate to unified base
17:00:25 <felixfontein> bcoca: since galaxy-ng has no support for roles, it doesn't look like that will happen anytime soon
17:00:27 <samccann> acozine - that's fine, at least we know what to do next (get the idea circulated, find out who has other plans for the folder etc)
17:00:34 <acozine> yeah
17:00:42 <tadeboro> samccann: Example of what? (Kids running around, focus bad ;))
17:00:49 <acozine> can we run a few minutes over today?
17:00:50 <felixfontein> (also the amount of public communication on what will happen to roles on galaxy is essentially zero)
17:01:09 <acozine> #chair
17:01:09 <zodbot> Current chairs: abadger1999 acozine bcoca briantist dericcrago dmsimard felixfontein lmodemal samccann sommersoft
17:01:11 <samccann> tadeboro - if you find an AH example collection that is displaying docs on AH from the /docs folder, that would be great to see
17:01:27 <bcoca> iirc it supports README.md but not much more
17:01:29 <acozine> if you need to head out, feel free . . . we're going to run a bit over the hour today
17:01:55 <tadeboro> samccann: Sure. I will post a few screengrabs of you tell me where.
17:02:01 <samccann> yeah I've seen readme.md.  I knew they were 'thinking' about accepting any md in the /docs folder, but haven't seen it in action (haven't looked either)
17:02:20 <samccann> tadeboro - you can post here or a private irc with the collection name. I can go look from there, thanks!
17:02:38 <samccann> acozine - I can stay longer if we have another topic to move to etc
17:02:50 <acozine> #topic PR/issue labels: https://github.com/ansible/ansibullbot/pull/1505
17:02:51 <github-linkbot> https://github.com/ansible/ansibullbot/pull/1505 | open, created 2021-02-06T14:45:20Z by sommersoft: [WIP] Classify/Label PRs That Are Docs Only
17:03:10 <bcoca> samccann:  i still think just saying 'generate the html' and use whatever you want for source woudl be the simplest int he end (then styles/iframes become the fun part)
17:04:16 <acozine> sommersoft opened a PR for the bot to apply the `docs` labels more consistently
17:04:27 <samccann> oo fun!
17:05:30 <sommersoft> indeed! :)
17:05:55 <acozine> we currently have 3 labels: `docs`, `docsite`, and `docsite_pr`, and they are applied inconsistently at best
17:06:16 <sommersoft> one of the pressing questions is highlighted by acozine's comment: what is the appropriate label to have ansibullbot apply. https://github.com/ansible/ansibullbot/pull/1505#issuecomment-776257938
17:06:41 <acozine> yup, what labels do we want? and what should they mean?
17:06:55 <acozine> is it useful to have one that means "the person who opened this used `Edit on GitHub`"?
17:07:23 <acozine> is it useful to have one that means "this PR affects only files in the `docs/docsite/rst` folder"?
17:07:42 <acozine> do we need a third one that means "this PR has both code and documentation"?
17:07:55 <acozine> are there other labels that would be useful?
17:08:18 <samccann> i like the 'edit on github' having its own label -  those should be quick merges and helps us to understand how frequently people use that feature
17:08:46 <samccann> and one that is `docs_only`. Those are the ones we as the writers should be able to keep on top of and merge.
17:09:00 <acozine> theoretically we have that - `docsite_pr` is supposed to mean "opened with `Edit on GitHub`" but I don't know if it's applied consistently (or at all)
17:09:44 <samccann> we should be able to test that by editing and seeing what labels the PR gets
17:10:14 <acozine> true
17:10:36 <acozine> for historical reasons, I don't want to get rid of the `docs` label
17:10:49 <acozine> we've used it to track PR numbers for many years
17:10:51 <samccann> we leave that for what is basically `docs` and code
17:11:08 <sommersoft> i haven't dug into that one much; it's a bit outside of what i've been doing. should be easy enough to verify from a historical and programmatic standpoint
17:11:10 <samccann> ah. So perhaps a docs only pr has both labels then?
17:11:18 <acozine> yeah
17:11:50 <samccann> ok thinking aloud here
17:12:04 <acozine> so `docs` is anything to do with docs, and a subset of those gets `docsite` (ONLY docs), and `docsite_pr` (from Edit on GitHub)
17:12:22 <acozine> so then a PR with `docs` but neither of the others is code-plus-docs
17:12:25 <samccann> if the only reason to keep `docs` for all doc prs is historical - we continue with the stats by using a combination?
17:12:46 <samccann> as in the same stats are the combination of all three labels going forward?
17:13:39 <acozine> I'm guessing it will be easier to code "everything that touches /docs/ gets the `docs` label, stuff that meets these other criteria get other labels added"
17:13:48 <samccann> i personally like the feeling of each label means something different... but .. ya know.. not the hill I'm gonna die on or anything :-)
17:13:58 <sommersoft> note: current application of `docs` also involves the issue/pr templates.
17:14:01 <samccann> ..nor am I doing any of the coding
17:14:18 <acozine> sommersoft: good point
17:14:41 <samccann> sommersoft ah so maybe the easier approach is to leave/let the `docs` label continue to do what it's doing, and add logic to detect 'oh by the way this is ONLY docs so add this new label?
17:15:44 * acozine looks again at PR
17:15:53 <sommersoft> yeah. mkrizek recommended a `docs_only` label. i agree with that, unless one of the current labels' description is updated to mean the same.
17:15:57 <acozine> we can use `docs_only` instead of `docsite`
17:16:13 <acozine> yes, I think `docs_only` is much more readable
17:16:16 <samccann> yeah if docsite has no meaning today, let's replace it with docs_only
17:16:27 <acozine> +1
17:16:31 <tadeboro> samccann: Docs rendered from https://github.com/cyberark/ansible-security-automation-collection/tree/master/docs https://usercontent.irccloud-cdn.com/file/wnCpNFvI/ah-cyberark-pas.png
17:16:50 <samccann> tadeboro++ thanks!
17:17:44 <samccann> #info - example of collection that has docs in docs folder - https://github.com/cyberark/ansible-security-automation-collection/tree/master/docs - this displays today on Automation Hub
17:18:14 <acozine> I can update the labels themselves - remove `docsite`and add `docs_only`, or update the former to be the latter
17:18:48 <acozine> sommersoft: I'll add a comment to the PR when that's done
17:19:02 <sommersoft> removing `docsite` will likely upset ansibullbot without addressing how it interacts with that label.
17:19:04 <samccann> cool
17:19:19 <sommersoft> how it currently*
17:19:24 <samccann> oh heh didn't mean cool about an angry ansibullbot
17:19:32 <sommersoft> :)
17:19:45 <sommersoft> angry bots are def not cool. haha
17:19:47 <acozine> so add `docs_only` then wait until the PR is merged for next steps?
17:19:58 <acozine> heh, do not make the bot angry
17:20:36 <acozine> #agreed acozine to add a `docs_only` label
17:20:46 <sommersoft> acozine: seems like a good approach. i'm on board to address deprecating `docsite` on the bot end. though, will likely drive discussions outside of my purview.
17:21:04 <acozine> yeah, i don't know what happens to old PRs with a label that doesn't exist any more
17:21:13 <acozine> I'll do some digging and see if I can find anything
17:21:26 <acozine> maybe the old label lives on, with a deprecation in its description
17:21:52 <acozine> anything else on labels or the bot?
17:22:04 <acozine> (we're at 20 minutes past our usual time)
17:22:15 <acozine> all right, thanks sommersoft
17:22:19 <acozine> #topic open floor
17:22:39 <acozine> all questions, comments, suggestions, ideas, critiques welcome now
17:22:49 <acozine> if you have a PR or issue you'd like reviewed
17:23:12 <acozine> or need information about contributing to the docs
17:23:18 <acozine> or anything else you'd like to bring up
17:23:24 <acozine> the floor is yours!
17:23:44 <dmsimard> I have just a small PR that should be an easy merge :) https://github.com/ansible/ansible/pull/73615
17:23:45 <github-linkbot> https://github.com/ansible/ansible/pull/73615 | open, created 2021-02-15T17:09:20Z by dmsimard: Update 2.10 porting guide to include module index [affects_2.11,core_review,docs,needs_triage,small_patch,support:core]
17:24:19 <acozine> Looks good, thanks dmsimard
17:25:00 <acozine> merged!
17:25:51 <acozine> anything else on folks' minds?
17:26:21 <acozine> going once . . .
17:26:41 <acozine> going twice . . .
17:27:10 <acozine> thanks abadger1999 bcoca briantist dericcrago dmsimard felixfontein lmodemal samccann sommersoft!
17:27:15 <acozine> see you next week
17:27:18 <acozine> #endmeeting