docs_working_group_aka_dawgs
MINUTES

#ansible-docs: Docs Working Group aka DaWGs

Meeting started by acozine at 16:01:34 UTC (full logs).

Meeting summary

  1. opening chatter (acozine, 16:01:38)
  2. filter/test plugin docs (acozine, 16:09:02)
  3. role argspec update (acozine, 16:13:25)
    1. decided to place the argspec in `meta/main.yml` under the `argument_specs` entry. that was to satisfy a request from felixfontein for future docs reasons. (samccann, 16:14:32)
    2. we have no doc specific requirements spec'd for it at this time, but i would expect that to be filled out after the initial PoC phase. (samccann, 16:14:42)
    3. 2.11 you can expect: 1) validates role args at task execution time from spec in meta/main.yml, 2) ansible-doc support to output role entrypoints and descriptions. (samccann, 16:19:03)
    4. the role arg spec format will be a subset of module arg spec. they will, in fact, share the same code. (samccann, 16:19:26)
    5. ACTION: tadeboro to investigate ways to move forward with role docs as we wait for role argspec validation (acozine, 16:28:59)
    6. removing the "update on role argspec" from the agenda for the next few months, will add it back as a regular item after 2.11 release (acozine, 16:29:33)

  4. template for collection `/docs/` folder (acozine, 16:30:46)
    1. directory: we're going to propose allocating a specific subdirectory in the collection for building docsite content from. Nothing unrelated to the docsite should be placed there. (abadger1999, 16:38:44)
    2. need 'some way' to make labels unique across all the collections (samccann, 16:39:17)
    3. an example of a potential label would be `.. _anscoll_community_crypto_LABEL::` (_anscoll_community_crypto_ is the part that uniquifies the label. (samccann, 16:45:35)
    4. need a way to exclude collections whose docs are bad (for instance, contain conflicting labels) or include the collections that are known good. (abadger1999, 16:49:29)
    5. ACTION: acozine to summarize today's conversation in a proposal or issue (acozine, 17:01:10)
    6. https://github.com/sensu/sensu-go-ansible/blob/master/docs/Makefile.custom is what we do to render things. (tadeboro, 17:04:19)

  5. docs user survey results (acozine, 17:05:32)
    1. 27% said they were "very happy" and another 33% said they were "slightly happy" with the Ansible docs (samccann, 17:07:49)
    2. only 9.6% said they were "very unhappy" (samccann, 17:08:05)
    3. https://stats.eng.ansible.com/apps/docs/docs-survey.html (gwmngilfen, 17:10:02)
    4. raw data from the survey (more insights to come later ) - https://stats.eng.ansible.com/apps/docs/docs-survey.html (samccann, 17:11:25)

  6. open floor (acozine, 17:16:24)
    1. https://github.com/ansible-community/antsibull/pull/231#issuecomment-757371797 (felixfontein, 17:16:48)


Meeting ended at 17:42:40 UTC (full logs).

Action items

  1. tadeboro to investigate ways to move forward with role docs as we wait for role argspec validation
  2. acozine to summarize today's conversation in a proposal or issue


Action items, by person

  1. acozine
    1. acozine to summarize today's conversation in a proposal or issue
  2. tadeboro
    1. tadeboro to investigate ways to move forward with role docs as we wait for role argspec validation


People present (lines said)

  1. acozine (137)
  2. felixfontein (51)
  3. samccann (49)
  4. abadger1999 (32)
  5. tadeboro (18)
  6. gwmngilfen (16)
  7. zodbot (14)
  8. Shrews (8)
  9. bcoca (3)
  10. alongchamps (2)
  11. gundalow (1)
  12. dericcrago (1)


Generated by MeetBot 0.1.4.