documentation_working_group_supplemental_meeting
MINUTES

#ansible-docs: Documentation Working Group supplemental meeting

Meeting started by samccann at 15:31:01 UTC (full logs).

Meeting summary

  1. opening chatter (samccann, 15:31:15)
  2. status update (samccann, 15:36:06)
    1. problem statement - the ansible PyPI package called version 3.0.0 will beta at start of Feb 2021 timeframe and some time after that, the ansible-core PyPI package called version 2.11 will release. We need a way for docs to reflect the two “streams” of versions. Ansible 3.0.0 docs need to reference back to ansible-base 2.10 docs for all Ansible features that are not collections. (samccann, 15:36:18)
    2. proposal docs.ansible.com/ansible becomes Ansible the Package documentation. docs.ansible.com/ansible-core becomes the core only documentation. (samccann, 15:36:32)
    3. current status Reviewing internally to get full buyin from management later this week (samccann, 15:36:50)
    4. Today's meeting goals - implementation - assuming we get approval, how can we accomplish all this in 3 weeks and 2 days (to have a docsite for 3.0.0 beta) (samccann, 15:37:14)
    5. agenda - https://github.com/ansible/community/issues/579#issuecomment-750471248 (samccann, 15:37:36)

  3. what must we accomplish by Feb 2 and what can we push off to a later date (samccann, 15:38:00)
    1. proposal https://hackmd.io/TQmzyhCUSSKa22iFR_079A?both (gundalow, 15:38:34)
    2. AGREED: we need a docsite that reflects Ansible 3.0.0, that doesn't mess up older releases, and that has /devel/ for ansible-core (samccann, 15:41:24)
    3. AGREED: we will not try to unversion any existing docs (aka community/developer guide) by Feb 2. (samccann, 15:53:43)
    4. https://docs.ansible.com/ansible/devel/roadmap/COLLECTIONS_3_0.html that seems to refer to 2.11 (dericcrago, 16:00:23)
    5. If a user installs Ansible 3.x it will never install ansible=core 2.11 (samccann, 16:07:41)
    6. Ansible 4.x would never install core-2.12 either (samccann, 16:09:12)
    7. Docs will reflect what is in Ansible the package and not attempt to match what a user may manually upgrade after that (samccann, 16:14:53)

  4. new repo for new community guides etc (samccann, 16:16:39)
    1. We know there are various gaps in the community documentation, especially around how to look after (maintain, own, manage) Collection & Collection repos. We have a lot of brand new docs to write. Currently we've been using https://github.com/ansible-collections/overview to host some RST. Though this was always viewed as a short term solution (gundalow, 16:18:39)
    2. I wonder if we could start a new top level docsite for these brand new docs (docs.ansible.com/community) (gundalow, 16:19:28)
    3. Example index page https://hackmd.io/uKhHRhFUStG_bVNhY10cLQ#New-Index-structure (gundalow, 16:19:45)

  5. next steps (samccann, 16:36:06)
    1. ACTION: samccann abadger1999 to continue discussing how to build this 3.x docsite from some 2.10 rst files later today (samccann, 16:44:52)

  6. Open Floor (samccann, 16:44:59)


Meeting ended at 16:55:52 UTC (full logs).

Action items

  1. samccann abadger1999 to continue discussing how to build this 3.x docsite from some 2.10 rst files later today


Action items, by person

  1. abadger1999
    1. samccann abadger1999 to continue discussing how to build this 3.x docsite from some 2.10 rst files later today
  2. samccann
    1. samccann abadger1999 to continue discussing how to build this 3.x docsite from some 2.10 rst files later today


People present (lines said)

  1. samccann (121)
  2. abadger1999 (52)
  3. acozine (44)
  4. gundalow (37)
  5. zodbot (11)
  6. dmsimard (10)
  7. dericcrago (7)
  8. bcoca (3)
  9. tadeboro (3)
  10. lmodemal (3)
  11. felixfontein (1)
  12. zbr (1)


Generated by MeetBot 0.1.4.