documentation_working_group_supplemental_-_docsit_split
MINUTES

#ansible-docs: Documentation Working Group supplemental - docsit split

Meeting started by samccann at 15:30:40 UTC (full logs).

Meeting summary

  1. opening chatter (samccann, 15:30:51)
    1. https://github.com/ansible/ansible/pull/72287 (dmsimard, 15:37:24)
    2. here is a WIP for "ansible --version" to display both the ansible-core and ansible versions https://github.com/ansible/ansible/pull/72287 (samccann, 15:37:43)
    3. ACTION: samccann acozine - ask for a way to show the Ansible version along with core version installed (samccann, 15:44:54)
    4. can use a combination of ansible --version (to show core version once the pr is merged) and pip show ansible for the Ansible version (samccann, 15:46:25)
    5. will need a page or paragraph somewhere that says "here's how you tell which versions you have installed" (samccann, 15:48:40)
    6. symlinks likely will be bad for SEO but generating two versions of the docsite from the same sources could work (along with other limitations) (abadger1999, 15:57:16)
    7. Known things that would have to change to maintain good SEO with duplicate content are the /latest/ url and canonical url which is specified in the conf.py (abadger1999, 15:58:08)
    8. AGREED: We will duplicate user guide on Ansible docs and ansible-core docs with appropriate SEO optimizations (samccann, 16:01:10)
    9. ACTION: samccann to ask internal SEO expert how to handle duplicat content - is cannonical url enough? (samccann, 16:01:32)

  2. moving ansible-core docs to a new docsite (samccann, 16:01:48)
    1. ACTION: samccann to discuss ansible-core having its own docsite w/ core team (samccann, 16:05:45)

  3. ansible-core docs with no collection index (samccann, 16:07:51)
    1. while it is not ideal that you can't find anything about networking/cloud/security on the ansible-core docsite, this is an short-term fix until we get to a docsite based on personas and a better way to get between all the information (samccann, 16:13:58)

  4. moving non-plugin collections docs to other repo(s) (samccann, 16:14:53)
    1. see the section here for an overview - https://hackmd.io/iDEyihLqRtWnjtOUd3pNYQ (samccann, 16:15:06)
    2. and see here for some real detail - https://hackmd.io/pPeMLaFYSt2W8RAqm-ZkXA (samccann, 16:15:27)

  5. where do we publish ansible.builtin docs (samccann, 16:16:49)
    1. we need to track ansible version as 3.X since it will be one docset to cover 3.0, 3.1, etc (aka semver) (samccann, 16:36:41)
    2. can we have `ansible-3.x', `ansible-core-3.0`, etc in the version dropdowns so we have one docsite with both sets of info? (samccann, 16:39:27)
    3. ACTION: samccann to create better mockups of separate /ansible/ vs /ansible-core docsites for review (samccann, 17:03:09)
    4. https://docs.ansible.com/ansible/devel/collections/index.html (acozine, 17:10:06)
    5. we will need separate conf.py to do all this... tho might be done w/ builder instead of different repos. Intersphinx might help with M() between the docsites some (samccann, 17:21:31)
    6. need something on ansible-core collection index to say 'go to ansible for much more' (samccann, 17:29:52)
    7. ACTION: acozine to create a PR with a page about "figuring out versions" (acozine, 17:45:02)
    8. ACTION: samccan to hack more mockups, maybe play w/ intersphinx (samccann, 17:46:41)


Meeting ended at 17:48:13 UTC (full logs).

Action items

  1. samccann acozine - ask for a way to show the Ansible version along with core version installed
  2. samccann to ask internal SEO expert how to handle duplicat content - is cannonical url enough?
  3. samccann to discuss ansible-core having its own docsite w/ core team
  4. samccann to create better mockups of separate /ansible/ vs /ansible-core docsites for review
  5. acozine to create a PR with a page about "figuring out versions"
  6. samccan to hack more mockups, maybe play w/ intersphinx


Action items, by person

  1. acozine
    1. samccann acozine - ask for a way to show the Ansible version along with core version installed
    2. acozine to create a PR with a page about "figuring out versions"
  2. samccann
    1. samccann acozine - ask for a way to show the Ansible version along with core version installed
    2. samccann to ask internal SEO expert how to handle duplicat content - is cannonical url enough?
    3. samccann to discuss ansible-core having its own docsite w/ core team
    4. samccann to create better mockups of separate /ansible/ vs /ansible-core docsites for review


People present (lines said)

  1. samccann (180)
  2. acozine (98)
  3. abadger1999 (97)
  4. sivel (66)
  5. felixfontein (44)
  6. zodbot (12)
  7. dmsimard (9)
  8. dericcrago (9)
  9. lmodemal (1)


Generated by MeetBot 0.1.4.