documentation_supplemental_working_group_meeting
MINUTES

#ansible-docs: Documentation Supplemental Working Group Meeting

Meeting started by samccann at 14:42:17 UTC (full logs).

Meeting summary

  1. supporting independent release cycles for ansible-base and ansible in the docs (samccann, 14:44:56)
    1. problem statement - Ansible pypi package called 2.11 will release in jan/feb? and some time after that, ansible-base will release with a version called 2.11 (but a different 2.11) (samccann, 14:50:45)
    2. https://etherpad.opendev.org/p/ansible-documentation-split (samccann, 14:51:47)
    3. we may see more community users installing just `ansible-base` and the selection of collections they are interested in. (samccann, 14:54:47)
    4. possible solution: one publication pipeline takes docs content in each maintained stable branch of `ansible/ansible` and publishes it as docs.ansible.com/ansible-core (or ansible-base . . . exact name TBD); a separate publication pipeline takes docs content from a specific maintained stable branch of `ansible/ansible` and combines it with specific versions of collections and publishes it as docs.ansible.com/ansible (acozine, 15:08:04)
    5. this solution would let us maintain a single source for documentation of core/base features that appears in versioned HTML for both the `ansible` PyPI package and `ansible-core` or ansible-base (acozine, 15:09:21)
    6. we may need to pull the docs publishing files out of ansible/ansible - such as theme, scripts to build config.rst, etc etc. (samccann, 15:22:28)
    7. ansible-base users/developers essentially need everything that doesn't document something that isn't part of ansible-base (i.e. some filters and scenario guides) (samccann, 15:25:15)
    8. https://github.com/ansible/ansible/pull/72476 <= jic someone wants to poke (bcoca, 15:31:31)
    9. The Problem: soon there will be an `ansible` package version 2.11; some time after that there will be an `ansible-base/core/engine` version 2.11; current documentation cannot handle documenting any features that exist in `ansible-base/core/engine` 2.11 but NOT in `ansible` 2.11 (samccann, 15:41:34)
    10. The Opportunity: as we think about how to handle this situation, we can (and should) think about documentation personas - who will be using `ansible` package 2.11, and what do they need? Who will be using `ansible-base/core/engine` 2.11 and what do they need? (samccann, 15:41:53)
    11. AGREED: - next step - take a stab at 2-4 personas and the top 5 tasks we think they need in docs (ignoring current docs). That will help us know if we have a two-way split or more ways to split the current docs (samccann, 15:45:46)
    12. AGREED: we will meet at 10:30am ET on Thursdays to discuss the docs split for a few weeks (samccann, 15:48:28)
    13. https://etherpad.opendev.org/p/ansible-documentation-split is the scratchpad of ideas. Please add your thoughts there as well between meetings (samccann, 15:49:18)
    14. https://hackmd.io/uKhHRhFUStG_bVNhY10cLQ?both (gundalow, 15:50:24)
    15. gundalows scratchpad for personas - https://hackmd.io/uKhHRhFUStG_bVNhY10cLQ?both (samccann, 15:52:27)


Meeting ended at 15:52:36 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. samccann (95)
  2. acozine (79)
  3. felixfontein (25)
  4. gundalow (11)
  5. zodbot (10)
  6. abadger1999 (4)
  7. lmodemal (2)
  8. bcoca (1)


Generated by MeetBot 0.1.4.