docs_working_group_aka_dawgs
MINUTES

#ansible-docs: Docs Working Group aka DaWGs

Meeting started by acozine at 14:34:05 UTC (full logs).

Meeting summary

  1. opening chatter (acozine, 14:34:17)
    1. https://github.com/ansible/community/issues/521#issuecomment-668744313 (acozine, 14:39:21)

  2. Update on latest url (samccann, 14:41:16)
    1. ansible-base 2.10 release happening soon. We'll have changelogs and porting guides for that (samccann, 14:43:43)
    2. we will update the `latest` symlink for the docs only after ansible 2.10 is released (acozine, 14:43:47)
    3. but we won't switch the version switcher to include 2.10, or change the pages that /latest/ refers to until Ansible releases later (samccann, 14:43:54)
    4. Thursday's release of ansible-base should not change the /latest/ url to 2.10 (it should stay 2.9) - if you see problems, please let us know here in irc (samccann, 14:52:30)

  3. FQCN changes and PR 70530 (acozine, 14:52:59)
    1. https://github.com/ansible/ansible/pull/70530 (felixfontein, 14:53:26)
    2. PR is ready to merge (samccann, 14:56:21)
    3. https://github.com/ansible/ansible/pull/71194 humm IBM style guide (baptistemm, 15:03:57)

  4. release and maintenance page (acozine, 15:05:52)
    1. https://docs.ansible.com/ansible/latest/reference_appendices/release_and_maintenance.html (acozine, 15:06:24)
    2. AGREED: - separate ansible-base from Ansible on the release-maintenance page, preferably before Thurs (samccann, 15:11:48)
    3. ACTION: samccann to ask tower folks how they ensured people always looked at the newest version of that release page (samccann, 15:13:11)
    4. ACTION: samccann to create a quick PR to make the release/maintenance page have separate sections for ansible-base vs ansible (samccann, 15:14:21)

  5. updates on porting guide, changelogs, and pipeline (acozine, 15:17:09)
    1. some collections are converting their changelogs to use our tool. We have one request so far for a direct link to a collections changelog due to format requirements unique to that community. (samccann, 15:21:09)
    2. pipeline redirects work starting. We will open an issue 'someplace logical' to explain the strategy of the redirects (samccann, 15:21:51)
    3. this would redirect someone who had a bookmark to /latest/some-module so it goes to /latest/collections/blabla/some-module... and the reverse.. so to speak. See issue when it is created for more details (samccann, 15:22:45)
    4. ACTION: samccann to create a tracking issue for the redirects (samccann, 15:23:03)

  6. priority issues for 2.10 docs (acozine, 15:25:17)
    1. check https://github.com/ansible/ansible/projects/27#column-2809177 for list of priority items we are tracking for Ansible 2.10 release. Let us know if you see something else we need to track (samccann, 15:30:51)
    2. https://github.com/ansible/ansible/issues/59226 is it still accurate ? (baptistemm, 15:31:06)

  7. the Great Issue and PR Autoclose (acozine, 15:33:01)
    1. check your PRs and issues to see if you have any old ones you want to move (acozine, 15:36:24)
    2. use the needs_collection_redirect label to find them (samccann, 15:36:47)
    3. or bot_closed to see what was automatically closed after the bot runs (samccann, 15:37:38)
    4. the bot is starting to work on closing old issues and PRs today (acozine, 15:37:44)

  8. General Status updates (samccann, 15:41:41)
    1. work still going to get the docs to say collections/FQCN where needed. Volunteers most welcome to help out! (samccann, 15:42:13)

  9. Open Floor (samccann, 15:50:00)
    1. Friday of this week is a red hat "recharge day". Most red hat employees will have the day off. (abadger1999, 15:53:05)


Meeting ended at 15:53:34 UTC (full logs).

Action items

  1. samccann to ask tower folks how they ensured people always looked at the newest version of that release page
  2. samccann to create a quick PR to make the release/maintenance page have separate sections for ansible-base vs ansible
  3. samccann to create a tracking issue for the redirects


Action items, by person

  1. samccann
    1. samccann to ask tower folks how they ensured people always looked at the newest version of that release page
    2. samccann to create a quick PR to make the release/maintenance page have separate sections for ansible-base vs ansible
    3. samccann to create a tracking issue for the redirects


People present (lines said)

  1. acozine (94)
  2. samccann (84)
  3. felixfontein (33)
  4. baptistemm (25)
  5. zodbot (13)
  6. abadger1999 (9)
  7. andersson007_ (6)
  8. gundalow (6)
  9. cyberpear (2)
  10. Shrews (2)


Generated by MeetBot 0.1.4.