docs_working_group_aka_dawgs
MINUTES

#ansible-docs: Docs Working Group aka DaWGs

Meeting started by acozine at 14:31:16 UTC (full logs).

Meeting summary

  1. opening chatter (acozine, 14:31:26)
  2. standardize boolean value for module docs examples (samccann, 14:36:44)
    1. https://github.com/ansible/community/issues/521#issuecomment-656833594 (samccann, 14:36:54)
    2. https://github.com/ansible/community/issues/521#issuecomment-656690621 (felixfontein, 14:37:32)
    3. ACTION: samccann to followup w/ acozine on the standardizing of boolean output across ansible docs outputs (samccann, 14:41:56)
    4. yaml 1.1 and 1.2 use true/false the same way... yes/no are strings in yaml1.2 - thus true/false might be the better standard to use (samccann, 14:44:42)

  3. should examples show up before the module options section? (samccann, 14:45:26)
    1. example of a module docs page with examples at the top - https://sensu.github.io/sensu-go-ansible/modules/asset.html (samccann, 14:57:06)
    2. example of a module with a long parameters section and a long examples section - https://docs.ansible.com/ansible/2.10/collections/cisco/iosxr/iosxr_acls_module.html#ansible-collections-cisco-iosxr-iosxr-acls-module (samccann, 15:01:46)
    3. for now, we will keep examples where they are. (samccann, 15:06:44)

  4. Porting guide/changelog updates (samccann, 15:06:58)
    1. ansible changelog now has a new home: https://github.com/ansible-community/ansible-build-data/blob/main/2.10/CHANGELOG-v2.10.rst (samccann, 15:07:55)
    2. PR to move the remaining non-base things from the ansible-base porting guide into the ansible changelog and porting guide: https://github.com/ansible-community/ansible-build-data/pull/22 with one of two PRs in antsibull (samccann, 15:09:41)
    3. PR to rename the ansible-base porting guide to porting_guide_base_2.10.rst, and add an automatically generated ansible 2.10 porting guide: https://github.com/ansible/ansible/pull/70891 (samccann, 15:09:51)
    4. he PR diff shows the manual data extracted from the porting guide: https://github.com/ansible-community/ansible-build-data/pull/22/files (samccann, 15:10:35)
    5. Ansible 2.10.0.a6 released yesterday. matching docs at https://docs.ansible.com/ansible/2.10/index.html (samccann, 15:12:38)
    6. https://github.com/ansible-community/antsibull/issues/161 (felixfontein, 15:13:40)
    7. request to move unchanged sections to the en d - https://github.com/ansible-community/antsibull/issues/161 (samccann, 15:14:31)
    8. ACTION: - all - review the changelogs for any further feedback (samccann, 15:15:18)
    9. once the auto-generated porting guide is in place, we have to do the following steps after every release: 1) generate the latest porting guide, 2) merge it into devel, 3) backport it to stable-2.10, 4) rebuild docs (felixfontein, 15:18:28)
    10. ACTION: relrod to update https://github.com/ansible/community/wiki/RelEng:-ReleaseProcess with appropriate steps to keep autogenerated porting guide in sync with each release for ansible (including minor releases) (samccann, 15:22:02)

  5. docs pipeline updates (samccann, 15:23:52)
    1. https://docs.ansible.com/ansible/2.10/index.html - continue to poke around your fav modules/collections to see how they look (samccann, 15:24:26)
    2. - the ansible docsite will mirror the collection version in the relevant ansible release (samccann, 15:25:52)
    3. if your collection is more recent than what is in ansible, the only way to see collection docs for the version is if you put them in your collection readme as Galaxy does not yet display module docs (samccann, 15:26:55)
    4. ansible docs will be republished with each minor etc release of ansible (samccann, 15:27:20)
    5. work continuing on the redirects from old module pages to new collection-based module pages. (samccann, 15:27:54)
    6. how we handle `devel` docs wrt to collection versions is TBD (samccann, 15:34:19)

  6. Open Floor (samccann, 15:36:04)


Meeting ended at 15:42:26 UTC (full logs).

Action items

  1. samccann to followup w/ acozine on the standardizing of boolean output across ansible docs outputs
  2. - all - review the changelogs for any further feedback
  3. relrod to update https://github.com/ansible/community/wiki/RelEng:-ReleaseProcess with appropriate steps to keep autogenerated porting guide in sync with each release for ansible (including minor releases)


Action items, by person

  1. acozine
    1. samccann to followup w/ acozine on the standardizing of boolean output across ansible docs outputs
  2. samccann
    1. samccann to followup w/ acozine on the standardizing of boolean output across ansible docs outputs
  3. UNASSIGNED
    1. - all - review the changelogs for any further feedback
    2. relrod to update https://github.com/ansible/community/wiki/RelEng:-ReleaseProcess with appropriate steps to keep autogenerated porting guide in sync with each release for ansible (including minor releases)


People present (lines said)

  1. samccann (98)
  2. felixfontein (59)
  3. acozine (26)
  4. baptistemm (20)
  5. abadger1999 (19)
  6. tadeboro (16)
  7. zodbot (11)
  8. andersson007_ (5)
  9. geerlingguy (5)


Generated by MeetBot 0.1.4.