docs_working_group_aka_dawgs
MINUTES

#ansible-docs: Docs Working Group aka DaWGs

Meeting started by acozine at 14:31:37 UTC (full logs).

Meeting summary

  1. opening chatter (acozine, 14:31:47)
    1. https://www.irccloud.com/pastebin/rf8N9AQx/docsite%20repo%20PR%2025 (acozine, 14:39:49)

  2. redirects updates (acozine, 14:40:11)
    1. the current redirects are targeted on urls with `latest` or `devel` that use the old 2.4-style url pattern. This complicates the new collection-based module urls. (samccann, 14:46:53)
    2. the rule basically inserts "modules/" into any URL that ends with `_module.html (samccann, 14:47:15)
    3. consider stub pages such as https://docs.ansible.com/ansible/latest/modules/acme_account_facts_module.html for when modules move between collections. This gives the user the info that they need to change things (samccann, 15:25:22)
    4. AGREED: acozine to investigate whether the docsite repo needs to remain a private repo or not (acozine, 15:30:41)
    5. ACTION: acozine to investigate whether the docsite repo needs to remain private or not (acozine, 15:31:10)
    6. https://github.com/ansible/community/wiki/Docs:Redirects (abadger1999, 15:31:22)
    7. details on the types of redirects we need to consider - https://github.com/ansible/community/wiki/Docs:Redirects (samccann, 15:31:44)

  3. standardizing boolean values (acozine, 15:33:03)
    1. https://github.com/ansible/community/issues/521#issuecomment-656833594 (acozine, 15:33:23)
    2. https://github.com/ansible/community/issues/521#issuecomment-656833594 (samccann, 15:34:03)
    3. ansible.com convertst boolean to yes/now, ansible-doc to true/false - not sure what AH does. And of course the docstrings can be either (samccann, 15:59:18)
    4. consistency may be difficult to achieve (samccann, 15:59:51)
    5. AGREED: we should be consistent in our outputs at least. If we convert to one style (yes/no or true/false) this needs to apply to AH, ansible-doc and docs.ansible.com (samccann, 16:02:34)
    6. ACTION: create a proposal for creating consistency in the boolean values (acozine, 16:19:46)

  4. open floor (acozine, 16:21:06)
  5. open floor (felixfontein, 16:21:06)
  6. changelog output (samccann, 16:22:37)
    1. changelog output now groups by change type (minor, major, etc) and then lists by collection (samccann, 16:25:57)


Meeting ended at 16:28:21 UTC (full logs).

Action items

  1. acozine to investigate whether the docsite repo needs to remain private or not
  2. create a proposal for creating consistency in the boolean values


Action items, by person

  1. acozine
    1. acozine to investigate whether the docsite repo needs to remain private or not


People present (lines said)

  1. acozine (132)
  2. felixfontein (113)
  3. samccann (64)
  4. abadger1999 (19)
  5. zbr (19)
  6. cyberpear (13)
  7. Jmainguy (12)
  8. zodbot (10)
  9. baptistemm (7)
  10. andersson007_ (2)
  11. zbr|ruck (2)
  12. geerlingguy (2)


Generated by MeetBot 0.1.4.