docs_working_group_aka_dawgs
MINUTES

#ansible-docs: Docs Working Group aka DaWGs

Meeting started by acozine at 14:31:04 UTC (full logs).

Meeting summary

  1. intro chatter (acozine, 14:31:10)
    1. https://github.com/ansible/community/issues/521#issuecomment-644857813 (acozine, 14:34:02)

  2. changelogs and porting guides (acozine, 14:36:04)
    1. ACTION: samccann - create PR to bring in `antsibull-changelog` install and how to docs from the repo (samccann, 14:43:38)
    2. ACTION: samccann create a nagogram issue or 3 pointing to that doc, the removed fragments from ansible/ansible and how/why the collection owner(s) need to generate their changelogs for inclusion in the next ansible release (maybe beta??) (samccann, 14:44:39)
    3. https://github.com/ansible/ansible/pull/68565 (acozine, 14:45:07)
    4. https://github.com/ansible/ansible/pull/68498#issuecomment-609404786 and then there's another one (felixfontein, 14:45:41)
    5. sivel used a script to remove most of the changelog fragments from ansible/ansible and it attempted to list potential collections they belong to. Useful for tracking down collection owners that need to bring in those fragments (samccann, 14:45:49)
    6. https://github.com/ansible/ansible/pull/68565 (samccann, 14:46:04)
    7. https://github.com/ansible/ansible/pull/68498#issuecomment-609404786 (samccann, 14:46:15)
    8. https://www.irccloud.com/pastebin/xKfWzj5E/JSON%20output%20for%20changelog%20removals (acozine, 14:47:02)
    9. AGREED: each collection can make its own decision about how much to encourage changelog entries, and we will not require them anywhere (acozine, 15:03:58)
    10. http://www.galactanet.com/comic/view.php?strip=517 (felixfontein, 15:11:28)

  3. docs pipeline (acozine, 15:14:50)
    1. https://github.com/ansible-collections/community.crypto/commit/cc45650e82b769125eb4f6dad5cb5de330be4501 (felixfontein, 15:22:02)
    2. change M() and `seealso:` - for `ansible_base`, change to `ansible.builtin.yum` for example. For a collection, use `<FQCN>.<modulename>` (samccann, 15:23:02)
    3. see https://github.com/ansible-collections/community.crypto/commit/cc45650e82b769125eb4f6dad5cb5de330be4501 for an example (samccann, 15:23:28)
    4. ACTION: document how M() and seealso now work in docstrings and highlight the need to make these changes for collection owners (samccann, 15:24:12)
    5. this is for all occurences of M() and `seealso:` (samccann, 15:25:29)
    6. ACTION: samccann - add details on M() and `seaalso` work to gundalow's magic list of all things that collection owners need to do https://github.com/ansible-collections/overview/issues/45 (samccann, 15:30:34)

  4. https://github.com/bcoca/collection/issues/3 (samccann, 15:36:28)
    1. AGREED: - move bcoca's collection into a formal showcase collection 'somewheres'. It likely needs more content added. (samccann, 15:42:25)
    2. consider if https://github.com/ansible-collections/collection_template needs more to it as well. (samccann, 15:44:40)
    3. https://github.com/ansible-collections/collection_template is what I clone when making new repos, such as community.sops (gundalow, 15:47:06)

  5. open floor (acozine, 15:48:37)
    1. all are welcome, and docs is an easy way to get involved in Ansible. Add agenda items for the next meeting at https://github.com/ansible/community/issues/521 (samccann, 15:51:36)


Meeting ended at 15:52:38 UTC (full logs).

Action items

  1. samccann - create PR to bring in `antsibull-changelog` install and how to docs from the repo
  2. samccann create a nagogram issue or 3 pointing to that doc, the removed fragments from ansible/ansible and how/why the collection owner(s) need to generate their changelogs for inclusion in the next ansible release (maybe beta??)
  3. document how M() and seealso now work in docstrings and highlight the need to make these changes for collection owners
  4. samccann - add details on M() and `seaalso` work to gundalow's magic list of all things that collection owners need to do https://github.com/ansible-collections/overview/issues/45


Action items, by person

  1. gundalow
    1. samccann - add details on M() and `seaalso` work to gundalow's magic list of all things that collection owners need to do https://github.com/ansible-collections/overview/issues/45
  2. samccann
    1. samccann - create PR to bring in `antsibull-changelog` install and how to docs from the repo
    2. samccann create a nagogram issue or 3 pointing to that doc, the removed fragments from ansible/ansible and how/why the collection owner(s) need to generate their changelogs for inclusion in the next ansible release (maybe beta??)
    3. samccann - add details on M() and `seaalso` work to gundalow's magic list of all things that collection owners need to do https://github.com/ansible-collections/overview/issues/45


People present (lines said)

  1. acozine (94)
  2. samccann (78)
  3. felixfontein (65)
  4. abadger1999 (30)
  5. geerlingguy (21)
  6. zodbot (12)
  7. gundalow (5)
  8. bcoca (4)
  9. tributarian (3)
  10. zbr (3)
  11. sivel (2)


Generated by MeetBot 0.1.4.