supplemental_docs_working_group_(dawgs)
MINUTES

#ansible-docs: Supplemental Docs Working Group (DaWGs)

Meeting started by acozine at 15:02:09 UTC (full logs).

Meeting summary

  1. changelogs in collections/ACD (acozine, 15:07:56)
    1. changelogs summary: https://github.com/ansible-collections/overview/issues/18 (acozine, 15:08:42)
    2. some docs for the changelogs - https://github.com/felixfontein/ansibulled/blob/changelog-docs/docs/changelogs.rst (samccann, 15:13:14)
    3. felixfontein Felix Fontein -community.general, community.network, community.crypto and community.internal_test_tools now validate changelog fragments (samccann, 15:14:33)
    4. example of a changelog generator config - community.general: https://github.com/ansible-collections/community.general/blob/master/changelogs/config.yaml (samccann, 15:16:20)
    5. those 4 repos use use this extra sanity test runner: https://github.com/ansible-collections/community.internal_test_tools/tree/master/tools (samccann, 15:17:03)
    6. AGREED: need to move https://github.com/felixfontein/ansibulled/blob/changelog-docs/docs/changelogs.rst into a PR for collections dev guide on docs.ansible.com/ansible (samccann, 15:22:10)
    7. issues with ansibulled as a tool name - can't use ansi<tab> for command completion anymore. but ansible-changelog etc creeps into the tool names that the core team may want to keep control of (samccann, 15:33:54)
    8. ACTION: - think up naming options to replace ansibulled-xxx. ac-xxx is one option but command completion will be important as well as ease of remembering (samccann, 15:44:41)
    9. AGREED: collections tools will be renamed `ac-*` unless we can come up with a more interesting pattern that still preserves autocomplete for the main `ansible` tools (acozine, 15:44:54)
    10. https://github.com/ansible-collections/community.general/blob/master/changelogs/config.yaml (felixfontein, 15:47:44)

  2. porting guides in the collections ecosystem (acozine, 15:50:15)
    1. ACTION: felixfontein will add trivial to the changelog generator (abadger1999, 16:01:31)

  3. open floor (acozine, 16:04:18)


Meeting ended at 16:09:17 UTC (full logs).

Action items

  1. - think up naming options to replace ansibulled-xxx. ac-xxx is one option but command completion will be important as well as ease of remembering
  2. felixfontein will add trivial to the changelog generator


Action items, by person

  1. felixfontein
    1. felixfontein will add trivial to the changelog generator


People present (lines said)

  1. acozine (106)
  2. felixfontein (96)
  3. samccann (51)
  4. abadger1999 (21)
  5. zodbot (9)
  6. bcoca (5)
  7. cbudz (4)
  8. cyberpear (1)


Generated by MeetBot 0.1.4.