docs_working_group_aka_dawgs
MINUTES

#ansible-docs: Docs Working Group aka DaWGs

Meeting started by acozine at 14:31:10 UTC (full logs).

Meeting summary

  1. docs pipeline update (acozine, 14:33:22)
    1. ansible-doc can't solve what the docs pipeline needs so developing a separate parser with a docs schema. See https://gist.github.com/abadger/5d7ad556052758993b3245f9dc14a1d9 for work thus far (samccann, 14:36:05)
    2. this is using pydantic for the schema. fyi docs sanity test uses volumptuous (samccann, 14:38:10)
    3. json schema from this may be helpful in the future for developing stricter testing on the module docs. (samccann, 14:42:33)
    4. this approach would mean we no longer use ansible-doc --json to output docstrings for module/plugin docs (samccann, 14:53:40)
    5. ACTION: abadger1999 to archive ansible-doc cards in the project board (samccann, 14:55:49)
    6. ACTION: samccann to create a 2.11 column for evaluating next steps with this approach (aka integrating the schema json into ansible-test for docs, passing the approach on to AH to consider etc) (samccann, 14:56:46)

  2. https://github.com/ansible/ansible/pull/69268 (acozine, 14:59:29)
  3. version_added in collections (acozine, 15:00:58)
    1. https://github.com/ansible/ansible/pull/69291 (felixfontein, 15:01:18)
    2. https://github.com/ansible/ansible/pull/69291 (samccann, 15:01:49)
    3. problem occurs when a collection includes a doc_fragment from ansible-base. The collection has version_added for collection version, while doc_fragment reflects ansible-base version (samccann, 15:05:31)
    4. https://github.com/ansible/ansible/pull/69291#issuecomment-630409820 contains examples of how this looks with ansible-doc (felixfontein, 15:06:57)
    5. collections will use version_added to reflect collection version. ansible-base use it to reflect ansible-base version. The PR then parses to add 'built in' vs 'collection' to the version number to clarify for users. (and tests collection version # ) (samccann, 15:11:43)
    6. ACTION: samccann to add card to docs pipeline board for future work - consider whether we need version too old back again (samccann, 15:16:08)
    7. specify --collection-version_added for ansible-test sanity to enforce new options get version_added set correclty (samccann, 15:22:03)
    8. how optional should the optional test be and can we turn on the version_added test on ansible-base withought messing up other optional tests? (samccann, 15:56:32)

  4. open floor (acozine, 16:03:07)


Meeting ended at 16:04:48 UTC (full logs).

Action items

  1. abadger1999 to archive ansible-doc cards in the project board
  2. samccann to create a 2.11 column for evaluating next steps with this approach (aka integrating the schema json into ansible-test for docs, passing the approach on to AH to consider etc)
  3. samccann to add card to docs pipeline board for future work - consider whether we need version too old back again


Action items, by person

  1. abadger1999
    1. abadger1999 to archive ansible-doc cards in the project board
  2. samccann
    1. samccann to create a 2.11 column for evaluating next steps with this approach (aka integrating the schema json into ansible-test for docs, passing the approach on to AH to consider etc)
    2. samccann to add card to docs pipeline board for future work - consider whether we need version too old back again


People present (lines said)

  1. felixfontein (131)
  2. acozine (80)
  3. samccann (51)
  4. abadger1999 (42)
  5. mattclay (33)
  6. zodbot (8)
  7. jtanner (3)
  8. cbudz_ (2)


Generated by MeetBot 0.1.4.