docs_working_group_aka_dawgs
MINUTES

#ansible-docs: Docs Working Group aka DaWGs

Meeting started by acozine at 14:31:57 UTC (full logs).

Meeting summary

    1. https://github.com/ansible/community/issues/521#issuecomment-613526358 (acozine, 14:36:01)

  1. changelog mockup (acozine, 14:39:54)
    1. ACD changelog mockup is at https://github.com/samccann/ansible/blob/test-changelog/docs/docsite/rst/changelog_acd.rst (samccann, 14:41:19)
    2. hacked together from a couple of existing collections, based on the ansible/ansible changelog.py script (samccann, 14:41:40)
    3. https://github.com/felixfontein/community.general/blob/changelog-1.0/changelogs/config.yaml (felixfontein, 14:51:16)
    4. the output headings are set in https://github.com/felixfontein/community.general/blob/changelog-1.0/changelogs/config.yaml so we can modify them as needed (samccann, 14:51:39)
    5. the ansible/ansible Major Changes was reserved for core changes. We can reuse that category in collections for 'something else" (samccann, 14:52:08)

  2. changelog generator -wip (samccann, 14:55:56)
    1. felixfontein has a WIP of what the changelog-generator tool might look like at https://github.com/felixfontein/ansible-changelog/ (samccann, 14:56:29)
    2. generated output for `community.general` is at https://github.com/felixfontein/community.general/blob/changelog-1.0/changelogs/CHANGELOG-v1.rst (samccann, 14:57:02)
    3. and in yaml format at - https://github.com/felixfontein/community.general/blob/changelog-1.0/changelogs/changelog.yaml (samccann, 14:57:23)
    4. this WIP creates the same changelog as ansible's tool for 2.9 does and can do changelogs for collections (samccann, 14:57:58)
    5. collection owners who choose not to use the recommended changelog-generator tool would have to convert their output to the yaml file example included above. That is likely what some future ACD changelog tool would look to pull into an ACD changelog (samccann, 15:01:40)
    6. ACTION: need to guestimate what it would take to convert a reno or towncrier changelog.rst into changelog.yaml similar to felixfontein's WIP so that a future ACD changelog-generator could bring it in cleanly. (samccann, 15:08:34)
    7. ACTION: samccann to follow up with dmellado on how to get reno output into this changelog.yaml format (samccann, 15:11:58)

  3. porting guides for ACD and collections (samccann, 15:18:58)
    1. we could potentially use 'major_changes' for porting guide entries in collections (samccann, 15:19:17)
    2. and include removals and deprecations (samccann, 15:19:38)
    3. consider adding 'behavior_changes' to the default config to cover the important changes where a user must do something different when using this new version of a collection/ACD (samccann, 15:31:24)
    4. then 'major_changes` can remain to describe major new features in a collection or ansible-base (samccann, 15:32:00)
    5. module X has this new feature" is a "major change" and "module X now requires parameter Y" is a "behavior change (samccann, 15:32:27)

  4. open floor (acozine, 15:40:50)
    1. agenda items are always welcome, just add a comment to https://github.com/ansible/community/issues/521 (acozine, 15:42:23)


Meeting ended at 15:43:59 UTC (full logs).

Action items

  1. need to guestimate what it would take to convert a reno or towncrier changelog.rst into changelog.yaml similar to felixfontein's WIP so that a future ACD changelog-generator could bring it in cleanly.
  2. samccann to follow up with dmellado on how to get reno output into this changelog.yaml format


Action items, by person

  1. dmellado
    1. samccann to follow up with dmellado on how to get reno output into this changelog.yaml format
  2. felixfontein
    1. need to guestimate what it would take to convert a reno or towncrier changelog.rst into changelog.yaml similar to felixfontein's WIP so that a future ACD changelog-generator could bring it in cleanly.
  3. samccann
    1. samccann to follow up with dmellado on how to get reno output into this changelog.yaml format


People present (lines said)

  1. samccann (78)
  2. acozine (71)
  3. felixfontein (69)
  4. zodbot (8)
  5. dmellado (4)
  6. cbudz (4)
  7. bcoca (1)


Generated by MeetBot 0.1.4.