documentation_working_group_aka_dawgs
MINUTES

#ansible-docs: Documentation Working Group aka DaWGs

Meeting started by acozine at 14:30:53 UTC (full logs).

Meeting summary

    1. https://www.waywordradio.org/us-chickens/ (acozine, 14:36:45)

  1. docs priorities for April (acozine, 14:41:54)
    1. - top priorities - the docs pipeline to get collection module docs into docs.ansible.com, update existing docs to reflect collections, set the strategy for collection/ACD changelogs (samccann, 14:45:33)
    2. following links relate to documentation needs for updates based on collections: (samccann, 14:50:37)
    3. https://github.com/ansible/ansible/issues/67939 (samccann, 14:50:51)
    4. https://github.com/ansible/ansible/issues/68594 (samccann, 14:51:16)
    5. https://github.com/ansible/ansible/issues/67486 (samccann, 14:52:01)
    6. https://github.com/ansible/ansible/issues/67484 (samccann, 14:52:27)
    7. https://github.com/ansible/ansible/issues/67621 (samccann, 14:53:05)
    8. https://github.com/ansible/ansible/issues/67621 (samccann, 14:53:15)
    9. https://github.com/ansible/ansible/issues/60282 (acozine, 14:55:03)
    10. some more docs requests appearing here - https://github.com/ansible-collections/overview/issues (samccann, 14:55:11)
    11. https://github.com/ansible/ansible/issues/60282 (samccann, 14:55:37)
    12. use this to potentially find more - https://github.com/ansible/ansible/issues?q=is%3Aissue+is%3Aopen+label%3Adocs+collection+in%3Atitle (samccann, 14:57:39)
    13. AGREED: find and label docs issues that are for collections with the collection label (samccann, 15:04:54)

  2. follow-up on release notes strategy (acozine, 15:06:51)
    1. https://github.com/ansible-collections/overview/issues/18#issuecomment-608473331 (acozine, 15:07:04)
    2. ACTION: gundalow to ask collection owners to vote on https://github.com/ansible-collections/overview/issues/18#issuecomment-608473331 (samccann, 15:14:43)
    3. ACTION: samccann to post request for comments to reddit on https://github.com/ansible-collections/overview/issues/18#issuecomment-608473331 as well (samccann, 15:15:05)
    4. we will send out a final call to action with a goal to get people to vote on an option for the changelog and make a final decision (samccann, 15:15:44)

  3. provide a way for collection developers to create .rst files from modules?? (acozine, 15:20:25)
    1. details on the original discussion are here - https://github.com/ansible/community/issues/521#issuecomment-606234088 (samccann, 15:22:58)
    2. ACTION: samccann to create issue on ansible/ansible to create a tool/way for collection dev/users to get .rst files from the module docstrings (samccann, 15:29:10)

  4. open floor (acozine, 15:29:41)
    1. agenda items welcome on https://github.com/ansible/community/issues/521 (acozine, 15:32:21)


Meeting ended at 15:33:14 UTC (full logs).

Action items

  1. gundalow to ask collection owners to vote on https://github.com/ansible-collections/overview/issues/18#issuecomment-608473331
  2. samccann to post request for comments to reddit on https://github.com/ansible-collections/overview/issues/18#issuecomment-608473331 as well
  3. samccann to create issue on ansible/ansible to create a tool/way for collection dev/users to get .rst files from the module docstrings


Action items, by person

  1. gundalow
    1. gundalow to ask collection owners to vote on https://github.com/ansible-collections/overview/issues/18#issuecomment-608473331
  2. samccann
    1. samccann to post request for comments to reddit on https://github.com/ansible-collections/overview/issues/18#issuecomment-608473331 as well
    2. samccann to create issue on ansible/ansible to create a tool/way for collection dev/users to get .rst files from the module docstrings


People present (lines said)

  1. acozine (63)
  2. samccann (62)
  3. zodbot (9)
  4. gundalow (7)
  5. felixfontein (6)
  6. bcoca (5)
  7. cbudz (5)


Generated by MeetBot 0.1.4.