dawgs_aka_docs_working_group
MINUTES

#ansible-docs: DaWGs aka Docs Working Group

Meeting started by samccann at 14:31:26 UTC (full logs).

Meeting summary

  1. Filter page docs discussion (samccann, 14:33:53)
    1. https://docs.ansible.com/ansible/latest/user_guide/playbooks_filters.html (samccann, 14:34:09)
    2. filter docs page is too long, bad SEO experience since cannot search on an individual filter, and lacks examples (samccann, 14:40:30)
    3. we could model the filters after the plugins - have a 'main page' that explains in general and then link to each with specific docs/examples (samccann, 14:41:29)
    4. https://docs.ansible.com/ansible/latest/user_guide/playbooks_filters_ipaddr.html (samccann, 14:45:50)
    5. https://github.com/ansible/ansible/pull/46979 (bcoca, 14:50:24)
    6. wip pr adding more examples - #link https://github.com/ansible/ansible/pull/46979 (samccann, 14:51:22)
    7. 'tests' have a similar problem to the filters page (samccann, 14:56:28)
    8. https://docs.ansible.com/ansible/latest/dev_guide/testing/sanity/index.html#all-sanity-tests (acozine, 14:58:18)
    9. AGREED: - consider breaking up the filters page into high level groupings with more examples for each filter type (samccann, 14:58:34)
    10. https://docs.ansible.com/ansible/latest/user_guide/playbooks_tests.html (bcoca, 14:59:05)
    11. https://docs.ansible.com/ansible/latest/user_guide/playbooks_tests.html for jinja2 tests (samccann, 14:59:30)

  2. support elements in return values in documentation (samccann, 15:08:29)
    1. https://github.com/ansible/ansible/pull/62929 for sample PR (samccann, 15:09:01)
    2. AGREED: worth adding support for elements in return value docs (samccann, 15:23:07)

  3. open floor (acozine, 15:24:18)


Meeting ended at 15:31:23 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. acozine (81)
  2. samccann (50)
  3. bcoca (25)
  4. cyberpear (22)
  5. felixfontein (9)
  6. zodbot (8)


Generated by MeetBot 0.1.4.