ansible_community_meeting
LOGS
18:00:16 <felixfontein> #startmeeting Ansible Community Meeting
18:00:16 <zodbot> Meeting started Wed Oct 27 18:00:16 2021 UTC.
18:00:16 <zodbot> This meeting is logged and archived in a public location.
18:00:16 <zodbot> The chair is felixfontein. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
18:00:16 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:16 <zodbot> The meeting name has been set to 'ansible_community_meeting'
18:00:17 <felixfontein> #topic Agenda https://github.com/ansible/community/issues/539
18:00:17 <felixfontein> acozine andersson007_ baptistemm bcoca briantist cyberpear cybette dericcrago dmsimard felixfontein geerlingguy gundalow gwmngilfen ikhan_ jillr jtanner lmodemal misc nitzmahone resmo samccann tadeboro cidrblock thaumos zbr: ping!
18:00:20 <felixfontein> #info Agenda: https://github.com/ansible/community/issues/539 / Topics: https://github.com/ansible-community/community-topics
18:00:26 <jillr> o/
18:00:29 <tadeboro> o/
18:00:33 <felixfontein> #chair jillr tadeboro
18:00:33 <zodbot> Current chairs: felixfontein jillr tadeboro
18:00:37 <felixfontein> #topic Updates
18:00:40 <dmsimard> o/
18:00:42 * dericcrago waves
18:00:53 <andersson007_> o/
18:00:54 <felixfontein> #chair dmsimard dericcrago
18:00:54 <zodbot> Current chairs: dericcrago dmsimard felixfontein jillr tadeboro
18:00:56 <felixfontein> #chair andersson007_[m]
18:00:56 <zodbot> Current chairs: andersson007_[m] dericcrago dmsimard felixfontein jillr tadeboro
18:00:56 <cybette> o/
18:01:02 <felixfontein> #chair andersson007_ cybette
18:01:02 <zodbot> Current chairs: andersson007_ andersson007_[m] cybette dericcrago dmsimard felixfontein jillr tadeboro
18:01:03 <briantist> \o/
18:01:10 <zbr> o/
18:01:10 <felixfontein> #chair briantist
18:01:10 <zodbot> Current chairs: andersson007_ andersson007_[m] briantist cybette dericcrago dmsimard felixfontein jillr tadeboro
18:01:25 <felixfontein> #chair zbr
18:01:25 <zodbot> Current chairs: andersson007_ andersson007_[m] briantist cybette dericcrago dmsimard felixfontein jillr tadeboro zbr
18:01:50 <dmsimard> cybette: do you want to share the survey link as an update ?
18:02:38 <felixfontein> actually I didn't found time to collect any updates (and couldn't find anything when looking quickly now), so if someone else has updates, ... :)
18:03:30 <cybette> #info Please take the Contributor Survey (whether or not you attended the Contributor Summit, we'd love your feedback!) https://www.surveymonkey.co.uk/r/MY2JR9M
18:03:58 <cybette> dmsimard: thanks, you read my mind :)
18:03:59 <dmsimard> #info Bullhorn issue 36 is out: https://bit.ly/thebullhorn36
18:04:26 <gundalow> o/
18:05:00 * cyberpear halfway here
18:05:07 <felixfontein> #chair gundalow cyberpear
18:05:07 <zodbot> Current chairs: andersson007_ andersson007_[m] briantist cyberpear cybette dericcrago dmsimard felixfontein gundalow jillr tadeboro zbr
18:05:10 <dmsimard> #info ansible 5.0.0a3 and 4.8.0 are both scheduled next week
18:05:32 <briantist> hm did I miss the cutoff for the bullhorn?
18:05:34 <felixfontein> #info community.general 4.0.0 is scheduled for next week
18:05:48 <dmsimard> briantist: there's always the next one
18:06:07 <felixfontein> any more updates?
18:06:10 <dmsimard> none from me
18:06:12 <briantist> yeah, I thought I saw somewhere to deadline was tuesday though, and I posted on Monday
18:06:14 <briantist> maybe I misread
18:06:17 <gundalow> briantist: It's every two weeks
18:06:23 <dmsimard> briantist: that's the one from last week
18:06:27 <briantist> ohhhhh
18:06:31 <felixfontein> #topic Meeting time - end of daylight savings
18:06:31 <felixfontein> #info Discussion: https://github.com/ansible-community/community-topics/issues/48
18:07:22 <felixfontein> from the opinions voiced in the issue, 2a = move meeting time to 19:00 UTC on October 31 sounds reasonable
18:07:26 <felixfontein> should we vote on it?
18:07:48 <felixfontein> (we don't have much time for discussion)
18:07:50 * samccann strolls in super late
18:07:55 <felixfontein> #chair samccann
18:07:55 <zodbot> Current chairs: andersson007_ andersson007_[m] briantist cyberpear cybette dericcrago dmsimard felixfontein gundalow jillr samccann tadeboro zbr
18:07:58 <cybette> let's vote
18:08:25 <dmsimard> I'm in the middle between north american west coast and EMEA/APAC so I will settle for whatever folks suit them best
18:08:45 <felixfontein> VOTE: move the community meeting to 19:00 UTC (currently: 18:00 UTC) from next week's meeting on
18:09:12 <andersson007_> +1
18:09:15 <felixfontein> +1
18:09:19 <dmsimard> +0
18:09:27 <tadeboro> +1
18:09:48 <felixfontein> #chair
18:09:48 <zodbot> Current chairs: andersson007_ andersson007_[m] briantist cyberpear cybette dericcrago dmsimard felixfontein gundalow jillr samccann tadeboro zbr
18:09:50 <cybette> +0
18:09:51 <jillr> +0 (I'm in favor of whatever works for the majority of people who care)
18:09:54 <samccann> +1
18:10:05 <dericcrago> +0
18:10:12 <briantist> +0
18:10:45 <zbr> -1
18:11:58 <felixfontein> cyberpear: gundalow:
18:12:41 * acozine just got back from the dentist
18:12:41 <dmsimard> zbr: For context, this is a standing item to resolve at least the next few weeks where timezones are in flux with DST -- I'd like to do a broader survey to see if there are time slots that are earlier in the day that could work as well.
18:12:44 <acozine> what'd I miss?
18:12:52 <felixfontein> #chair acozine
18:12:52 <zodbot> Current chairs: acozine andersson007_ andersson007_[m] briantist cyberpear cybette dericcrago dmsimard felixfontein gundalow jillr samccann tadeboro zbr
18:13:00 <gundalow> +0
18:13:10 <felixfontein> acozine: moving the meeting time to 19:00 UTC (from current 18:00 UTC) starting next week
18:13:14 <acozine> ah, DST
18:13:59 <acozine> +0 to changing, as it does not affect me much
18:14:21 <acozine> +1 to a broader re-visiting of the "when should we meet" question
18:15:01 <remindbot[m]> @cybette:ansible.im cyb-clock chimes every 15 minutes during the community meeting
18:15:03 <felixfontein> ok, so the question of moving has 3 x +1, 3 x 0, 1 x -1 steering committee votes if I counted correctly
18:15:38 <felixfontein> well, I guess we'll meet at 18:00 UTC then next week
18:15:45 <felixfontein> #topic Clarify Python version restriction documentation
18:15:45 <felixfontein> #info Discussion: https://github.com/ansible-community/community-topics/issues/47
18:15:52 <felixfontein> here's another thing to vote on:
18:16:03 <felixfontein> VOTE: merge https://github.com/ansible-community/community-topics/issues/47 as-is
18:16:13 <felixfontein> (since nobody came up with further suggestions, I assume everyone's happy)
18:16:23 <tadeboro> +1
18:16:23 <dmsimard> felixfontein: that's an issue, I guess you meant the PR
18:16:29 <felixfontein> oh
18:16:31 <andersson007_> +1
18:16:37 <felixfontein> VOTE: merge https://github.com/ansible-collections/overview/pull/187 as-is
18:16:37 <github-linkbot> https://github.com/ansible-collections/overview/pull/187 | open, created 2021-10-06T15:58:55Z by felixfontein: Clarify Python version restriction documentation  
18:16:40 <felixfontein> :)
18:16:40 <andersson007_> +1
18:16:42 <tadeboro> +1
18:16:43 <felixfontein> +1
18:16:49 <felixfontein> dmsimard: thanks :)
18:16:57 <briantist> +0
18:17:05 <acozine> +1
18:17:10 <cybette> +1
18:17:15 <dmsimard> +1
18:17:37 <gundalow> +0 (I haven't followed this discussion, so happy to go with others)
18:17:43 <samccann> +1
18:17:55 * jillr reading lastest rev...
18:18:27 <jillr> +1
18:18:51 <felixfontein> #chair
18:18:51 <zodbot> Current chairs: acozine andersson007_ andersson007_[m] briantist cyberpear cybette dericcrago dmsimard felixfontein gundalow jillr samccann tadeboro zbr
18:19:34 <dericcrago> +1
18:20:33 <felixfontein> #agreed merge https://github.com/ansible-collections/overview/pull/187 as-is
18:20:46 <felixfontein> #topic Inclusion candidates for Ansible 5
18:20:46 <felixfontein> #info Discussion: https://github.com/ansible-community/community-topics/issues/32
18:20:52 <felixfontein> I guess this is today's main topic
18:21:08 <felixfontein> according to https://docs.ansible.com/ansible/devel/roadmap/COLLECTIONS_5.html today's the deadline to vote on collection inclusions for Ansible 5
18:21:30 <felixfontein> (unfortunately I was pretty much out of time and didn't manage to do another review :( )
18:21:57 <dmsimard> I got sidetracked and couldn't finish reviewing nautobot before the meeting but I also haven't seen anything that stood out to me as problematic
18:22:12 <felixfontein> I'm actually not sure we have something to vote on today.
18:22:13 <felixfontein> tadeboro:
18:22:44 <tadeboro> As far as I can tell, https://github.com/ansible-collections/ansible-inclusion/discussions/31 is the only one.
18:22:48 <felixfontein> or wait, maybe cisco.ise
18:23:05 <felixfontein> #info Include cisco.ise into Ansible 5
18:23:06 <tadeboro> Than one has 2 thumbs-up reviews, others will have to wait.
18:23:12 <felixfontein> #link Discussion: https://github.com/ansible-collections/ansible-inclusion/discussions/31
18:24:13 <tadeboro> The collection did have some major issue when I reviewed it for the first time, but maintainers did address them.
18:26:34 <acozine> I'm more comfortable voting in favor of a collection that wasn't perfect at first but fixed all the issues, than for one that was perfect at first but the maintainers don't communicate.
18:27:18 <felixfontein> unresponsive/uncommunicative maintainers are usually a bad sign :)
18:27:19 * gundalow agrees with acozine
18:27:25 <briantist> hard agree
18:27:36 <tadeboro> acozine: I feel the same way. My comment was meant as a "they did good".
18:28:01 <felixfontein> I skimmed over the collection, looks good to me
18:28:17 <felixfontein> (i.e. no bad surprises :) )
18:28:21 <jillr> same.  I havent skimmed the code but from that conversation and the checklist it sounds like it's in a good place
18:28:45 <tadeboro> I must admit I refreshed my knowledge of action plugins while reviewing that one. So a win-win situation here ;)
18:28:55 <acozine> heh, nice!
18:28:59 <felixfontein> :)
18:29:10 <felixfontein> should we vote, or does someone wants more time to look at the collection?
18:30:01 <remindbot[m]> @cybette:ansible.im cyb-clock chimes every 15 minutes during the community meeting
18:30:55 <acozine> more time is not going to help me, with weeks of free time I couldn't really review the code - I vote for voting
18:31:17 <dmsimard> the only thing that stands out to me is the relicensing from MIT to GPLv3
18:31:53 <dmsimard> but it doesn't seem like there's a long history or many contributors so it's probably OK
18:32:10 <felixfontein> dmsimard: what's relicensed?
18:32:14 <tadeboro> dmsimard: That collection is mostly action plugins and those need to be GPLv3. Before that chnge, things were actually not OK.
18:32:29 <dmsimard> felixfontein: https://github.com/CiscoISE/ansible-ise/commit/5f636e8f0dd363deab4af88eaa590fc77f385522
18:32:45 <felixfontein> ah, thanks!
18:32:52 <dmsimard> tadeboro: makes sense
18:33:38 <dmsimard> I thought I would mention it since we didn't specifically ask for it in the review, andersson007_ just mentioned it was MIT in his review
18:34:07 <tadeboro> dmsimard: I did ask, but once this was resolved, I updated my review.
18:34:28 <tadeboro> Maybe I should just mark my comments as resoved in the future ...
18:34:35 <felixfontein> VOTE: shall we include cisco.ise in Ansible 5?
18:34:36 <dmsimard> tadeboro: ah, must have missed it
18:34:46 <felixfontein> #chair
18:34:46 <zodbot> Current chairs: acozine andersson007_ andersson007_[m] briantist cyberpear cybette dericcrago dmsimard felixfontein gundalow jillr samccann tadeboro zbr
18:34:52 <tadeboro> +1
18:34:53 <andersson007_> +1
18:34:53 <dmsimard> +1
18:34:56 <felixfontein> +1
18:34:59 <jillr> +1
18:35:01 <acozine> +1
18:35:14 <cybette> +1
18:35:22 <samccann> +1
18:35:56 <gundalow> +1 ( assuming licensing is correct)
18:36:34 <tadeboro> dmsimard: If you go to https://github.com/ansible-collections/ansible-inclusion/discussions/31#discussioncomment-1483963, select edited, and select the last revision from 12 days ago, you will see my licensng comment.
18:37:14 <dmsimard> tadeboro: you're correct, thank you
18:37:34 <tadeboro> gundalow: It should be licensed OK now. And when they changed the license, I did a quick check and it looked like all people involved in that repo were OK with it (they are work for the same company as far as I can tell).
18:37:54 <gundalow> tadeboro: Thanks for clarifying
18:38:11 <andersson007_> tadeboro: thanks
18:38:51 <felixfontein> if nobody else wants to vote...
18:39:08 <felixfontein> #agreed we include cisco.ise in Ansible 5
18:39:12 <felixfontein> thanks everyone!
18:39:15 <tadeboro> I think we have +7, so we shouild be fine.
18:39:21 * tadeboro is too slow ;)
18:39:26 <russoz[m]> o/ morning
18:39:44 <andersson007_> morning russoz[m]
18:39:45 <felixfontein> #chair russoz[m]
18:39:45 <zodbot> Current chairs: acozine andersson007_ andersson007_[m] briantist cyberpear cybette dericcrago dmsimard felixfontein gundalow jillr russoz[m] samccann tadeboro zbr
18:39:48 <felixfontein> morning russoz[m]!
18:40:11 <felixfontein> ok, since we are out of other collections to vote on, I guess this concludes the inclusion of other collections into Ansible 5
18:40:28 <felixfontein> thanks a lot to all reviewers, in particular tadeboro who did most of the work!
18:40:36 <tadeboro> Yep. The rest of them will have to wait for Ansible 6.
18:41:15 <andersson007_> thanks tadeboro !
18:41:34 <dmsimard> hang on
18:41:45 <cybette> thanks tadeboro and all reviewers!
18:41:54 <dmsimard> I think we can afford ourselves a little bit of time to get nautobot in ?
18:43:20 <dmsimard> if all we are missing is an extra review
18:43:22 <felixfontein> technically the deadline for reviews was yesterday, but since we already ignored that...
18:43:55 <felixfontein> it would be good to have two deeper reviews though, and not just one + a cursory one
18:44:11 <felixfontein> and we won't manage much more than a cursory one in the next ~15 minutes I think
18:45:01 <remindbot[m]> @cybette:ansible.im cyb-clock chimes every 15 minutes during the community meeting
18:45:13 <dmsimard> I guess what I'm trying to say is that it's more on us that we couldn't complete the reviews in time than them being late so I would be willing to grant an exception
18:45:31 <tadeboro> I cannot do much there since that collection already has my review. And as felixfontein said, that collection is not the smallest one and it takes some time to get over it.
18:46:01 <tadeboro> dmsimard: The same thing holds for cisco.dnac. We did not review it because no one had a time, so they did not make it.
18:46:07 <jillr> unfortunately I have negative available time right now so I can't take this one  :(
18:46:17 <felixfontein> dmsimard: well, they had outstanding issues ~12 days ago from a review that was several months old, so it's also their fault
18:46:21 <tadeboro> Not sure why nautobot would be treated differenly in this scenario.
18:47:12 <dmsimard> I suppose that's fair
18:47:12 <tadeboro> And we had a disclaimer that we cannot review things 5 minutes before the deadline.
18:47:57 <gundalow> After Ansible 5.0 is out, it might be good to have a retrospective on the inclusion criteria (and how we avoid tadeboro doing all the work)
18:48:10 <jillr> +1
18:48:11 <andersson007_> we should have at least 2 thorough reviews imo
18:48:14 <tadeboro> I am fine with making an exception here, but if we go that way, we should also review cisco.dnac.
18:48:17 <dmsimard> gundalow: I was about to mention that
18:48:30 <jillr> maybe we need something like hackdays where we do collection reviews
18:48:34 <felixfontein> I think the main finding will be 'we have too few reviewers' :)
18:48:41 <jillr> make it a scheduled thing that people commit to
18:48:52 <jillr> which could also be a forum to train up new reviewers
18:49:09 <gundalow> jillr: I like the sound of that
18:49:18 <felixfontein> did we do one for Ansible 5, or was it for Ansible 4? in any case, the last time we did that, there wasn't much to do since most applicants didn't address the comments from the first review
18:49:32 <jillr> felixfontein: that's also a good point
18:49:38 <andersson007_> yeah
18:49:53 <andersson007_> i remember that day:)
18:50:01 <felixfontein> maybe advertising this more clearly would help, like putting a comment in all applications ~two weeks before such a review day that they should better fix as much as possible until then
18:50:21 <felixfontein> andersson007_: me too, though I don't remember anymore when it was... but I think it was for Ansible 4
18:50:30 <andersson007_> same
18:50:32 <gundalow> #info We should do a retrospective on inclusion criteria
18:50:55 <gundalow> #info Possibly ping all open discussions at T-2 weeks
18:51:05 <gundalow> (just so we don't lose these ideas)
18:51:52 <gundalow> #info Possible have inclusion review days (similar to hackdays) were we can also educate & mentor others
18:51:58 <felixfontein> #info Have a collection review day, announce that one at T-2 weeks so hopefully collections will address outstanding issues
18:52:02 <tadeboro> I did a few pings (I think one was cca. 2 weeks before the deadline). And then some maintainers moved a bit, not all in al, not much happened.
18:52:44 <felixfontein> tadeboro: I noticed, I was looking at collections to review some time ago (between your post and last week's meeting) and it turned out most hadn't moved
18:53:16 <felixfontein> ok, let's switch to open floor :)
18:53:20 <felixfontein> #topic Open Floor
18:54:23 <felixfontein> #info Please take a look at https://github.com/ansible-community/community-topics/issues/50 (drop support for Ansible 2.9/-base 2.10) and https://github.com/ansible-community/community-topics/issues/51 (replacement for 'Changes impacting ...' issue) and add your ideas if you haven't done so
18:55:17 <cybette> if we don't move the meeting time next week, do we still try to get another round of votes again next week or just stick to 18:00 UTC?
18:55:39 <felixfontein> that's a very good question
18:56:16 <samccann> fwiw DaWGs plans on moving our meeting starting next week.
18:56:37 <samccann> (in UTC time)
18:56:42 <felixfontein> (reminds me I have to read up the DaWGs minutes...)
18:56:58 <samccann> we assigned everything to you :-)
18:57:02 <samccann> (kidding)
18:57:08 <acozine> heh
18:57:23 <acozine> "DaWGs: be there or end up with all the tickets"
18:57:35 <samccann> u betcha
18:57:35 <tadeboro> I think we should try to start making such decisions in an async fashion. Then we can just count the votes during the meeting and log what we decided in the issue.
18:57:36 <cybette> I think if we tally up the votes in the github issue, most (with a preference ) are for moving to 19:00
18:57:44 <jillr> good deal. it would be an EMEA afternoon on some Thursday in mid Nov
18:57:50 <jillr> eek, sorry mis-channel!
18:58:02 <samccann> heh
18:58:10 <felixfontein> :)
18:58:12 <jillr> -ETOOMANYCHANNELS
18:58:19 <cybette> tadeboro: +1
18:58:27 <tadeboro> jillr: You are two different channels? ;)
18:58:33 <gundalow> YES, Async is the only way this scales
18:58:45 <jillr> tadeboro: I'm in 3 different chat services and an untold number of channels, lol
18:59:14 <gundalow> I'm only in 37 Ansible channels
18:59:39 <felixfontein> that's quite a lot
18:59:44 <samccann> I finally figured out how to change the 'ping' tones for some of my chat clients. Haven't figured out matrix yet tho
19:00:17 <gundalow> Improving async is on the list of goals for my folks, though we need ideas from everybody
19:00:23 <felixfontein> tadeboro: cybette: it probably makes sense to copy the votes from this meeting into the issue then, so that the meeting is also represented
19:00:33 <felixfontein> in any case, one hour's over!
19:00:44 <felixfontein> #endmeeting